summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-01-21 22:50:57 +0100
committerDavid Seifert <soap@gentoo.org>2020-01-21 22:50:57 +0100
commit3077091c6b1e7fe353b0b2b0b176272fe56fad91 (patch)
tree5abc9c3209d176887ef4473e300451d1fe79173d /app-text/texi2html/texi2html-5.0-r1.ebuild
parentapp-text/pspdftool: Port to EAPI 7 (diff)
downloadgentoo-3077091c6b1e7fe353b0b2b0b176272fe56fad91.tar.gz
gentoo-3077091c6b1e7fe353b0b2b0b176272fe56fad91.tar.bz2
gentoo-3077091c6b1e7fe353b0b2b0b176272fe56fad91.zip
app-text/texi2html: Port to EAPI 7
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'app-text/texi2html/texi2html-5.0-r1.ebuild')
-rw-r--r--app-text/texi2html/texi2html-5.0-r1.ebuild30
1 files changed, 16 insertions, 14 deletions
diff --git a/app-text/texi2html/texi2html-5.0-r1.ebuild b/app-text/texi2html/texi2html-5.0-r1.ebuild
index 81ea54fbe106..51e4bdab7d44 100644
--- a/app-text/texi2html/texi2html-5.0-r1.ebuild
+++ b/app-text/texi2html/texi2html-5.0-r1.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
+EAPI=7
inherit prefix
@@ -13,32 +13,34 @@ LICENSE="GPL-2+ || ( GPL-2 CC-BY-SA-1.0 ) Texinfo-manual LGPL-2+ MIT"
SLOT="0"
KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
IUSE="unicode"
+RESTRICT="test" #411523
-RDEPEND=">=dev-lang/perl-5.10.1
- >=dev-perl/libintl-perl-1.200
+RDEPEND="
+ dev-lang/perl
+ dev-perl/libintl-perl
unicode? (
dev-perl/Text-Unidecode
dev-perl/Unicode-EastAsianWidth
- )"
+ )"
DEPEND="${RDEPEND}"
-DOCS="AUTHORS ChangeLog NEWS README TODO"
-
-RESTRICT="test" #411523
-
src_prepare() {
+ default
+
# On FreeBSD this script is used instead of GNU install but it comes without
# executable pemissions... Fix it!
chmod +x install-sh || die
if use prefix; then
- hprefixify $(find . -name '*.pl' | xargs)
+ local f
+ while IFS="" read -d $'\0' -r f ; do
+ hprefixify "${f}"
+ done < <(find . -name '*.pl' -print0)
fi
}
src_configure() {
- local myconf
- use unicode && myconf='--with-external-Unicode-EastAsianWidth'
+ use unicode && local myconf='--with-external-Unicode-EastAsianWidth'
econf \
--with-external-libintl-perl \
@@ -48,9 +50,9 @@ src_configure() {
src_install() {
default
- rm -f "${ED}"/usr/share/${PN}/images/{COPYING*,GPL,README}
+ rm "${ED}"/usr/share/${PN}/images/{COPYING*,GPL,README} || die
}
pkg_preinst() {
- rm -f "${EROOT}"/usr/bin/${PN}
+ rm -f "${EROOT}"/usr/bin/${PN} || die
}