summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-05-17 14:26:47 +0200
committerJeroen Roovers <jer@gentoo.org>2020-05-17 14:27:53 +0200
commit7e549ea5c9ac67bd3d7f0620ed36501a2e1fda44 (patch)
treea86c4b258c7252bc01916e6775d8cefb787bd4ce /app-text/tabler
parentsci-mathematics/wxmaxima: bump to 20.04.0 (diff)
downloadgentoo-7e549ea5c9ac67bd3d7f0620ed36501a2e1fda44.tar.gz
gentoo-7e549ea5c9ac67bd3d7f0620ed36501a2e1fda44.tar.bz2
gentoo-7e549ea5c9ac67bd3d7f0620ed36501a2e1fda44.zip
app-text/tabler: Fix building with CFLAGS=-fno-common
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Closes: https://bugs.gentoo.org/706932 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'app-text/tabler')
-rw-r--r--app-text/tabler/files/tabler-2-fno-common.patch22
-rw-r--r--app-text/tabler/tabler-2-r1.ebuild16
2 files changed, 30 insertions, 8 deletions
diff --git a/app-text/tabler/files/tabler-2-fno-common.patch b/app-text/tabler/files/tabler-2-fno-common.patch
new file mode 100644
index 000000000000..b334880e5ec8
--- /dev/null
+++ b/app-text/tabler/files/tabler-2-fno-common.patch
@@ -0,0 +1,22 @@
+--- a/util.h
++++ b/util.h
+@@ -35,7 +35,7 @@
+ int digits(int n, int base);
+ char *replace_backslashed(char *string);
+
+-char *_strregtok_previous_end;
++extern char *_strregtok_previous_end;
+ char *strregtok(char *string, const regex_t *seperator);
+
+ #endif /* UTIL_H */
+--- a/util.c
++++ b/util.c
+@@ -32,6 +32,8 @@
+ #include "conf.h"
+ #include "util.h"
+
++char *_strregtok_previous_end;
++
+ /* replace_backslashed
+ *
+ * Replaces, within the given string, certain backslashed characters with the
diff --git a/app-text/tabler/tabler-2-r1.ebuild b/app-text/tabler/tabler-2-r1.ebuild
index f727d216278f..e39e7e2835a9 100644
--- a/app-text/tabler/tabler-2-r1.ebuild
+++ b/app-text/tabler/tabler-2-r1.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
DESCRIPTION="A utility to create text art tables from delimited input"
HOMEPAGE="https://sourceforge.net/projects/tabler/"
@@ -10,9 +10,9 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ppc x86"
-IUSE=""
-
-src_install() {
- emake DESTDIR="${D}" install
- dodoc AUTHORS ChangeLog README
-}
+PATCHES=(
+ "${FILESDIR}"/${P}-fno-common.patch
+)
+DOCS=(
+ AUTHORS ChangeLog README
+)