summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/pep/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/pep/files')
-rw-r--r--app-text/pep/files/pep-2.8-gentoo.patch25
-rw-r--r--app-text/pep/files/pep-2.8-include.patch10
2 files changed, 35 insertions, 0 deletions
diff --git a/app-text/pep/files/pep-2.8-gentoo.patch b/app-text/pep/files/pep-2.8-gentoo.patch
new file mode 100644
index 000000000000..8d5c13624d65
--- /dev/null
+++ b/app-text/pep/files/pep-2.8-gentoo.patch
@@ -0,0 +1,25 @@
+--- a/Makefile 1995-08-11 02:00:00.000000000 +0200
++++ b/Makefile 2010-08-26 23:54:34.000000000 +0200
+@@ -66,7 +66,7 @@
+
+ # Unix
+ CC = gcc
+-LFLAGS = -o pep
++LFLAGS = -o pep $(LDFLAGS)
+ SRC = src
+ XXX = c
+ OBJ = o
+@@ -78,10 +78,10 @@
+ UNZIP = unzip
+
+ # directories, etc.
+-BINDIR = /local/bin
+-LIBDIR = /local/share/lib/pep
++BINDIR = /usr/bin
++LIBDIR = /usr/share/pep
+ MANEXT = 1
+-MANDIR = /local/man/man$(MANEXT)
++MANDIR = /usr/share/man/man$(MANEXT)
+ TODAY = 19950811
+ CLOCK = 0200
+ VER = 28
diff --git a/app-text/pep/files/pep-2.8-include.patch b/app-text/pep/files/pep-2.8-include.patch
new file mode 100644
index 000000000000..d70c8dfe35cf
--- /dev/null
+++ b/app-text/pep/files/pep-2.8-include.patch
@@ -0,0 +1,10 @@
+--- a/main.c 1995-08-11 02:00:00.000000000 +0200
++++ b/main.c 2010-08-26 23:57:03.000000000 +0200
+@@ -91,6 +91,7 @@
+
+ #include <stdio.h>
+ #include <stdlib.h>
++#include <unistd.h>
+ #include <string.h>
+ #include <ctype.h>
+ #include "pep.h"