summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2021-11-13 16:24:03 +0100
committerSebastian Pipping <sping@gentoo.org>2021-11-13 16:24:03 +0100
commit1829f0b44ffa8cc28b3fbbe94fa67b36b82553cb (patch)
treef90bd596af19303a64e58162b624c12d347bd2b3 /app-text/nuspell
parentgnome-extra/gnome-tweaks: enable py3.10 (diff)
downloadgentoo-1829f0b44ffa8cc28b3fbbe94fa67b36b82553cb.tar.gz
gentoo-1829f0b44ffa8cc28b3fbbe94fa67b36b82553cb.tar.bz2
gentoo-1829f0b44ffa8cc28b3fbbe94fa67b36b82553cb.zip
app-text/nuspell: 5.0.1
Signed-off-by: Sebastian Pipping <sping@gentoo.org> Package-Manager: Portage-3.0.28, Repoman-3.0.3
Diffstat (limited to 'app-text/nuspell')
-rw-r--r--app-text/nuspell/Manifest1
-rw-r--r--app-text/nuspell/nuspell-5.0.1.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/app-text/nuspell/Manifest b/app-text/nuspell/Manifest
index a3212369e1b7..36441ef368c0 100644
--- a/app-text/nuspell/Manifest
+++ b/app-text/nuspell/Manifest
@@ -4,3 +4,4 @@ DIST nuspell-4.0.1.tar.gz 379342 BLAKE2B be52797ddd737c523a6141fc1c2683690cfcd1a
DIST nuspell-4.1.0.tar.gz 380814 BLAKE2B 500da0797e4f0d1939afd8451b734f309b5c58e66532150614dd3463eda95ab421094e6c0485396b7ef1dd4b7fc03cadf10316d9cfdb1390b2769ddcc963d8b3 SHA512 d0c01dd73fefd8b9c800e6419fe916e55a53b8b19f5848d3766cdcb50383fdcd9e9bb49362b5cea4d9d2d7fda21aed055f28cb47b006e2049b2a904355f7f9ed
DIST nuspell-4.2.0.tar.gz 382635 BLAKE2B cc141e764ce4e649a7a10f213c392973eb98eb21adddc7d2cd46c01f3cc9a6c85432bfb13ce178fba387a01aa1661e7c9b6a4717fca18fb3bfa220732daf53eb SHA512 ae9157e9753868c002ed69a765fb705d29d993f3940e11efbc2699778a8b1abee2eb7daa0ff51187b899d6935a215a24662e5b52ec1ef5c644e90a0245f7583d
DIST nuspell-5.0.0.tar.gz 372940 BLAKE2B 67e3b9b73f79d39c7cdb371ae7699fdaf8323db15dacd17907642f3d799eeb3e3303678d4a9ee4c5a88a5f61d7f1778745590fbac880625dc08c78e94752da6b SHA512 92605c5f0d413b86711fea3b993d656552d5e72440303d3e71907a503d060ead032dfeb0dd8dbb790f35599b8cca8854bdd8650f0560793d9c62a11aebccc2e5
+DIST nuspell-5.0.1.tar.gz 372917 BLAKE2B 30743620035fa49b9d2d190673de1b3de4be0978633eeead1775586c5ab4f0912e4f778867b5839105d1b4f4597e8a2ece33ddbb3290b6447755bfe4a742ea5c SHA512 f883d8c8a3a722a62d411d7b0973dd409c6d09d08ea678c577cef68ec8b5c7e4a4e4cb8a1323e632114414fc17137d1add996a72fbd522ab4de8c6f70fc77073
diff --git a/app-text/nuspell/nuspell-5.0.1.ebuild b/app-text/nuspell/nuspell-5.0.1.ebuild
new file mode 100644
index 000000000000..5645809c40f3
--- /dev/null
+++ b/app-text/nuspell/nuspell-5.0.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Spell checker library and CLI for complex natural languages"
+HOMEPAGE="https://nuspell.github.io/ https://github.com/nuspell/nuspell"
+SRC_URI="https://github.com/nuspell/nuspell/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3+"
+SLOT="0/5" # due to libnuspell.so.5
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND=">=dev-libs/icu-60"
+DEPEND="${RDEPEND}
+ doc? ( app-text/pandoc )
+ test? ( >=dev-cpp/catch-2.3.0:0 )
+ "
+
+DOCS=( CHANGELOG.md )
+
+RESTRICT="!test? ( test )"
+
+src_prepare() {
+ rm -R external/Catch2/ || die
+ if ! use test ; then
+ rm -R external/hunspell/ || die
+ fi
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTING=$(usex test)
+ )
+
+ cmake_src_configure
+}
+
+pkg_postinst() {
+ einfo
+ einfo 'Nuspell needs language packs and/or dictionaries to be of use'
+ einfo 'e.g. package app-dicts/myspell-en or one of its siblings.'
+ einfo
+ einfo 'Besides MySpell dictionaries, for other options please'
+ einfo 'see https://nuspell.github.io/#languages-and-users .'
+ einfo
+}