summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2024-06-14 10:46:02 +0100
committerJames Le Cuirot <chewi@gentoo.org>2024-06-17 10:36:53 +0100
commita72ab1ef2b064157365f39170bb45b0cd1d111d5 (patch)
treece6204e3f4b2135868412ba4f69d85f488eff20e /app-text/mdbook
parentapp-portage/emlop: Use new cargo_target_dir helper (diff)
downloadgentoo-a72ab1ef2b064157365f39170bb45b0cd1d111d5.tar.gz
gentoo-a72ab1ef2b064157365f39170bb45b0cd1d111d5.tar.bz2
gentoo-a72ab1ef2b064157365f39170bb45b0cd1d111d5.zip
app-text/mdbook: Use new cargo_target_dir helper
Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'app-text/mdbook')
-rw-r--r--app-text/mdbook/mdbook-0.4.37.ebuild2
-rw-r--r--app-text/mdbook/mdbook-0.4.40.ebuild2
2 files changed, 2 insertions, 2 deletions
diff --git a/app-text/mdbook/mdbook-0.4.37.ebuild b/app-text/mdbook/mdbook-0.4.37.ebuild
index 2b512da75f1f..2e29e312d40c 100644
--- a/app-text/mdbook/mdbook-0.4.37.ebuild
+++ b/app-text/mdbook/mdbook-0.4.37.ebuild
@@ -269,7 +269,7 @@ src_compile() {
if tc-is-cross-compiler; then
ewarn "html docs were skipped due to cross-compilation"
else
- target/$(usex debug{,} release)/${PN} build -d html guide || die
+ "$(cargo_target_dir)"/${PN} build -d html guide || die
fi
fi
}
diff --git a/app-text/mdbook/mdbook-0.4.40.ebuild b/app-text/mdbook/mdbook-0.4.40.ebuild
index e5e76b2f6ed6..5adbdeee6234 100644
--- a/app-text/mdbook/mdbook-0.4.40.ebuild
+++ b/app-text/mdbook/mdbook-0.4.40.ebuild
@@ -280,7 +280,7 @@ src_compile() {
if tc-is-cross-compiler; then
ewarn "html docs were skipped due to cross-compilation"
else
- target/$(usex debug{,} release)/${PN} build -d html guide || die
+ "$(cargo_target_dir)"/${PN} build -d html guide || die
fi
fi
}