summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/libwpd
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/libwpd')
-rw-r--r--app-text/libwpd/Manifest2
-rw-r--r--app-text/libwpd/libwpd-0.10.0-r1.ebuild56
-rw-r--r--app-text/libwpd/libwpd-0.10.0-r2.ebuild55
-rw-r--r--app-text/libwpd/libwpd-0.10.0.ebuild56
-rw-r--r--app-text/libwpd/libwpd-0.9.9.ebuild56
-rw-r--r--app-text/libwpd/metadata.xml11
6 files changed, 236 insertions, 0 deletions
diff --git a/app-text/libwpd/Manifest b/app-text/libwpd/Manifest
new file mode 100644
index 000000000000..22cd751ae5fa
--- /dev/null
+++ b/app-text/libwpd/Manifest
@@ -0,0 +1,2 @@
+DIST libwpd-0.10.0.tar.xz 506220 SHA256 9d8ba780cb9c0aed7859c59a602138d8ab360b40f6aa655e42f5f769f2cfd32c SHA512 1d1962edd133b72ef835e1c7cf8d856cb959b231811009da14a272f20dc6ad3f9df02424791d26012bf130db05e22fa7862af355ecbaf3be30d9948aa719eba2 WHIRLPOOL 867049ca6128c9182a5df7d39189392618a1d2aae5631e518b6b5a33d6f2b08ddf2ad7b9d5fee8c8bef0edc6a6dae0cb0552475a73bf84db3a9ddeb19ae07449
+DIST libwpd-0.9.9.tar.xz 541608 SHA256 b91df4ca0ef0f456be9531c9ee07cf6a5e50a16b52002abb99e8ebef13fac2b2 SHA512 a71b4990670446270518e1318066e714c02c4a0752fba0be03037ea7bd434c5dd0219d61687448faabf7e31bc40e4e4a9d4b67d01fd362dae96322db513d79ac WHIRLPOOL c51155a0a88047abe856d0a83b05721b1629c4e5c24e68de65905ce8c735fd0144290c2739971d0118dfcf24eff47aea0f6b8b260c7eaa9af2a36cf8325d3c0a
diff --git a/app-text/libwpd/libwpd-0.10.0-r1.ebuild b/app-text/libwpd/libwpd-0.10.0-r1.ebuild
new file mode 100644
index 000000000000..b8ffa626b8d6
--- /dev/null
+++ b/app-text/libwpd/libwpd-0.10.0-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit alternatives eutils
+
+DESCRIPTION="WordPerfect Document import/export library"
+HOMEPAGE="http://libwpd.sf.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz"
+
+LICENSE="|| ( LGPL-2.1 MPL-2.0 )"
+SLOT="0.10"
+KEYWORDS="~alpha amd64 ~arm ~hppa ~mips x86 ~x86-fbsd"
+IUSE="doc test +tools"
+
+RDEPEND="dev-libs/librevenge"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+ test? ( dev-util/cppunit )
+"
+RDEPEND="${RDEPEND}
+ !<app-text/libwpd-0.8.14-r1"
+
+src_configure() {
+ econf \
+ --disable-static \
+ --disable-werror \
+ $(use_with doc docs) \
+ $(use_enable tools) \
+ --docdir="${EPREFIX}"/usr/share/doc/${PF} \
+ --program-suffix=-${SLOT}
+}
+
+src_install() {
+ default
+ prune_libtool_files --all
+}
+
+pkg_postinst() {
+ if use tools; then
+ alternatives_auto_makesym /usr/bin/wpd2html "/usr/bin/wpd2html-[0-9].[0-10]"
+ alternatives_auto_makesym /usr/bin/wpd2raw "/usr/bin/wpd2raw-[0-9].[0-10]"
+ alternatives_auto_makesym /usr/bin/wpd2text "/usr/bin/wpd2text-[0-9].[0-10]"
+ fi
+}
+
+pkg_postrm() {
+ if use tools; then
+ alternatives_auto_makesym /usr/bin/wpd2html "/usr/bin/wpd2html-[0-9].[0-10]"
+ alternatives_auto_makesym /usr/bin/wpd2raw "/usr/bin/wpd2raw-[0-9].[0-10]"
+ alternatives_auto_makesym /usr/bin/wpd2text "/usr/bin/wpd2text-[0-9].[0-10]"
+ fi
+}
diff --git a/app-text/libwpd/libwpd-0.10.0-r2.ebuild b/app-text/libwpd/libwpd-0.10.0-r2.ebuild
new file mode 100644
index 000000000000..ecc9ce00e4aa
--- /dev/null
+++ b/app-text/libwpd/libwpd-0.10.0-r2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit alternatives eutils
+
+DESCRIPTION="WordPerfect Document import/export library"
+HOMEPAGE="http://libwpd.sf.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz"
+
+LICENSE="|| ( LGPL-2.1 MPL-2.0 )"
+SLOT="0.10"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~mips ~x86 ~x86-fbsd"
+IUSE="doc +tools"
+
+COMMON_DEPEND="dev-libs/librevenge"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
+RDEPEND="${COMMON_DEPEND}
+ !<app-text/libwpd-0.8.14-r1"
+
+src_configure() {
+ econf \
+ --disable-static \
+ --disable-werror \
+ $(use_with doc docs) \
+ $(use_enable tools) \
+ --docdir="${EPREFIX}"/usr/share/doc/${PF} \
+ --program-suffix=-${SLOT}
+}
+
+src_install() {
+ default
+ prune_libtool_files --all
+}
+
+pkg_postinst() {
+ if use tools; then
+ alternatives_auto_makesym /usr/bin/wpd2html "/usr/bin/wpd2html-[0-9].[0-9][0-9]"
+ alternatives_auto_makesym /usr/bin/wpd2raw "/usr/bin/wpd2raw-[0-9].[0-9][0-9]"
+ alternatives_auto_makesym /usr/bin/wpd2text "/usr/bin/wpd2text-[0-9].[0-9][0-9]"
+ fi
+}
+
+pkg_postrm() {
+ if use tools; then
+ alternatives_auto_makesym /usr/bin/wpd2html "/usr/bin/wpd2html-[0-9].[0-9][0-9]"
+ alternatives_auto_makesym /usr/bin/wpd2raw "/usr/bin/wpd2raw-[0-9].[0-9][0-9]"
+ alternatives_auto_makesym /usr/bin/wpd2text "/usr/bin/wpd2text-[0-9].[0-9][0-9]"
+ fi
+}
diff --git a/app-text/libwpd/libwpd-0.10.0.ebuild b/app-text/libwpd/libwpd-0.10.0.ebuild
new file mode 100644
index 000000000000..4f56fa069236
--- /dev/null
+++ b/app-text/libwpd/libwpd-0.10.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit alternatives eutils
+
+DESCRIPTION="WordPerfect Document import/export library"
+HOMEPAGE="http://libwpd.sf.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz"
+
+LICENSE="|| ( LGPL-2.1 MPL-2.0 )"
+SLOT="0.10"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~mips ~x86 ~x86-fbsd"
+IUSE="doc test +tools"
+
+RDEPEND="dev-libs/librevenge"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+ test? ( dev-util/cppunit )
+"
+RDEPEND="${RDEPEND}
+ !<app-text/libwpd-0.8.14-r1"
+
+src_configure() {
+ econf \
+ --disable-static \
+ --disable-werror \
+ $(use_with doc docs) \
+ $(use_with tools stream) \
+ --docdir="${EPREFIX}"/usr/share/doc/${PF} \
+ --program-suffix=-${SLOT}
+}
+
+src_install() {
+ default
+ prune_libtool_files --all
+}
+
+pkg_postinst() {
+ if use tools; then
+ alternatives_auto_makesym /usr/bin/wpd2html "/usr/bin/wpd2html-[0-9].[0-10]"
+ alternatives_auto_makesym /usr/bin/wpd2raw "/usr/bin/wpd2raw-[0-9].[0-10]"
+ alternatives_auto_makesym /usr/bin/wpd2text "/usr/bin/wpd2text-[0-9].[0-10]"
+ fi
+}
+
+pkg_postrm() {
+ if use tools; then
+ alternatives_auto_makesym /usr/bin/wpd2html "/usr/bin/wpd2html-[0-9].[0-10]"
+ alternatives_auto_makesym /usr/bin/wpd2raw "/usr/bin/wpd2raw-[0-9].[0-10]"
+ alternatives_auto_makesym /usr/bin/wpd2text "/usr/bin/wpd2text-[0-9].[0-10]"
+ fi
+}
diff --git a/app-text/libwpd/libwpd-0.9.9.ebuild b/app-text/libwpd/libwpd-0.9.9.ebuild
new file mode 100644
index 000000000000..a21e6793e3dd
--- /dev/null
+++ b/app-text/libwpd/libwpd-0.9.9.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit alternatives eutils
+
+DESCRIPTION="WordPerfect Document import/export library"
+HOMEPAGE="http://libwpd.sf.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz"
+
+LICENSE="|| ( LGPL-2.1 MPL-2.0 )"
+SLOT="0.9"
+KEYWORDS="alpha amd64 ~arm hppa ia64 ~mips ppc ppc64 sparc x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc test +tools"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+ test? ( dev-util/cppunit )
+"
+RDEPEND="${RDEPEND}
+ !<app-text/libwpd-0.8.14-r1"
+
+src_configure() {
+ econf \
+ --disable-static \
+ --disable-werror \
+ $(use_with doc docs) \
+ $(use_with tools stream) \
+ --docdir="${EPREFIX}"/usr/share/doc/${PF} \
+ --program-suffix=-${SLOT}
+}
+
+src_install() {
+ default
+ prune_libtool_files --all
+}
+
+pkg_postinst() {
+ if use tools; then
+ alternatives_auto_makesym /usr/bin/wpd2html "/usr/bin/wpd2html-[0-9].[0-9]"
+ alternatives_auto_makesym /usr/bin/wpd2raw "/usr/bin/wpd2raw-[0-9].[0-9]"
+ alternatives_auto_makesym /usr/bin/wpd2text "/usr/bin/wpd2text-[0-9].[0-9]"
+ fi
+}
+
+pkg_postrm() {
+ if use tools; then
+ alternatives_auto_makesym /usr/bin/wpd2html "/usr/bin/wpd2html-[0-9].[0-9]"
+ alternatives_auto_makesym /usr/bin/wpd2raw "/usr/bin/wpd2raw-[0-9].[0-9]"
+ alternatives_auto_makesym /usr/bin/wpd2text "/usr/bin/wpd2text-[0-9].[0-9]"
+ fi
+}
diff --git a/app-text/libwpd/metadata.xml b/app-text/libwpd/metadata.xml
new file mode 100644
index 000000000000..99f70c13b1d1
--- /dev/null
+++ b/app-text/libwpd/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>openoffice</herd>
+ <use>
+ <flag name="tools">Build miscellaneous tools</flag>
+ </use>
+ <upstream>
+ <remote-id type="sourceforge">libwpd</remote-id>
+ </upstream>
+</pkgmetadata>