summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-01-13 18:41:00 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-01-13 21:45:02 +0100
commit517db018c664c25c9a4db3883ef1ec39cc3588dd (patch)
tree8c0b8b36c3224bc25895e101d6c8143d4fa7f3b7 /app-text/libwpd
parentprofiles: arm: Cleanup obsolete entries, add bug reference (diff)
downloadgentoo-517db018c664c25c9a4db3883ef1ec39cc3588dd.tar.gz
gentoo-517db018c664c25c9a4db3883ef1ec39cc3588dd.tar.bz2
gentoo-517db018c664c25c9a4db3883ef1ec39cc3588dd.zip
app-text/libwpd: Fix build with GCC-4.8
Closes: https://bugs.gentoo.org/674402 Package-Manager: Portage-2.3.55, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-text/libwpd')
-rw-r--r--app-text/libwpd/files/libwpd-0.10.3-gcc-4.8.patch16
-rw-r--r--app-text/libwpd/libwpd-0.10.3.ebuild4
2 files changed, 19 insertions, 1 deletions
diff --git a/app-text/libwpd/files/libwpd-0.10.3-gcc-4.8.patch b/app-text/libwpd/files/libwpd-0.10.3-gcc-4.8.patch
new file mode 100644
index 000000000000..f47847c1d212
--- /dev/null
+++ b/app-text/libwpd/files/libwpd-0.10.3-gcc-4.8.patch
@@ -0,0 +1,16 @@
+Authored by: David Tardon David Tardon 2018-12-30
+Commit 333c8a26f231bea26ec3d56245315041bbf5577f
+
+fix build with gcc 4.8
+
+--- a/src/lib/WPXTable.h
++++ b/src/lib/WPXTable.h
+@@ -53,7 +53,7 @@
+ ~WPXTable();
+ void insertRow();
+ void insertCell(unsigned char colSpan, unsigned char rowSpan, unsigned char borderBits);
+- const WPXTableCell *getCell(size_t i, size_t j)
++ const WPXTableCell *getCell(std::size_t i, std::size_t j)
+ {
+ return &(m_tableRows[i])[j];
+ }
diff --git a/app-text/libwpd/libwpd-0.10.3.ebuild b/app-text/libwpd/libwpd-0.10.3.ebuild
index febfff6725bf..469e0bc7eba3 100644
--- a/app-text/libwpd/libwpd-0.10.3.ebuild
+++ b/app-text/libwpd/libwpd-0.10.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -21,6 +21,8 @@ BDEPEND="
doc? ( app-doc/doxygen )
"
+PATCHES=( "${FILESDIR}/${P}-gcc-4.8.patch" )
+
src_configure() {
local myeconfargs=(
--program-suffix=-${SLOT}