summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-07-27 21:08:30 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-07-27 21:14:43 +0200
commit02547555a8e3c64ad858ef75fdfa4d3d511935a0 (patch)
tree7032b17fa289e9c94e831c9fa9283abe631af0c2 /app-text/libmwaw
parentkde-plasma/xembed-sni-proxy: 5.22.4 version bump (diff)
downloadgentoo-02547555a8e3c64ad858ef75fdfa4d3d511935a0.tar.gz
gentoo-02547555a8e3c64ad858ef75fdfa4d3d511935a0.tar.bz2
gentoo-02547555a8e3c64ad858ef75fdfa4d3d511935a0.zip
app-text/libmwaw: EAPI-8 bump
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-text/libmwaw')
-rw-r--r--app-text/libmwaw/libmwaw-9999.ebuild19
1 files changed, 9 insertions, 10 deletions
diff --git a/app-text/libmwaw/libmwaw-9999.ebuild b/app-text/libmwaw/libmwaw-9999.ebuild
index bd259959df53..f0bf404e1fb2 100644
--- a/app-text/libmwaw/libmwaw-9999.ebuild
+++ b/app-text/libmwaw/libmwaw-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-if [[ ${PV} = 9999 ]]; then
+if [[ ${PV} == *9999* ]]; then
EGIT_REPO_URI="https://git.code.sf.net/p/libmwaw/libmwaw"
inherit autotools git-r3
else
@@ -18,27 +18,26 @@ LICENSE="LGPL-2.1"
SLOT="0"
IUSE="doc tools"
-BDEPEND="
- sys-devel/libtool
- virtual/pkgconfig
- doc? ( app-doc/doxygen )
-"
DEPEND="
dev-libs/librevenge
sys-libs/zlib
"
RDEPEND="${DEPEND}"
+BDEPEND="
+ sys-devel/libtool
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
src_prepare() {
default
- [[ ${PV} == 9999 ]] && eautoreconf
+ [[ ${PV} == *9999* ]] && eautoreconf
}
src_configure() {
# zip is hard enabled as the zlib is dep on the rdeps anyway
local myeconfargs=(
--enable-zip
- --disable-static
--disable-werror
$(use_with doc docs)
$(use_enable tools)