summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-07-02 12:12:39 +0200
committerPacho Ramos <pacho@gentoo.org>2016-07-02 12:43:01 +0200
commit6a1950fb1d9251aa59c179a78ed88e6d78e0bbfc (patch)
treea46c3e3349aaf2b70e5fcac13b458b5108a03c32 /app-text/libgxps/libgxps-0.2.4.ebuild
parentapp-text/libgxps: Drop old (diff)
downloadgentoo-6a1950fb1d9251aa59c179a78ed88e6d78e0bbfc.tar.gz
gentoo-6a1950fb1d9251aa59c179a78ed88e6d78e0bbfc.tar.bz2
gentoo-6a1950fb1d9251aa59c179a78ed88e6d78e0bbfc.zip
app-text/libgxps: Version bump
Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'app-text/libgxps/libgxps-0.2.4.ebuild')
-rw-r--r--app-text/libgxps/libgxps-0.2.4.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/app-text/libgxps/libgxps-0.2.4.ebuild b/app-text/libgxps/libgxps-0.2.4.ebuild
new file mode 100644
index 000000000000..697cf562aab9
--- /dev/null
+++ b/app-text/libgxps/libgxps-0.2.4.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2
+
+DESCRIPTION="Library for handling and rendering XPS documents"
+HOMEPAGE="https://wiki.gnome.org/Projects/libgxps"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug +introspection jpeg lcms static-libs tiff"
+
+RDEPEND="
+ >=app-arch/libarchive-2.8
+ >=dev-libs/glib-2.24:2
+ media-libs/freetype:2
+ media-libs/libpng:0
+ >=x11-libs/cairo-1.10[svg]
+ introspection? ( >=dev-libs/gobject-introspection-0.10.1:= )
+ jpeg? ( virtual/jpeg:0 )
+ lcms? ( media-libs/lcms:2 )
+ tiff? ( media-libs/tiff:0[zlib] )
+"
+DEPEND="${RDEPEND}
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt
+ dev-util/gtk-doc-am
+ virtual/pkgconfig
+"
+
+# There is no automatic test suite, only an interactive test application
+RESTRICT="test"
+
+src_configure() {
+ gnome2_src_configure \
+ --enable-man \
+ --disable-test \
+ $(use_enable debug) \
+ $(use_enable introspection) \
+ $(use_with jpeg libjpeg) \
+ $(use_with lcms liblcms2) \
+ $(use_enable static-libs static) \
+ $(use_with tiff libtiff)
+}