summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-12-15 22:55:37 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2017-12-15 23:49:53 +0100
commitf7e469abdab654d02d15f13f938aff04cb5e6aab (patch)
treebe89a535e33e5ebda448635467ab892ac2d78c72 /app-text/libepubgen
parentsys-fs/cryptsetup: Enable argon2 USE flag by default. (diff)
downloadgentoo-f7e469abdab654d02d15f13f938aff04cb5e6aab.tar.gz
gentoo-f7e469abdab654d02d15f13f938aff04cb5e6aab.tar.bz2
gentoo-f7e469abdab654d02d15f13f938aff04cb5e6aab.zip
app-text/libepubgen: 0.1.0 version bump
Package-Manager: Portage-2.3.18, Repoman-2.3.6
Diffstat (limited to 'app-text/libepubgen')
-rw-r--r--app-text/libepubgen/Manifest1
-rw-r--r--app-text/libepubgen/libepubgen-0.1.0.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/app-text/libepubgen/Manifest b/app-text/libepubgen/Manifest
index 67d6216846b4..fd8f6a53b7eb 100644
--- a/app-text/libepubgen/Manifest
+++ b/app-text/libepubgen/Manifest
@@ -1 +1,2 @@
DIST libepubgen-0.0.1.tar.xz 295780 BLAKE2B e0aee4a076d84ffa290b25a357c9cd67df133e6262db750e8e2491b779f1775dcc38013458294492a1f22ce66584becd3a9ced83b44ea47871f9de20cd61166c SHA512 9add9c873ea0ad1b04fcfdfb987c7974b20f7e0c6c6b5a65b6ce5105a85318307fb9871ab60e998da649da378038f6df3722001940d00a7bc88af6dc87bd8945
+DIST libepubgen-0.1.0.tar.xz 319652 BLAKE2B e6573e0a680711380ac3d2ef742413e38030e76dc50639f9659544e7410f7d7f987cdf1aa20cf2f2afa924bbcbecaf7141225d387fc509d0db6387cd144cb16e SHA512 6be431d06321807991048567aebd7111359f8aa364fe33e651c991553f832c03ad3bb3520b9f7e8d72a861a9ebd84483587becb9062e226bcd1d8ade1819b4a9
diff --git a/app-text/libepubgen/libepubgen-0.1.0.ebuild b/app-text/libepubgen/libepubgen-0.1.0.ebuild
new file mode 100644
index 000000000000..508558384209
--- /dev/null
+++ b/app-text/libepubgen/libepubgen-0.1.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="EPUB generator for librevenge"
+HOMEPAGE="https://sourceforge.net/projects/libepubgen/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug doc test"
+
+RDEPEND="
+ dev-libs/librevenge
+"
+DEPEND="${RDEPEND}
+ dev-libs/boost
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
+
+src_configure() {
+ econf \
+ --disable-weffc \
+ --disable-werror \
+ $(use_enable debug) \
+ $(use_with doc docs) \
+ $(use_enable test tests)
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}