summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/jabref-bin
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/jabref-bin')
-rw-r--r--app-text/jabref-bin/Manifest3
-rw-r--r--app-text/jabref-bin/jabref-bin-2.10.ebuild31
-rw-r--r--app-text/jabref-bin/jabref-bin-2.11_beta_rc2.ebuild33
-rw-r--r--app-text/jabref-bin/jabref-bin-2.11_beta_rc3-r1.ebuild36
-rw-r--r--app-text/jabref-bin/jabref-bin-2.11_beta_rc3.ebuild33
-rw-r--r--app-text/jabref-bin/metadata.xml18
6 files changed, 154 insertions, 0 deletions
diff --git a/app-text/jabref-bin/Manifest b/app-text/jabref-bin/Manifest
new file mode 100644
index 000000000000..2c17d03cfcdb
--- /dev/null
+++ b/app-text/jabref-bin/Manifest
@@ -0,0 +1,3 @@
+DIST JabRef-2.10.jar 15223054 SHA256 bb8f001043079bd12f7f8867d725723fca33b03889af864a100d0cf5c4364ce4 SHA512 833ec41bf8d5a76892ec82f0726c5dcf6382de8b05a949b1d697dbdbb79ba727557069f3267827a7febe6ec4ead996c8de273479b8e3d0363467ec6b91e6bd3a WHIRLPOOL a8026762ae934e680f24698e5c658c03a8f6e1c0ec6d48a0ee4b3eaee9ceb93b1831777009627c02f0377333b7f96b34da4e8e36481a859a63bd3d799f5cb03e
+DIST JabRef-2.11b2.jar 15817749 SHA256 f811eb98bdef938c9aaeee5e9807c6ea28a8b4d7270df93cb6ac2cf405dc6f8c SHA512 045f33632f5aa6ef6c61cb8e16dae69f2d91f2b4b85bfce5e51bd9492ad80d41c92b093d8f6b0d67972f18fa787d626b8c6fd419c7cd4cd3249d3e40d7025bf4 WHIRLPOOL 01e9c89b644a110ec2fc1e222ff996f69a0210520cb5c2dc0f7b4c8bb16d91bb4d37358e8e76bd2cfe7630cd664ad925b62c0a46e041da2949c4655b8326250d
+DIST JabRef-2.11b3.jar 16426897 SHA256 251192bc24448886bb62dbc5d01e0c68ee345c45d83fd586db16e5562894fa78 SHA512 93f691928948346f2e3891d5a52be14159b6e0e953897d12a839026ae125bae9c97082bf8f2e160bf20fd42d7e81fa5385114c5e7800e17be07666aa4ec0f7ed WHIRLPOOL ecf0088eb1b30391851a2c30f502b34accd9d4b1e6133f2f06e6e6689160a1dcd74a7f719c3d1e7d8e489f0bcb1f5187a07403d998a0a3256bacf4cbcaa0a2fc
diff --git a/app-text/jabref-bin/jabref-bin-2.10.ebuild b/app-text/jabref-bin/jabref-bin-2.10.ebuild
new file mode 100644
index 000000000000..fed7d625d935
--- /dev/null
+++ b/app-text/jabref-bin/jabref-bin-2.10.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils java-pkg-2
+
+MY_PV_1="${PV/_beta/b}"
+MY_PV="${MY_PV_1/_rc/}"
+
+DESCRIPTION="Java GUI for managing BibTeX and other bibliographies"
+HOMEPAGE="http://jabref.sourceforge.net/"
+SRC_URI="mirror://sourceforge/jabref/JabRef-${MY_PV}.jar"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND=">=virtual/jre-1.6"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ cp -v "${DISTDIR}/${A}" . || die
+}
+
+src_install() {
+ java-pkg_newjar JabRef-${MY_PV}.jar
+ java-pkg_dolauncher ${PN} --jar ${PN}.jar
+}
diff --git a/app-text/jabref-bin/jabref-bin-2.11_beta_rc2.ebuild b/app-text/jabref-bin/jabref-bin-2.11_beta_rc2.ebuild
new file mode 100644
index 000000000000..8c8255d001a5
--- /dev/null
+++ b/app-text/jabref-bin/jabref-bin-2.11_beta_rc2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils java-pkg-2
+
+MY_PV_1="${PV/_beta/b}"
+MY_PV="${MY_PV_1/_rc/}"
+MY_URI_PV_1="${PV/rc/}"
+MY_URI_PV="${MY_URI_PV_1//_/%20}"
+
+DESCRIPTION="Java GUI for managing BibTeX and other bibliographies"
+HOMEPAGE="http://jabref.sourceforge.net/"
+SRC_URI="mirror://sourceforge/jabref/JabRef-${MY_PV}.jar"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND=">=virtual/jre-1.6"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ cp -v "${DISTDIR}/${A}" . || die
+}
+
+src_install() {
+ java-pkg_newjar JabRef-${MY_PV}.jar
+ java-pkg_dolauncher ${PN} --jar ${PN}.jar
+}
diff --git a/app-text/jabref-bin/jabref-bin-2.11_beta_rc3-r1.ebuild b/app-text/jabref-bin/jabref-bin-2.11_beta_rc3-r1.ebuild
new file mode 100644
index 000000000000..e8d6f3380e76
--- /dev/null
+++ b/app-text/jabref-bin/jabref-bin-2.11_beta_rc3-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils java-pkg-2
+
+MY_PV_1="${PV/_beta/b}"
+MY_PV="${MY_PV_1/_rc/}"
+MY_URI_PV_1="${PV/rc/}"
+MY_URI_PV="${MY_URI_PV_1//_/%20}"
+
+DESCRIPTION="Java GUI for managing BibTeX and other bibliographies"
+HOMEPAGE="http://jabref.sourceforge.net/"
+SRC_URI="mirror://sourceforge/jabref/JabRef-${MY_PV}.jar"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND=">=virtual/jre-1.6"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ cp -v "${DISTDIR}/${A}" . || die
+ jar xf ${A} images/JabRef-icon-48.png || die
+}
+
+src_install() {
+ java-pkg_newjar JabRef-${MY_PV}.jar
+ java-pkg_dolauncher ${PN} --jar ${PN}.jar
+ newicon images/JabRef-icon-48.png JabRef-bin-icon.png
+ make_desktop_entry ${PN} JabRef-bin JabRef-bin-icon Office
+}
diff --git a/app-text/jabref-bin/jabref-bin-2.11_beta_rc3.ebuild b/app-text/jabref-bin/jabref-bin-2.11_beta_rc3.ebuild
new file mode 100644
index 000000000000..8c8255d001a5
--- /dev/null
+++ b/app-text/jabref-bin/jabref-bin-2.11_beta_rc3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils java-pkg-2
+
+MY_PV_1="${PV/_beta/b}"
+MY_PV="${MY_PV_1/_rc/}"
+MY_URI_PV_1="${PV/rc/}"
+MY_URI_PV="${MY_URI_PV_1//_/%20}"
+
+DESCRIPTION="Java GUI for managing BibTeX and other bibliographies"
+HOMEPAGE="http://jabref.sourceforge.net/"
+SRC_URI="mirror://sourceforge/jabref/JabRef-${MY_PV}.jar"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND=">=virtual/jre-1.6"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ cp -v "${DISTDIR}/${A}" . || die
+}
+
+src_install() {
+ java-pkg_newjar JabRef-${MY_PV}.jar
+ java-pkg_dolauncher ${PN} --jar ${PN}.jar
+}
diff --git a/app-text/jabref-bin/metadata.xml b/app-text/jabref-bin/metadata.xml
new file mode 100644
index 000000000000..ac4685933be7
--- /dev/null
+++ b/app-text/jabref-bin/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+ <herd>sci</herd>
+ <maintainer>
+ <email>nicolasbock@gentoo.org</email>
+ <name>Nicolas Bock</name>
+ </maintainer>
+ <longdescription lang="en">
+ JabRef is an open source bibliography reference manager. The native
+ file format used by JabRef is BibTeX, the standard LaTeX bibliography
+ format.
+ </longdescription>
+ <upstream>
+ <remote-id type="sourceforge">jabref</remote-id>
+ </upstream>
+</pkgmetadata>