summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/hnb
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/hnb')
-rw-r--r--app-text/hnb/Manifest1
-rw-r--r--app-text/hnb/files/hnb-1.9.18-flags.patch83
-rw-r--r--app-text/hnb/files/hnb-1.9.18-include.patch13
-rw-r--r--app-text/hnb/files/hnb-1.9.18-printf.patch11
-rw-r--r--app-text/hnb/hnb-1.9.18-r1.ebuild41
-rw-r--r--app-text/hnb/metadata.xml13
6 files changed, 162 insertions, 0 deletions
diff --git a/app-text/hnb/Manifest b/app-text/hnb/Manifest
new file mode 100644
index 000000000000..cd42b75ebce4
--- /dev/null
+++ b/app-text/hnb/Manifest
@@ -0,0 +1 @@
+DIST hnb-1.9.18.tar.gz 166043 SHA256 b9a1e567d904dc9d3eb262e4f6fd46a4494339452333c35d77e154c7b0d5031f SHA512 9919a5d6512b6da3d19cc8efbed21d4452a2f6a343a38758c36728f73415b6e8ad57e24ff3eec17eb4e1e53b458d579c165ae1ad906f5b75f2fd42897159a30f WHIRLPOOL 713bb592a3122e7fcaad0a6378134dbf6055d41004020bef4ddff0d1ac59ff596337b41b54792726cb170c8155ac4bf2ce4e9d0ebddb1ea5f403c0802e45330e
diff --git a/app-text/hnb/files/hnb-1.9.18-flags.patch b/app-text/hnb/files/hnb-1.9.18-flags.patch
new file mode 100644
index 000000000000..4111b7078d70
--- /dev/null
+++ b/app-text/hnb/files/hnb-1.9.18-flags.patch
@@ -0,0 +1,83 @@
+--- a/Makefile
++++ b/Makefile
+@@ -1,19 +1,19 @@
+
+ src/hnb: src/*.c src/*.h src/*.inc src/hnbrc.inc
+- (cd src;make)
++ (cd src;$(MAKE))
+ install: src/hnb
+ install -D src/hnb /usr/local/bin/hnb
+ install -D -m444 doc/hnb.1 /usr/local/man/man1/hnb.1
+ clean:
+- (cd src;make clean)
+- (cd util;make clean)
++ (cd src;$(MAKE) clean)
++ (cd util;$(MAKE) clean)
+ rm -f *~
+
+ rcupdate: updaterc
+ updaterc: src/hnbrc.inc
+
+ src/hnbrc.inc: doc/hnbrc
+- (cd util;make)
++ (cd util;$(MAKE))
+ echo -n "\"">src/hnbrc.inc
+ cat doc/hnbrc | util/asc2c >> src/hnbrc.inc
+ echo "\"">>src/hnbrc.inc
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -1,5 +1,6 @@
+-LIBS=-lncurses libcli/libcli.a
+-CFLAGS=-I.. -Ilibcli -DHAVE_CONFIG_H -Wall -pedantic -g
++LIBS=$(shell ${PKG_CONFIG} --libs ncurses) libcli/libcli.a
++CFLAGS+=-Wall -pedantic
++CPPFLAGS+=-I.. -Ilibcli -DHAVE_CONFIG_H
+
+ CFILES=$(wildcard *.c)
+ OBJS=$(patsubst %.c,%.o,$(CFILES))
+@@ -8,22 +9,22 @@
+ $(CC) -c $(CFLAGS) $(CPPFLAGS) -o $@ $<
+
+ hnb: libcli/libcli.a Makefile $(OBJS) init_subsystems.c *.h *.inc
+- $(CC) -o hnb $(OBJS) $(LIBS) $(CFLAGS)
++ $(CC) -o hnb $(OBJS) $(LIBS) $(CFLAGS) $(LDFLAGS)
+ # strip hnb
+ libcli/libcli.a: libcli/*.c
+- (cd libcli;make libcli.a)
++ (cd libcli;$(MAKE) libcli.a)
+ libcli/libcli_p.a: libcli/*.c
+- (cd libcli;make libcli_p.a)
+-init_subsystems.c: *.c
++ (cd libcli;$(MAKE) libcli_p.a)
++init_subsystems.c: $(CFILES)
+ echo "/* this file is autogenerated, do not edit */">init_subsystems.c
+- cat *.c | grep "^\!init_" | sort | sed -e "s/^\!/void /g">>init_subsystems.c
++ cat $(CFILES) | grep "^\!init_" | sort | sed -e "s/^\!/void /g">>init_subsystems.c
+ echo "">>init_subsystems.c
+ echo "void init_subsystems(){">>init_subsystems.c
+- cat *.c | grep "^\!init_" | sort | sed -e "s/^\!/ /g">>init_subsystems.c
++ cat $(CFILES) | grep "^\!init_" | sort | sed -e "s/^\!/ /g">>init_subsystems.c
+ echo "}">>init_subsystems.c
+ clean:
+ rm -f xml_debug hnb $(OBJS) *~ cli_*.inc
+- (cd libcli;make clean)
++ (cd libcli;$(MAKE) clean)
+ hnb_p: *.c libcli/libcli_p.a init_subsystems.c
+ $(CC) -o hnb_p *.c -pg -lncurses_p libcli/libcli_p.a -I.. -Ilibcli -DHAVE_CONFIG_H
+
+--- a/src/libcli/Makefile
++++ b/src/libcli/Makefile
+@@ -7,11 +7,11 @@
+ clean:
+ rm -f *.o *.a *.so test-s* *~
+ libcli.a: $(OBJS)
+- ar rc libcli.a cli*.o
++ $(AR) rc libcli.a cli*.o
+ libcli_p.a:
+ $(CC) -pg -c cli.c
+ $(CC) -pg -c cli_history.c
+- ar rcs libcli_p.a cli*.o
++ $(AR) rcs libcli_p.a cli*.o
+ libcli.so: $(OBJS)
+ $(CC) -shared cli*.o -o libcli.so $(CFLAGS) $(LIBS)
+ test-static: test.o libcli.a
diff --git a/app-text/hnb/files/hnb-1.9.18-include.patch b/app-text/hnb/files/hnb-1.9.18-include.patch
new file mode 100644
index 000000000000..9ee57a351d51
--- /dev/null
+++ b/app-text/hnb/files/hnb-1.9.18-include.patch
@@ -0,0 +1,13 @@
+--- a/src/expanded.c
++++ b/src/expanded.c
+@@ -18,9 +18,9 @@
+ * Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+ */
+
++#include <string.h>
+ #include "tree.h"
+ #include "cli.h"
+-#define NULL 0
+
+ #include "evilloop.h"
+ #include "ctype.h"
diff --git a/app-text/hnb/files/hnb-1.9.18-printf.patch b/app-text/hnb/files/hnb-1.9.18-printf.patch
new file mode 100644
index 000000000000..d8ac27efb643
--- /dev/null
+++ b/app-text/hnb/files/hnb-1.9.18-printf.patch
@@ -0,0 +1,11 @@
+--- a/src/libcli/cli.c
++++ b/src/libcli/cli.c
+@@ -57,7 +57,7 @@
+ wp=word;
+ *wp='\0';
+ } else {
+- printf(tbuf);printf("\n");
++ printf("%s\n", tbuf);
+ bp=tbuf;
+ *bp='\0';
+ strcpy(bp,word);
diff --git a/app-text/hnb/hnb-1.9.18-r1.ebuild b/app-text/hnb/hnb-1.9.18-r1.ebuild
new file mode 100644
index 000000000000..4b9be7f51039
--- /dev/null
+++ b/app-text/hnb/hnb-1.9.18-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A program to organize many kinds of data in one place"
+HOMEPAGE="http://hnb.sourceforge.net/"
+SRC_URI="http://hnb.sourceforge.net/.files/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="amd64 ppc ~sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
+
+RDEPEND="sys-libs/ncurses"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ rm -r ${P} || die
+ rm src/cli_history.o || die
+
+ epatch \
+ "${FILESDIR}"/${P}-flags.patch \
+ "${FILESDIR}"/${P}-include.patch \
+ "${FILESDIR}"/${P}-printf.patch
+
+ tc-export AR CC PKG_CONFIG
+
+ # bug #532552
+ export LC_ALL=C
+}
+
+src_install() {
+ dodoc README doc/hnbrc
+ doman doc/hnb.1
+ dobin src/hnb
+}
diff --git a/app-text/hnb/metadata.xml b/app-text/hnb/metadata.xml
new file mode 100644
index 000000000000..8ce796e6b99c
--- /dev/null
+++ b/app-text/hnb/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ hnb is a program to organize many kinds of data in one place, including
+ addresses, TODO lists, ideas, book reviews, brainstorming, speech
+ outlines, etc. It stores data in XML format, and is capable of native
+ export to ASCII and HTML.
+ </longdescription>
+</pkgmetadata>