summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/dvipng
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/dvipng')
-rw-r--r--app-text/dvipng/Manifest2
-rw-r--r--app-text/dvipng/dvipng-1.14.ebuild49
-rw-r--r--app-text/dvipng/dvipng-1.15.ebuild40
-rw-r--r--app-text/dvipng/files/dvipng-1.14-wait.patch18
-rw-r--r--app-text/dvipng/metadata.xml27
5 files changed, 136 insertions, 0 deletions
diff --git a/app-text/dvipng/Manifest b/app-text/dvipng/Manifest
new file mode 100644
index 000000000000..09eb08fc9bef
--- /dev/null
+++ b/app-text/dvipng/Manifest
@@ -0,0 +1,2 @@
+DIST dvipng-1.14.tar.gz 173686 SHA256 43f5b57d0fab29398dcec1b849e8bebbcacb0b9c06875d2ac84a049be3c5b350 SHA512 d7dda0e83ec93c0ebb9c970f2464ed1b04cdd41c178165db6da7c37b90810f3be0a513b9a43162563cb5ca15a7dec3c12a49f27abeb44fca3739090661ab53ba WHIRLPOOL 5510c41343ddc4f628eaac44b47e1e865b964d043ebf920706098f98e9f56d4557553487c15fd1931ea862350b1984f2276a37bd85ed60fb9a0b2caaa7293bc6
+DIST dvipng-1.15.tar.gz 171529 SHA256 197e9fd0f87ede32dc4bc1d39ec2cd72fa5260856f9d0dc2d8e6895130408347 SHA512 54647526a9d3a26d2ba9c7ef17f285a426d9df06ffb1d5336a1da95cbf24cd17505ba7f6b1ffd14a0beb7f91ab3e519612ce3d3ea3f30c278733127dfbf07c5c WHIRLPOOL 4c0c5e410b107cd6cb56f9360acd556ae4336855d0624800d96e46cd29caead0467bc554d3d1c404e4564a3ce7b3732386f6af93ea98312c6b17745582f4ef92
diff --git a/app-text/dvipng/dvipng-1.14.ebuild b/app-text/dvipng/dvipng-1.14.ebuild
new file mode 100644
index 000000000000..9b84d76210e5
--- /dev/null
+++ b/app-text/dvipng/dvipng-1.14.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="Translate DVI files into PNG or GIF graphics"
+HOMEPAGE="http://dvipng.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-3+ Texinfo-manual"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="t1lib truetype test"
+
+RDEPEND="
+ dev-libs/kpathsea
+ media-libs/gd[jpeg,png]
+ media-libs/libpng
+ virtual/latex-base
+ sys-libs/zlib
+ t1lib? ( media-libs/t1lib )
+ truetype? ( >=media-libs/freetype-2.1.5 )"
+DEPEND="${RDEPEND}
+ virtual/texi2dvi
+ test? ( dev-texlive/texlive-fontsrecommended )"
+
+DOCS="ChangeLog README RELEASE"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-wait.patch
+}
+
+src_configure() {
+ if ! use t1lib; then
+ # The build system autodetects libt1. We don't want that if the
+ # USE flag is not set, so confuse it with a wrong name.
+ sed -i -e 's/T1_InitLib/dIsAbLe&/' configure || die "sed failed"
+ fi
+
+ if ! use truetype; then
+ sed -i -e 's/FT_Init_FreeType/dIsAbLe&/' configure || die "sed failed"
+ fi
+
+ export VARTEXFONTS="${T}/fonts"
+ econf
+}
diff --git a/app-text/dvipng/dvipng-1.15.ebuild b/app-text/dvipng/dvipng-1.15.ebuild
new file mode 100644
index 000000000000..c5f7cf43ab4b
--- /dev/null
+++ b/app-text/dvipng/dvipng-1.15.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="Translate DVI files into PNG or GIF graphics"
+HOMEPAGE="http://dvipng.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-3+ Texinfo-manual"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="truetype test"
+
+RDEPEND="
+ dev-libs/kpathsea:=
+ media-libs/gd[jpeg,png]
+ media-libs/libpng:0=
+ virtual/latex-base
+ sys-libs/zlib
+ truetype? ( >=media-libs/freetype-2.1.5 )"
+DEPEND="${RDEPEND}
+ virtual/texi2dvi
+ virtual/pkgconfig
+ test? ( dev-texlive/texlive-fontsrecommended )"
+
+DOCS="ChangeLog README RELEASE"
+
+src_configure() {
+ has_version '>=dev-libs/kpathsea-6.2.1' && append-cppflags "$($(tc-getPKG_CONFIG) --cflags kpathsea)"
+ if ! use truetype; then
+ sed -i -e 's/FT_Init_FreeType/dIsAbLe&/' configure || die "sed failed"
+ fi
+
+ export VARTEXFONTS="${T}/fonts"
+ econf
+}
diff --git a/app-text/dvipng/files/dvipng-1.14-wait.patch b/app-text/dvipng/files/dvipng-1.14-wait.patch
new file mode 100644
index 000000000000..d7f629fb372b
--- /dev/null
+++ b/app-text/dvipng/files/dvipng-1.14-wait.patch
@@ -0,0 +1,18 @@
+Patch by MATSUI Tetsushi to fix compilation issue on OSX
+
+sys/wait.h seems to be the man-page include for waitpid on Linux,
+Solaris and OSX
+
+https://bugs.gentoo.org/show_bug.cgi?id=369363
+
+--- special.c
++++ special.c
+@@ -26,7 +26,7 @@
+
+ #ifndef MIKTEX
+ #ifndef WIN32
+-#include <wait.h>
++#include <sys/wait.h>
+ #else /* WIN32 */
+ #include <fcntl.h>
+ #include <io.h>
diff --git a/app-text/dvipng/metadata.xml b/app-text/dvipng/metadata.xml
new file mode 100644
index 000000000000..010b40ad8f6a
--- /dev/null
+++ b/app-text/dvipng/metadata.xml
@@ -0,0 +1,27 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>tex</herd>
+ <herd>emacs</herd>
+ <longdescription>
+ This program makes PNG and/or GIF graphics from DVI files as obtained
+ from TeX and its relatives.
+
+ If GIF support is enabled, GIF output is chosen by using the ‘dvigif’
+ binary or with the ‘--gif’ option.
+
+ It is intended to produce anti-aliased screen-resolution images as fast
+ as is possible. The target audience is people who need to generate and
+ regenerate many images again and again. The primary target is the
+ preview-latex (X)Emacs package, a package to preview formulas from within
+ (X)Emacs. Yes, you get to see your formulas in the (X)Emacs buffer, see
+ &lt;http://www.gnu.org/software/auctex/preview-latex.html&gt;.
+</longdescription>
+ <use>
+ <flag name="t1lib">Enable support for T1lib font rendering
+ (<pkg>media-libs/t1lib</pkg>)</flag>
+ </use>
+ <upstream>
+ <remote-id type="sourceforge">dvipng</remote-id>
+ </upstream>
+</pkgmetadata>