summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/clara
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/clara')
-rw-r--r--app-text/clara/Manifest1
-rw-r--r--app-text/clara/clara-20031214.ebuild54
-rw-r--r--app-text/clara/files/clara_open_mode.patch20
-rw-r--r--app-text/clara/metadata.xml7
4 files changed, 82 insertions, 0 deletions
diff --git a/app-text/clara/Manifest b/app-text/clara/Manifest
new file mode 100644
index 000000000000..f2d720746c04
--- /dev/null
+++ b/app-text/clara/Manifest
@@ -0,0 +1 @@
+DIST clara-20031214.tar.gz 451539 SHA256 baae846923004ac1b5b91f73057d5faf042eb499434e163b7ab6db88410bbce1 SHA512 260d710132a3903d71b6c4c0885ac1709b60d520861e3dcd5e4b75a3bf5627549c94423670be08245e7a9db6a870a93a9526c8d318fadaddcce00cbf02985f49 WHIRLPOOL 19d229f9e4f391eb7e40d93799467a44de23dc202be012265c6580d08a55f2a4c2fac59323df1ee61798435b763aa0cf73e8425da02cc34cd9009eececadddb6
diff --git a/app-text/clara/clara-20031214.ebuild b/app-text/clara/clara-20031214.ebuild
new file mode 100644
index 000000000000..e94429308344
--- /dev/null
+++ b/app-text/clara/clara-20031214.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="An OCR (Optical Character Recognition) program"
+SRC_URI="mirror://gentoo/clara-20031214.tar.gz"
+HOMEPAGE="http://www.claraocr.org/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="amd64 ppc x86 ~ppc-macos ~sparc-solaris"
+IUSE=""
+
+RDEPEND="x11-libs/libX11"
+DEPEND="${RDEPEND}"
+
+# The test provided by clara doesn't seem to make any sense. It just
+# calls the binary with an unsupported option, which results in an
+# error.
+RESTRICT="test"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i -re "s/(C|LD)FLAGS =/\1FLAGS +=/" Makefile
+ epatch "${FILESDIR}/clara_open_mode.patch"
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" || die
+ emake doc || die
+}
+
+src_install() {
+ dobin clara selthresh
+ doman doc/clara*.1 selthresh.1
+
+ dodoc ANNOUNCE CHANGELOG doc/FAQ
+ insinto /usr/share/doc/${P}
+ doins imre.pbm
+
+ dohtml doc/*.html
+}
+
+pkg_postinst() {
+ elog
+ elog "Please note that Clara OCR has to be trained to recognize text,"
+ elog "without a training session it simply won't work. Have a look at"
+ elog "the docs in /usr/share/doc/${P}/html/ to get more "
+ elog "info about the training procedure."
+ elog
+}
diff --git a/app-text/clara/files/clara_open_mode.patch b/app-text/clara/files/clara_open_mode.patch
new file mode 100644
index 000000000000..3f73f466ab8c
--- /dev/null
+++ b/app-text/clara/files/clara_open_mode.patch
@@ -0,0 +1,20 @@
+--- pgmblock.c 2002-04-29 14:26:13.000000000 +0000
++++ pgmblock.c 2009-03-05 02:51:43.000000000 +0000
+@@ -161,7 +161,7 @@
+
+ printf("%d rare pixels (%1.4f)\n",t,((float)t)/(w*h));
+
+- F = open("map",O_WRONLY|O_CREAT);
++ F = open("map",O_WRONLY|O_CREAT, 0644);
+ write(F,m,h*bpl);
+ write(F,map,256);
+ close(F);
+@@ -197,7 +197,7 @@
+ {
+ int i,j,F;
+
+- F = open("map",O_RDONLY|O_CREAT);
++ F = open("map",O_RDONLY|O_CREAT, 0644);
+ read(F,m,h*bpl);
+ read(F,map,256);
+ close(F);
diff --git a/app-text/clara/metadata.xml b/app-text/clara/metadata.xml
new file mode 100644
index 000000000000..ff62877c67ae
--- /dev/null
+++ b/app-text/clara/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+</maintainer>
+</pkgmetadata>