summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Reffett <creffett@gentoo.org>2018-06-19 17:51:36 -0400
committerChris Reffett <creffett@gentoo.org>2018-06-19 21:21:17 -0400
commit4155c115ce916a690e7cc89907d7784da05da9f3 (patch)
treee609abea48c1ecb7abd35eaa611a9dfdfd3ab6f5 /app-text/bibletime/bibletime-2.11.1.ebuild
parentdev-python/cffi: bump to 1.11.5 (diff)
downloadgentoo-4155c115ce916a690e7cc89907d7784da05da9f3.tar.gz
gentoo-4155c115ce916a690e7cc89907d7784da05da9f3.tar.bz2
gentoo-4155c115ce916a690e7cc89907d7784da05da9f3.zip
app-text/bibletime: Version bump
Closes: https://bugs.gentoo.org/658356 Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'app-text/bibletime/bibletime-2.11.1.ebuild')
-rw-r--r--app-text/bibletime/bibletime-2.11.1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/app-text/bibletime/bibletime-2.11.1.ebuild b/app-text/bibletime/bibletime-2.11.1.ebuild
new file mode 100644
index 000000000000..ebbcd684ed65
--- /dev/null
+++ b/app-text/bibletime/bibletime-2.11.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="Qt Bible study application using the SWORD library"
+HOMEPAGE="http://www.bibletime.info/"
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${PV}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+# bug 313657
+RESTRICT="test"
+
+RDEPEND="
+ >=app-text/sword-1.7.0
+ dev-cpp/clucene
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtwebchannel:5
+ dev-qt/qtwebengine:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtxml:5
+"
+DEPEND="${RDEPEND}
+ dev-libs/boost
+ dev-libs/icu:=
+ dev-qt/linguist-tools:5
+ dev-qt/qttest:5
+ net-misc/curl
+ sys-libs/zlib
+"
+
+DOCS=( ChangeLog README.md )
+
+src_prepare() {
+ cmake-utils_src_prepare
+
+ sed -e "s:Dictionary;Qt:Dictionary;Office;TextTools;Utility;Qt:" \
+ -i cmake/platforms/linux/bibletime.desktop.cmake || die "fixing .desktop file failed"
+}