summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-12-03 07:12:55 +0000
committerSam James <sam@gentoo.org>2020-12-03 07:21:25 +0000
commit7d960010c929b679a57a5ccdeb11eb16137f5c08 (patch)
tree4b2e8899e461aa24786d6389fd8af9764e5b5767 /app-shells
parentapp-shells/powerline: add Python 3.8 to 9999 too (diff)
downloadgentoo-7d960010c929b679a57a5ccdeb11eb16137f5c08.tar.gz
gentoo-7d960010c929b679a57a5ccdeb11eb16137f5c08.tar.bz2
gentoo-7d960010c929b679a57a5ccdeb11eb16137f5c08.zip
app-shells/thefuck: add Python 3.8, 3.9
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/thefuck/thefuck-3.28.ebuild13
1 files changed, 6 insertions, 7 deletions
diff --git a/app-shells/thefuck/thefuck-3.28.ebuild b/app-shells/thefuck/thefuck-3.28.ebuild
index d7199bc7ffe9..ffcc66f3c8af 100644
--- a/app-shells/thefuck/thefuck-3.28.ebuild
+++ b/app-shells/thefuck/thefuck-3.28.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{6,7} )
+PYTHON_COMPAT=( python3_{6,7,8,9} )
inherit distutils-r1
@@ -14,8 +14,6 @@ SRC_URI="https://github.com/nvbn/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
RDEPEND="
dev-python/psutil[${PYTHON_USEDEP}]
@@ -24,12 +22,13 @@ RDEPEND="
dev-python/colorama[${PYTHON_USEDEP}]
dev-python/pyte[${PYTHON_USEDEP}]"
DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
test? (
- ${RDEPEND}
- dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
dev-python/pytest-mock[${PYTHON_USEDEP}]
- )"
+ )
+"
+
+distutils_enable_tests pytest
python_prepare_all() {
sed -i -e "/import pip/s/^/#/" -e "/pip.__version__/,+3 s/^/#/" setup.py || die