summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2020-12-13 21:48:12 +0900
committerAkinori Hattori <hattya@gentoo.org>2020-12-13 21:48:12 +0900
commitd02465865eb8fa1bf7e196158793c2332a2a44dd (patch)
treeef9ea3ea16019db1c18b2c02b3e524d73b3638fc /app-shells/yash
parentapp-text/sword-1.9.0: drop USE=static-libs support (diff)
downloadgentoo-d02465865eb8fa1bf7e196158793c2332a2a44dd.tar.gz
gentoo-d02465865eb8fa1bf7e196158793c2332a2a44dd.tar.bz2
gentoo-d02465865eb8fa1bf7e196158793c2332a2a44dd.zip
app-shells/yash: new upstream release
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Akinori Hattori <hattya@gentoo.org>
Diffstat (limited to 'app-shells/yash')
-rw-r--r--app-shells/yash/Manifest1
-rw-r--r--app-shells/yash/yash-2.51.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/app-shells/yash/Manifest b/app-shells/yash/Manifest
index 6bad76bc4d49..23f9215cf28f 100644
--- a/app-shells/yash/Manifest
+++ b/app-shells/yash/Manifest
@@ -1,2 +1,3 @@
DIST yash-2.49.tar.xz 740780 BLAKE2B 61fa2d2ab8a5f672cb21cc39c78f18076a4acd79d84fa2285bb35b03a697a58fa77584e5d66268dedbf69b5b2f2e00a7d2b6f6954ffa37a5e9fee3995851034b SHA512 99d98cfbe09aa746f2707217ecb506d8d5998df4a603ac276a8a67782fdcb3a7bd41fb34744f3834e319b0fdb0b1fd480cf9e2a4b835fec3e758280e13036db5
DIST yash-2.50.tar.xz 739988 BLAKE2B 4d8047150e2326b7c401f79416d87d09c099d4743026ee997e7f49d096cb23de210ded489b348cc9a264ece2fd4778b4f5c5c9999ed7391ab78699ce77ec03e0 SHA512 fc78d61b09f7c81d1d7bd3f4feefa7d4c0de910524759ebcba2b53322abc3f1e0a937007b36a5060af0ee759df210ec06d5eed2c71cf3f7ccd0825521b50edb7
+DIST yash-2.51.tar.xz 753880 BLAKE2B 4c66137eb2abf454c75b50c9d153522136bd835e7c26a305b424b8cf88694fd1dc83d9012efc8e2a611abc25217b34ae1dd36c20e0645204fb349871d23feefa SHA512 53f85f98dfd66c8937db292694da05fb7fdc8d270fc4811d7ec4d2787ab56600eca8e44379ef349755ec5fb739af3b32036a588ac35be810108ccc388be122e6
diff --git a/app-shells/yash/yash-2.51.ebuild b/app-shells/yash/yash-2.51.ebuild
new file mode 100644
index 000000000000..c89be90cc413
--- /dev/null
+++ b/app-shells/yash/yash-2.51.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PLOCALES="en ja"
+
+inherit flag-o-matic l10n toolchain-funcs
+
+DESCRIPTION="Yash is a POSIX-compliant command line shell"
+HOMEPAGE="https://yash.osdn.jp/"
+SRC_URI="mirror://sourceforge.jp/${PN}/74064/${P}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="sys-libs/ncurses:=
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}"
+BDEPEND="nls? ( sys-devel/gettext )
+ test? ( sys-apps/ed )"
+
+src_configure() {
+ append-cflags -std=c99
+
+ sh ./configure \
+ --prefix="${EPREFIX}"/usr \
+ --exec-prefix="${EPREFIX}" \
+ $(use_enable nls) \
+ CC=$(tc-getCC) \
+ LINGUAS="$(l10n_get_locales | sed "s/en/en@quot en@boldquot/")" \
+ || die
+}