summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2017-02-10 10:14:24 +0100
committerMichael Weber <xmw@gentoo.org>2017-02-10 10:43:36 +0100
commit1f2c76f541de6c0d4248abbddb2553c85273c0bb (patch)
tree516c0c0fe9afd08a542bd426fa7a2dc6d3657d36 /app-shells/quoter
parentapp-shells/push: Remove old versions. (diff)
downloadgentoo-1f2c76f541de6c0d4248abbddb2553c85273c0bb.tar.gz
gentoo-1f2c76f541de6c0d4248abbddb2553c85273c0bb.tar.bz2
gentoo-1f2c76f541de6c0d4248abbddb2553c85273c0bb.zip
app-shells/quoter: Move quoter_pipe.sh into /usr/share/quoter (bug 598529).
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'app-shells/quoter')
-rw-r--r--app-shells/quoter/quoter-3.0_p2-r1.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/app-shells/quoter/quoter-3.0_p2-r1.ebuild b/app-shells/quoter/quoter-3.0_p2-r1.ebuild
new file mode 100644
index 000000000000..29b79f549ee0
--- /dev/null
+++ b/app-shells/quoter/quoter-3.0_p2-r1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 2016-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit vcs-snapshot
+
+DESCRIPTION="Quote arguments or standard input for usage in POSIX shell by eval"
+HOMEPAGE="https://github.com/vaeth/quoter/"
+SRC_URI="https://github.com/vaeth/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x86-solaris"
+IUSE=""
+
+src_install() {
+ emake DESTDIR="${ED}" install
+
+ rm -f "${ED}"/usr/bin/quoter_pipe.sh || die
+ insinto /usr/share/${PN}
+ doins bin/quoter_pipe.sh
+}