summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2016-03-21 13:31:51 +0000
committerPatrice Clement <monsieurp@gentoo.org>2016-03-21 15:10:20 +0000
commit1851b20078ab6cb9cd703891c18dd6b683d7c13b (patch)
tree1bbece637e64ceed74e7a74888ef89a012bfc627 /app-shells/pdmenu
parentapp-shells/hstr: Fix DESCRIPTION length. (diff)
downloadgentoo-1851b20078ab6cb9cd703891c18dd6b683d7c13b.tar.gz
gentoo-1851b20078ab6cb9cd703891c18dd6b683d7c13b.tar.bz2
gentoo-1851b20078ab6cb9cd703891c18dd6b683d7c13b.zip
app-shells/pdmenu: EAPI 6 bump.
Package-Manager: portage-2.2.26
Diffstat (limited to 'app-shells/pdmenu')
-rw-r--r--app-shells/pdmenu/pdmenu-1.3.4-r1.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/app-shells/pdmenu/pdmenu-1.3.4-r1.ebuild b/app-shells/pdmenu/pdmenu-1.3.4-r1.ebuild
new file mode 100644
index 000000000000..5f16ae564378
--- /dev/null
+++ b/app-shells/pdmenu/pdmenu-1.3.4-r1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A simple console menu program"
+HOMEPAGE="http://joeyh.name/code/pdmenu/"
+SRC_URI="mirror://debian/pool/main/p/${PN}/pdmenu_${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~x86"
+IUSE="nls gpm examples"
+
+DEPEND="
+ sys-libs/slang
+ gpm? ( sys-libs/gpm )
+ nls? ( sys-devel/gettext )"
+
+S="${WORKDIR}/${PN}"
+
+RESTRICT="test"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-impl-dec.patch
+)
+
+src_prepare() {
+ default
+ sed \
+ -e 's:\(-o pdmenu\):$(LDFLAGS) \1:g' \
+ -i Makefile || die
+}
+
+src_configure() {
+ CC=$(tc-getCC) econf \
+ $(use_with gpm) \
+ $(use_enable nls)
+}
+
+src_compile() {
+ emake CC=$(tc-getCC)
+}
+
+src_install() {
+ dobin "${PN}"
+ dodoc doc/ANNOUNCE doc/BUGS doc/TODO
+ use examples && dodoc -r examples
+ mv "doc/${PN}.man" "doc/${PN}.1" || die
+ mv "doc/${PN}rc.man" "doc/${PN}rc.5" || die
+ doman "doc/${PN}.1" "doc/${PN}rc.5"
+
+}
+
+pkg_postinst() {
+ ewarn "Note this part from man page: Security warning! Any exec command"
+ ewarn "that uses the 'edit' flag will be a security hole. The user need"
+ ewarn "only to enter text with a ';' in it, and they can run an"
+ ewarn "arbitrary command after the semicolon!"
+}