summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2021-12-23 14:36:40 -0800
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2021-12-23 14:36:40 -0800
commit38fe8c5f2b50e35e919b26dbf5789238a04b12d0 (patch)
treef6a924a364cabe20485d3c59038801badd934004 /app-shells/fish
parentapp-shells/fish: never build docs for release version (diff)
downloadgentoo-38fe8c5f2b50e35e919b26dbf5789238a04b12d0.tar.gz
gentoo-38fe8c5f2b50e35e919b26dbf5789238a04b12d0.tar.bz2
gentoo-38fe8c5f2b50e35e919b26dbf5789238a04b12d0.zip
app-shells/fish: sync live ebuild
Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'app-shells/fish')
-rw-r--r--app-shells/fish/fish-9999.ebuild19
1 files changed, 16 insertions, 3 deletions
diff --git a/app-shells/fish/fish-9999.ebuild b/app-shells/fish/fish-9999.ebuild
index b0013271b00f..c35b05dc2100 100644
--- a/app-shells/fish/fish-9999.ebuild
+++ b/app-shells/fish/fish-9999.ebuild
@@ -18,7 +18,7 @@ if [[ ${PV} == "9999" ]]; then
EGIT_REPO_URI="https://github.com/${PN}-shell/${PN}-shell.git"
else
SRC_URI="https://github.com/${PN}-shell/${PN}-shell/releases/download/${MY_PV}/${MY_P}.tar.xz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
fi
LICENSE="GPL-2"
@@ -70,7 +70,11 @@ src_configure() {
-DWITH_GETTEXT="$(usex nls)"
)
# release tarballs ship pre-built docs // -DHAVE_PREBUILT_DOCS=TRUE
- [[ ${PV} == 9999 ]] && mycmakeargs+=( -DBUILD_DOCS="$(usex doc)" )
+ if [[ ${PV} == 9999 ]]; then
+ mycmakeargs+=( -DBUILD_DOCS="$(usex doc)" )
+ else
+ mycmakeargs+=( -DBUILD_DOCS=OFF )
+ fi
cmake_src_configure
}
@@ -81,7 +85,16 @@ src_install() {
}
src_test() {
- cmake_build -j1 test
+ # some tests are fragile, sanitize environment
+ local -x COLUMNS=80
+ local -x LINES=24
+
+ # very fragile, depends on terminal, size, tmux, screen and timing
+ if [[ ${PV} != 9999 ]]; then
+ rm -v tests/pexpects/terminal.py || die
+ fi
+
+ cmake_build test
}
pkg_postinst() {