summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-01-23 21:51:58 -0800
committerMatt Turner <mattst88@gentoo.org>2022-01-23 21:55:46 -0800
commit0e157d2202369b04dc1a6dc397dd1eaf49858520 (patch)
treeb58b1e1b2e6af788cf8b3df2ed30652d81684057 /app-shells/autojump
parentapp-shells/autojump: Add Python 3.10 compatibility (diff)
downloadgentoo-0e157d2202369b04dc1a6dc397dd1eaf49858520.tar.gz
gentoo-0e157d2202369b04dc1a6dc397dd1eaf49858520.tar.bz2
gentoo-0e157d2202369b04dc1a6dc397dd1eaf49858520.zip
app-shells/autojump: Drop old versions
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'app-shells/autojump')
-rw-r--r--app-shells/autojump/autojump-22.5.3.ebuild77
1 files changed, 0 insertions, 77 deletions
diff --git a/app-shells/autojump/autojump-22.5.3.ebuild b/app-shells/autojump/autojump-22.5.3.ebuild
deleted file mode 100644
index deb81c56b6b3..000000000000
--- a/app-shells/autojump/autojump-22.5.3.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_{7..9} )
-
-inherit bash-completion-r1 python-r1 vcs-snapshot prefix
-
-DESCRIPTION="change directory command that learns"
-HOMEPAGE="https://github.com/wting/autojump"
-SRC_URI="https://github.com/wting/${PN}/archive/release-v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="amd64 ~hppa ~mips ~ppc ~ppc64 x86 ~x64-macos"
-IUSE="ipython test"
-REQUIRED_USE="ipython? ( ${PYTHON_REQUIRED_USE} )"
-
-# Not all tests pass. Need investigation.
-RESTRICT="test"
-RDEPEND="ipython? ( ${PYTHON_DEPS} )"
-DEPEND="${PYTHON_DEPS}"
-
-src_prepare() {
- eapply_user
- sed -e "s:/usr/local/share:/usr/share:" \
- -i bin/autojump.sh || die
-
- # autojump_argparse is only there for Python 2.6 compatibility
- sed -e "s:autojump_argparse:argparse:" \
- -i bin/autojump || die
-
- hprefixify -q '"' -w '/usr\/share/' bin/autojump.sh
-}
-
-src_compile() {
- :
-}
-
-src_install() {
- dobin bin/"${PN}"
- python_replicate_script "${ED}"/usr/bin/"${PN}"
-
- insinto /etc/profile.d
- doins bin/"${PN}".sh
-
- insinto /usr/share/"${PN}"/
- doins bin/"${PN}.bash"
- doins bin/"${PN}.zsh"
- doins bin/"${PN}.fish"
- insinto /usr/share/zsh/site-functions
- doins bin/_j
-
- python_foreach_impl python_domodule bin/autojump_argparse.py bin/autojump_data.py \
- bin/autojump_match.py bin/autojump_utils.py
- if use ipython; then
- python_foreach_impl python_domodule tools/autojump_ipython.py
- fi
-
- doman docs/"${PN}.1"
- einstalldocs
-}
-
-pkg_postinst() {
- if use ipython; then
- elog 'This tool provides "j" for ipython, please add'
- elog '"import autojump_ipython" to your ipy_user_conf.py.'
- elog
- fi
-
- elog 'If you use app-shells/fish, add the following code to your'
- elog 'config.fish to get autojump support:'
- elog 'if test -f /usr/share/autojump/autojump.fish'
- elog ' source /usr/share/autojump/autojump.fish'
- elog 'end'
-}