summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-08-29 18:31:22 +0200
committerDavid Seifert <soap@gentoo.org>2020-08-29 18:31:22 +0200
commit899d76309f2c9041cf32763284ff70630f9455ab (patch)
treeebf07de7b8701d14778fe648062dd9c89abea954 /app-portage
parentprofiles/package.mask: remove dev-lang/go-1.12* mask (diff)
downloadgentoo-899d76309f2c9041cf32763284ff70630f9455ab.tar.gz
gentoo-899d76309f2c9041cf32763284ff70630f9455ab.tar.bz2
gentoo-899d76309f2c9041cf32763284ff70630f9455ab.zip
app-portage/repo-commit: Port to EAPI 7
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/repo-commit/repo-commit-0.4.1-r1.ebuild24
1 files changed, 17 insertions, 7 deletions
diff --git a/app-portage/repo-commit/repo-commit-0.4.1-r1.ebuild b/app-portage/repo-commit/repo-commit-0.4.1-r1.ebuild
index 978b47e224cf..5e2bdee57fc1 100644
--- a/app-portage/repo-commit/repo-commit-0.4.1-r1.ebuild
+++ b/app-portage/repo-commit/repo-commit-0.4.1-r1.ebuild
@@ -1,17 +1,27 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
+EAPI=7
-inherit autotools-utils
+inherit out-of-source
+
+if [[ ${PV} == *9999 ]]; then
+ EGIT_REPO_URI="https://bitbucket.org/gentoo/${PN}.git"
+ inherit autotools git-r3
+else
+ SRC_URI="https://www.bitbucket.org/gentoo/${PN}/downloads/${P}.tar.bz2"
+ KEYWORDS="~amd64 ~x86"
+fi
DESCRIPTION="A repository commit helper"
HOMEPAGE="https://bitbucket.org/gentoo/repo-commit/"
-SRC_URI="https://www.bitbucket.org/gentoo/${PN}/downloads/${P}.tar.bz2"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-RDEPEND=">=sys-apps/portage-2.2.0_alpha86"
+RDEPEND="sys-apps/portage"
+
+src_prepare() {
+ default
+ [[ ${PV} == *9999 ]] && eautoreconf
+}