summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-08-26 22:49:05 +0100
committerSam James <sam@gentoo.org>2023-08-26 22:49:05 +0100
commit3f679f5a280ed747c1bc4af312db9e495cad5165 (patch)
tree45282eaf1e9c4d03b514d96615265232b8e1e3ee /app-portage
parentmedia-libs/sdl2-gfx: Stabilize 1.0.4-r1 amd64, #913077 (diff)
downloadgentoo-3f679f5a280ed747c1bc4af312db9e495cad5165.tar.gz
gentoo-3f679f5a280ed747c1bc4af312db9e495cad5165.tar.bz2
gentoo-3f679f5a280ed747c1bc4af312db9e495cad5165.zip
app-portage/getuto: add 1.3
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/getuto/Manifest1
-rw-r--r--app-portage/getuto/getuto-1.3.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/app-portage/getuto/Manifest b/app-portage/getuto/Manifest
index d4feefeb21b3..e67f0f025728 100644
--- a/app-portage/getuto/Manifest
+++ b/app-portage/getuto/Manifest
@@ -1,3 +1,4 @@
DIST getuto-1.1.tar.gz 9394 BLAKE2B 50a129826a98d1a43e1bee68f4d12707334de6e7dd0408685e4e5b727affe86560199745a65bc810d857afc972ef0e2aab6b712c67061e1379add1b48494c4b5 SHA512 94f88b6562d763aa2b5cea407409e617d9c1bc89db5779fe12cebabf3db22873d60f36e98ca90ce8bbbc4a1f06bb734a1ee059b5735f54cdba24db9f041cc13c
DIST getuto-1.2.tar.gz 9412 BLAKE2B 0d207ecb83ca0739640a0c7587579b6c4d0437db5b84725dd14a31adee2f10ef1294dac9c159b8757dde42dd2693f82231aed720b7d1db63fa043bd20a5436bc SHA512 2d6ee97461fef1000f3616627c6e9899f5a348f6421e801ded37e96874340260ebb25a6e20138dda073278b8465ed8cebce8537da0e91fa4fc7e661c11f623d9
+DIST getuto-1.3.tar.gz 9589 BLAKE2B 79f95e263d3a18e58122bb418a3f7e4fe2f28b9e1c0e1cdd21c02df6cb1d0daec233c496ad0191ee4808ccad751b0e76212168454202da03d35bb74a100b24c4 SHA512 c7be7c992da2d3817240e20e47ee195a88eeb63a9a8a886e3b526b7a464fa6b2fe932b056aa0140960a9f104c34a6d4bafe483d10bf02da3c8ce9b7e3e4c3b26
DIST libc-1-r1-1.gpkg.tar 20480 BLAKE2B b2c184e20c1a29ff66240e992f9f81219285f525eb63cea081372685cf03a2e231a2edb528259617e74c655fbe61b6e0d8fc0bbdbd8452b6098de58432f019d7 SHA512 ce52f398ea8979ec16161381803740d49a4294c77303880f54090c379ba5eb8e545a3d3550f229cacc18c7763dc3adf7936561ba1c64b43c87692ec66084e4e6
diff --git a/app-portage/getuto/getuto-1.3.ebuild b/app-portage/getuto/getuto-1.3.ebuild
new file mode 100644
index 000000000000..860cc3595dd0
--- /dev/null
+++ b/app-portage/getuto/getuto-1.3.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Stand-alone gentoo install trust anchor generation tool"
+HOMEPAGE="https://github.com/projg2/getuto"
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/projg2/getuto"
+ inherit git-r3
+else
+ SRC_URI="
+ https://github.com/projg2/getuto/archive/refs/tags/${P}.tar.gz
+ "
+ S=${WORKDIR}/${PN}-${P}
+
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+SRC_URI+=" test? ( https://mirror.bytemark.co.uk/gentoo/releases/amd64/binpackages/17.1/x86-64/virtual/libc/libc-1-r1-1.gpkg.tar )"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ app-crypt/gnupg
+ dev-libs/openssl
+ sec-keys/openpgp-keys-gentoo-release
+"
+
+src_unpack() {
+ if [[ ${PV} == 9999 ]] ; then
+ git-r3_src_unpack
+ else
+ # Don't mangle test data
+ unpack ${P}.tar.gz
+ fi
+
+ if use test ; then
+ cp "${DISTDIR}"/libc-1-r1-1.gpkg.tar "${S}" || die
+ fi
+}
+
+src_install() {
+ dobin getuto
+}