summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-pda/dynamite
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-pda/dynamite')
-rw-r--r--app-pda/dynamite/Manifest1
-rw-r--r--app-pda/dynamite/dynamite-0.1.1_p20120512.ebuild32
-rw-r--r--app-pda/dynamite/files/dynamite-bootstrap.patch16
-rw-r--r--app-pda/dynamite/metadata.xml12
4 files changed, 61 insertions, 0 deletions
diff --git a/app-pda/dynamite/Manifest b/app-pda/dynamite/Manifest
new file mode 100644
index 000000000000..8713a70fd7ad
--- /dev/null
+++ b/app-pda/dynamite/Manifest
@@ -0,0 +1 @@
+DIST dynamite-0.1.1_p20120512.tar.xz 48964 SHA256 c828913e43d48d66ece7ad6738d29c00d4b479055f2dd9d8ef41a1429c564328 SHA512 ba7a4c773d460e0e644cb1da3ae7fe3e48fc6fbe94dafc3ccab61659ade6363544a5d1d458574d365623b7eeaa1c1c7d10c05324a344d0e8ef7422276540daaa WHIRLPOOL 84166a402faf3de6d848d7f51283ae2c885b17f37684656d25d4effbf57dfeefd5396fce26d8259130553f043ad819d70f347806a554d80c100562c12bdfd7bd
diff --git a/app-pda/dynamite/dynamite-0.1.1_p20120512.ebuild b/app-pda/dynamite/dynamite-0.1.1_p20120512.ebuild
new file mode 100644
index 000000000000..aff499910837
--- /dev/null
+++ b/app-pda/dynamite/dynamite-0.1.1_p20120512.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit autotools eutils
+
+DESCRIPTION="A tool (and library) for decompressing data compressed with PKWARE Data Compression Library"
+HOMEPAGE="https://github.com/twogood/dynamite http://sourceforge.net/projects/synce/"
+SRC_URI="http://dev.gentoo.org/~ssuominen/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="static-libs"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-bootstrap.patch
+ ./bootstrap
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc ChangeLog README
+
+ find "${ED}" -name '*.la' -exec rm -f {} +
+}
diff --git a/app-pda/dynamite/files/dynamite-bootstrap.patch b/app-pda/dynamite/files/dynamite-bootstrap.patch
new file mode 100644
index 000000000000..3ac2695f89b4
--- /dev/null
+++ b/app-pda/dynamite/files/dynamite-bootstrap.patch
@@ -0,0 +1,16 @@
+--- bootstrap
++++ bootstrap
+@@ -26,8 +26,8 @@
+ INCLUDES="-I m4"
+ fi
+ set -x
+-aclocal $INCLUDES
+-autoheader
+-libtoolize --copy --automake
+-automake --copy --foreign --add-missing
+-autoconf
++# aclocal $INCLUDES
++# autoheader
++# libtoolize --copy --automake
++# automake --copy --foreign --add-missing
++# autoconf
diff --git a/app-pda/dynamite/metadata.xml b/app-pda/dynamite/metadata.xml
new file mode 100644
index 000000000000..5b99dd4ae283
--- /dev/null
+++ b/app-pda/dynamite/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>pda</herd>
+ <maintainer>
+ <email>ssuominen@gentoo.org</email>
+ <name>Samuli Suominen</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">twogood/dynamite</remote-id>
+ </upstream>
+</pkgmetadata>