summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-office/plan
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-office/plan')
-rw-r--r--app-office/plan/Manifest2
-rw-r--r--app-office/plan/metadata.xml11
-rw-r--r--app-office/plan/plan-1.10.ebuild73
3 files changed, 86 insertions, 0 deletions
diff --git a/app-office/plan/Manifest b/app-office/plan/Manifest
new file mode 100644
index 000000000000..7e8726685ad8
--- /dev/null
+++ b/app-office/plan/Manifest
@@ -0,0 +1,2 @@
+DIST plan-1.10-gentoo.tar.xz 5976 SHA256 fd8abf28d2bed29aa65bdd533c408b8c83a7c3d77a91b2cbd33baa47fcea02c5 SHA512 60fcfe1fec1d7911a155d6737e6a808ea897ce7c4207bd2f4e95f57b1d154d8d594c6f5ecc8a959cc0d7f47f1415f86797e0c4053873775decfc048bc16048a3 WHIRLPOOL 312f26706767469da2394113580ee2091e65708c51fa32bd8bc768ac52db463c8b21c6e1e3a39867228e1725a7380a0bf2acc89ddd327950d2f4a35d54053aeb
+DIST plan-1.10.tar.gz 460150 SHA256 8584bdffd0a3421a029c2f5995b49231c2291ffcb5afaa6bdfd02e037a7a5fc3 SHA512 fde17ef17f25412cbe69427364f4130564f46a940859066c25d837d14eca6920752b843211192a6c1cdc83be05de9ac57c88424ca555928b67eb219fa8564fe8 WHIRLPOOL de37363c3f512645ba41274738893699e61ffe56920c8868433617030a87b88c200048a68d5c672e8a223b38a96179c7a9bf8e330b92f988dcb25bca3790b842
diff --git a/app-office/plan/metadata.xml b/app-office/plan/metadata.xml
new file mode 100644
index 000000000000..c1381d98a93e
--- /dev/null
+++ b/app-office/plan/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ <name>Default assignee for orphaned packages</name>
+ </maintainer>
+ <longdescription lang="en">
+ Plan is a Motif based schedule planner.
+ </longdescription>
+</pkgmetadata>
diff --git a/app-office/plan/plan-1.10.ebuild b/app-office/plan/plan-1.10.ebuild
new file mode 100644
index 000000000000..fa55d32c106c
--- /dev/null
+++ b/app-office/plan/plan-1.10.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="Motif based schedule planner"
+HOMEPAGE="http://www.bitrot.de/plan.html"
+SRC_URI="ftp://ftp.fu-berlin.de/unix/X11/apps/plan/${P}.tar.gz
+ mirror://gentoo/${P}-gentoo.tar.xz"
+
+LICENSE="GPL-2+" #448646
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="
+ x11-libs/libXpm
+ >=x11-libs/motif-2.3:0
+"
+RDEPEND="${DEPEND}"
+
+QA_PRESTRIPPED="
+/usr/bin/netplan
+/usr/bin/plan
+"
+src_prepare() {
+ epatch "${WORKDIR}"/${P}-patches/*.patch
+}
+
+src_compile() {
+ pushd src
+ emake CC=$(tc-getCC) SHARE=/usr/share/plan linux
+ popd
+}
+
+src_install() {
+ pushd src
+ emake \
+ DESTDIR="${D}" \
+ SHARE=/usr/share/plan \
+ install
+ keepdir /usr/share/plan/netplan.dir
+ popd
+
+ dodoc HISTORY README
+
+ pushd misc
+ doman netplan.1 plan.1 plan.4
+ insinto /usr/share/${PN}/misc
+ doins netplan.boot BlackWhite Monochrome plan.fti Plan.xpm plan.xpm
+ exeinto /usr/share/${PN}/misc
+ doexe Killpland cvs vsc msschedule2plan plan2vcs
+ popd
+
+ pushd web
+ insinto /usr/share/${PN}/web
+ doins help.html bottom.html cgi-lib.pl common.pl holiday_webplan rtsban.jpg
+ exeinto /usr/share/${PN}/web
+ doexe *.cgi
+ popd
+}
+
+pkg_postinst() {
+ elog
+ elog " Check /usr/share/${PN}/holiday for examples to set your"
+ elog " ~/.holiday according to your country."
+ elog
+ elog " WebPlan ${PV} can be found in /usr/share/${PN}/web."
+ elog
+}