summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-office/homebank
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-office/homebank')
-rw-r--r--app-office/homebank/Manifest3
-rw-r--r--app-office/homebank/homebank-4.6.3.ebuild41
-rw-r--r--app-office/homebank/homebank-5.0.0.ebuild44
-rw-r--r--app-office/homebank/homebank-5.0.3.ebuild44
-rw-r--r--app-office/homebank/metadata.xml8
5 files changed, 140 insertions, 0 deletions
diff --git a/app-office/homebank/Manifest b/app-office/homebank/Manifest
new file mode 100644
index 000000000000..0cee1efbfb7e
--- /dev/null
+++ b/app-office/homebank/Manifest
@@ -0,0 +1,3 @@
+DIST homebank-4.6.3.tar.gz 1899045 SHA256 f6e31bb789d626b507c2af9d176a0bac0cbaec770ede73048ba7a6df113a6948 SHA512 aab7374d90ffc52a40188eb334fc9b3461c299014d6134f236488991400fffe9f6dcb69247501857fe4caafbb08f0c5d729211b13551203f1231d136e99e024d WHIRLPOOL e8f6a421c64eb1bf6f2d97910e4687b00cf794fd27c8aff83ce9d39e18393cccca1984e73a44110ff5e87427fd0ed74963dcb997490d97614116800100daca5b
+DIST homebank-5.0.0.tar.gz 2553476 SHA256 28d4342d989997ce63acdf5b92354f6142bb6d87d57fc37dd7610beb73305918 SHA512 85fbd42658c5427a69d69b11394ba5d7a4eedf05ab6b480399a5bf253822175f91eeac874b271b816b7bd44a387f40fd6c686f791b3575f5cf02465fd10a50a2 WHIRLPOOL ea46a06b7f08b85976d9b1c61843188bc2f9dd2e5075707be263f46eed8719ccc1aca15c246276972f7fc6fbf707c9e5364da334869cc166c8eb43445398c504
+DIST homebank-5.0.3.tar.gz 2551525 SHA256 eac04a19f5d7644a5bf254a22f737d562b41503f280e339192f39745bf0d7839 SHA512 727802950570aac29c9a578c6332cad3cf4c9d71a8f059db9ff4acec7fca5e85148b4aad8eea825dcf76cf751e44b4ab94be5c6c70fa09b0ddc7d40948ea4ac5 WHIRLPOOL 937f3734e97d3294633192dab593c1042ea550eb1fce70b85f37c3980eef65c1a63a392da86bfe9bcebab77efa556a77db3eeef21b41e637eed4e29a0d6cfa5c
diff --git a/app-office/homebank/homebank-4.6.3.ebuild b/app-office/homebank/homebank-4.6.3.ebuild
new file mode 100644
index 000000000000..78a98c32aaad
--- /dev/null
+++ b/app-office/homebank/homebank-4.6.3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit fdo-mime eutils
+
+DESCRIPTION="Free, easy, personal accounting for everyone"
+HOMEPAGE="http://homebank.free.fr/index.php"
+SRC_URI="http://homebank.free.fr/public/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+ofx"
+KEYWORDS="amd64 ppc x86"
+
+RDEPEND=">=x11-libs/gtk+-2.20:2
+ >=dev-libs/glib-2.17
+ ofx? ( >=dev-libs/libofx-0.7 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ >=dev-util/intltool-0.40.5"
+
+src_configure() {
+ econf $(use_with ofx)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Installation failed"
+ dodoc AUTHORS ChangeLog README
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}
diff --git a/app-office/homebank/homebank-5.0.0.ebuild b/app-office/homebank/homebank-5.0.0.ebuild
new file mode 100644
index 000000000000..4f4210ce77f0
--- /dev/null
+++ b/app-office/homebank/homebank-5.0.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit fdo-mime eutils
+
+DESCRIPTION="Free, easy, personal accounting for everyone"
+HOMEPAGE="http://homebank.free.fr/index.php"
+SRC_URI="http://homebank.free.fr/public/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+ofx"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND=">=dev-libs/glib-2.28
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf
+ >=x11-libs/gtk+-3.6.4:3
+ x11-libs/pango
+ ofx? ( >=dev-libs/libofx-0.8.3 )"
+DEPEND="${RDEPEND}
+ >=dev-lang/perl-5.8.1
+ dev-perl/XML-Parser
+ >=dev-util/intltool-0.40.5
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS ChangeLog README )
+
+src_configure() {
+ econf $(use_with ofx)
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}
diff --git a/app-office/homebank/homebank-5.0.3.ebuild b/app-office/homebank/homebank-5.0.3.ebuild
new file mode 100644
index 000000000000..4f4210ce77f0
--- /dev/null
+++ b/app-office/homebank/homebank-5.0.3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit fdo-mime eutils
+
+DESCRIPTION="Free, easy, personal accounting for everyone"
+HOMEPAGE="http://homebank.free.fr/index.php"
+SRC_URI="http://homebank.free.fr/public/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+ofx"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND=">=dev-libs/glib-2.28
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf
+ >=x11-libs/gtk+-3.6.4:3
+ x11-libs/pango
+ ofx? ( >=dev-libs/libofx-0.8.3 )"
+DEPEND="${RDEPEND}
+ >=dev-lang/perl-5.8.1
+ dev-perl/XML-Parser
+ >=dev-util/intltool-0.40.5
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS ChangeLog README )
+
+src_configure() {
+ econf $(use_with ofx)
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}
diff --git a/app-office/homebank/metadata.xml b/app-office/homebank/metadata.xml
new file mode 100644
index 000000000000..5b12ed78d92e
--- /dev/null
+++ b/app-office/homebank/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>calchan@gentoo.org</email>
+ <name>Denis Dupeyron</name>
+</maintainer>
+</pkgmetadata>