summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-office/eqe
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-office/eqe')
-rw-r--r--app-office/eqe/Manifest1
-rw-r--r--app-office/eqe/eqe-1.3.0.ebuild31
-rw-r--r--app-office/eqe/files/eqe-1.3.0-Makefile.patch42
-rw-r--r--app-office/eqe/metadata.xml5
4 files changed, 79 insertions, 0 deletions
diff --git a/app-office/eqe/Manifest b/app-office/eqe/Manifest
new file mode 100644
index 000000000000..550292101629
--- /dev/null
+++ b/app-office/eqe/Manifest
@@ -0,0 +1 @@
+DIST eqe-1.3.0.tar.bz2 98707 SHA256 8dd320985ebb7763295bf04b3664e0fb8094e3c398e468fddf225b13ee77f4e5 SHA512 6a1ffc1e9f4ec72ebeeb402f35857050b8f64b6fa60d9658667bad70047300c3331a1ac1ea0f0541dca9814bf55ed6e7cdd85513a24625f7cdddf3005b0a5d3d WHIRLPOOL 01e72d83d2239a34078ae30a462d56d12c4650c4cf05ccb9dc744dfeb7e14bb3b837a9d51c6914f34357322522c5d3ab0bf757295faddfa9ddb4420ff9396ffe
diff --git a/app-office/eqe/eqe-1.3.0.ebuild b/app-office/eqe/eqe-1.3.0.ebuild
new file mode 100644
index 000000000000..85ecac8cfc79
--- /dev/null
+++ b/app-office/eqe/eqe-1.3.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+
+DESCRIPTION="A small LaTeX editor that produces images, with drag and drop support"
+HOMEPAGE="http://rlehy.free.fr/"
+SRC_URI="http://rlehy.free.fr/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE=""
+
+DEPEND="dev-perl/gtk2-perl
+ dev-perl/File-Slurp
+ dev-perl/Template-Toolkit
+ media-gfx/imagemagick
+ virtual/latex-base"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # Fix install loction and conform to the Gentoo way
+ epatch "${FILESDIR}"/${P}-Makefile.patch || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+}
diff --git a/app-office/eqe/files/eqe-1.3.0-Makefile.patch b/app-office/eqe/files/eqe-1.3.0-Makefile.patch
new file mode 100644
index 000000000000..0b8094a65022
--- /dev/null
+++ b/app-office/eqe/files/eqe-1.3.0-Makefile.patch
@@ -0,0 +1,42 @@
+diff -urN eqe-1.3.0.old/Makefile eqe-1.3.0/Makefile
+--- eqe-1.3.0.old/Makefile 2006-02-04 15:54:54.000000000 +0100
++++ eqe-1.3.0/Makefile 2006-02-14 10:52:04.000000000 +0100
+@@ -1,7 +1,7 @@
+ # Ronan Le Hy, 2005
+ # eqe installer
+
+-PREFIX=/usr/local
++PREFIX=/usr
+ DESTDIR=
+ PACKAGE_NAME=eqe
+ VERSION=1.3.0
+@@ -21,19 +21,17 @@
+ pod2man doc/eqedit.pod $(DESTDIR)/$(PREFIX)/share/man/man1/eqedit.1
+ gzip -f --best $(DESTDIR)/$(PREFIX)/share/man/man1/eqe.1
+ gzip -f --best $(DESTDIR)/$(PREFIX)/share/man/man1/eqedit.1
+- mkdir -p $(DESTDIR)/$(PREFIX)/share/doc/$(PACKAGE_NAME)/
+- cp changelog $(DESTDIR)/$(PREFIX)/share/doc/$(PACKAGE_NAME)/changelog
+- gzip -f --best $(DESTDIR)/$(PREFIX)/share/doc/$(PACKAGE_NAME)/changelog
+- cp README $(DESTDIR)/$(PREFIX)/share/doc/$(PACKAGE_NAME)/README
+- gzip -f --best $(DESTDIR)/$(PREFIX)/share/doc/$(PACKAGE_NAME)/README
+- cp FAQ $(DESTDIR)/$(PREFIX)/share/doc/$(PACKAGE_NAME)/FAQ
+- gzip -f --best $(DESTDIR)/$(PREFIX)/share/doc/$(PACKAGE_NAME)/FAQ
+- cp TODO $(DESTDIR)/$(PREFIX)/share/doc/$(PACKAGE_NAME)/TODO
+- cp copyright $(DESTDIR)/$(PREFIX)/share/doc/$(PACKAGE_NAME)/copyright
+- cp GPL.txt $(DESTDIR)/$(PREFIX)/share/doc/$(PACKAGE_NAME)/GPL.txt
++ mkdir -p $(DESTDIR)/$(PREFIX)/share/doc/$(PACKAGE_NAME)-$(VERSION)/
++ cp changelog $(DESTDIR)/$(PREFIX)/share/doc/$(PACKAGE_NAME)-$(VERSION)/changelog
++ gzip -f --best $(DESTDIR)/$(PREFIX)/share/doc/$(PACKAGE_NAME)-$(VERSION)/changelog
++ cp README $(DESTDIR)/$(PREFIX)/share/doc/$(PACKAGE_NAME)-$(VERSION)/README
++ gzip -f --best $(DESTDIR)/$(PREFIX)/share/doc/$(PACKAGE_NAME)-$(VERSION)/README
++ cp FAQ $(DESTDIR)/$(PREFIX)/share/doc/$(PACKAGE_NAME)-$(VERSION)/FAQ
++ gzip -f --best $(DESTDIR)/$(PREFIX)/share/doc/$(PACKAGE_NAME)-$(VERSION)/FAQ
++ cp TODO $(DESTDIR)/$(PREFIX)/share/doc/$(PACKAGE_NAME)-$(VERSION)/TODO
++ gzip -f --best $(DESTDIR)/$(PREFIX)/share/doc/$(PACKAGE_NAME)-$(VERSION)/TODO
+ chmod 644 $(DESTDIR)/$(PREFIX)/share/man/man1/eqe.1.gz $(DESTDIR)/$(PREFIX)/share/man/man1/eqedit.1.gz
+- chmod 644 $(DESTDIR)/$(PREFIX)/share/doc/$(PACKAGE_NAME)/README.gz $(DESTDIR)/$(PREFIX)/share/doc/$(PACKAGE_NAME)/changelog.gz $(DESTDIR)/$(PREFIX)/share/doc/$(PACKAGE_NAME)/TODO $(DESTDIR)/$(PREFIX)/share/doc/$(PACKAGE_NAME)/copyright
+- chmod 644 $(DESTDIR)/$(PREFIX)/share/doc/$(PACKAGE_NAME)/GPL.txt
++ chmod 644 $(DESTDIR)/$(PREFIX)/share/doc/$(PACKAGE_NAME)-$(VERSION)/README.gz $(DESTDIR)/$(PREFIX)/share/doc/$(PACKAGE_NAME)-$(VERSION)/changelog.gz $(DESTDIR)/$(PREFIX)/share/doc/$(PACKAGE_NAME)-$(VERSION)/TODO.gz $(DESTDIR)/$(PREFIX)/share/doc/$(PACKAGE_NAME)-$(VERSION)/FAQ.gz
+
+ install-templates:
+ mkdir -p $(DESTDIR)/$(PREFIX)/share/eqe/
diff --git a/app-office/eqe/metadata.xml b/app-office/eqe/metadata.xml
new file mode 100644
index 000000000000..ba6a8a8800d5
--- /dev/null
+++ b/app-office/eqe/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>tex</herd>
+</pkgmetadata>