summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPunarbasu Purkayastha <ppurka@gmail.com>2024-09-09 20:13:55 +0100
committerJoonas Niilola <juippis@gentoo.org>2024-10-17 12:58:31 +0300
commitf22d24f4549bbb98a15a6b002ea768cf3454cafc (patch)
tree07a9c0383e22d462d0569aa6a98e0b70e2150a6f /app-misc
parentmedia-sound/ncmpc: dropped obsolete 0.49 (diff)
downloadgentoo-f22d24f4549bbb98a15a6b002ea768cf3454cafc.tar.gz
gentoo-f22d24f4549bbb98a15a6b002ea768cf3454cafc.tar.bz2
gentoo-f22d24f4549bbb98a15a6b002ea768cf3454cafc.zip
app-misc/recoll: Version bump to 1.40.1
Closes: https://bugs.gentoo.org/937911 Closes: https://github.com/gentoo/gentoo/pull/38535 Signed-off-by: Punarbasu Purkayastha <ppurka@gmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/recoll/Manifest1
-rw-r--r--app-misc/recoll/metadata.xml2
-rw-r--r--app-misc/recoll/recoll-1.40.1.ebuild127
3 files changed, 129 insertions, 1 deletions
diff --git a/app-misc/recoll/Manifest b/app-misc/recoll/Manifest
index 1809c362172c..01e11f313ed0 100644
--- a/app-misc/recoll/Manifest
+++ b/app-misc/recoll/Manifest
@@ -1 +1,2 @@
DIST recoll-1.37.4.tar.gz 3135691 BLAKE2B 1c9113cbccb812e522addbc7fec0aa0b958d8616aa1b753aa866e9bb96f78dc0a40bb79a4a8ad016286f2508f1d8dea172d308917a430fa4c98822feaba0d309 SHA512 9e5af5d00191658f23e6a5916718014827f12f4553d9429fe385c0bd1c72f2f49ae97e7d7b8121cb174b299ffe482aa547e4a3aabf2da92e9773bf9eb0f57814
+DIST recoll-1.40.1.tar.gz 3034050 BLAKE2B f3a863ccb0a0c1b17fd9eb3093de472cec47b6375683e38e1b462584b26570f3d995531314a9c5f2dd193dca62efa150c699705a23e96419787000d3c4694510 SHA512 7590f1d17f9d8fc7930044d43d92be47158cbd2c830d8723a1604b672d3d8df22e507d7208525e1bfdc169b5151f5b6a3f96bbfefb5bededd0e2dae7bdeb2359
diff --git a/app-misc/recoll/metadata.xml b/app-misc/recoll/metadata.xml
index 54f36901f4f7..d6917c0fc057 100644
--- a/app-misc/recoll/metadata.xml
+++ b/app-misc/recoll/metadata.xml
@@ -14,7 +14,7 @@
<email>jfd@recoll.org</email>
<name>Jean-Francois Dockes</name>
</maintainer>
- <bugs-to>https://bitbucket.org/medoc/recoll/issues</bugs-to>
+ <bugs-to>https://framagit.org/medoc92/recoll/-/issues</bugs-to>
</upstream>
<use>
<flag name="camelcase">Enable indexing for camelCase sentences and words</flag>
diff --git a/app-misc/recoll/recoll-1.40.1.ebuild b/app-misc/recoll/recoll-1.40.1.ebuild
new file mode 100644
index 000000000000..ae27da1acd9b
--- /dev/null
+++ b/app-misc/recoll/recoll-1.40.1.ebuild
@@ -0,0 +1,127 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit linux-info optfeature python-single-r1 qmake-utils meson systemd
+
+DESCRIPTION="Personal full text search package"
+HOMEPAGE="https://www.recoll.org"
+SRC_URI="https://www.recoll.org/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+IUSE="camelcase chm +inotify qt6 session +spell systemd webengine"
+REQUIRED_USE="
+ session? ( inotify )
+ webengine? ( qt6 )
+ ${PYTHON_REQUIRED_USE}
+"
+
+DEPEND="
+ dev-libs/libxml2
+ dev-libs/libxslt
+ dev-libs/xapian:=
+ sys-libs/zlib
+ virtual/libiconv
+ chm? (
+ dev-libs/chmlib
+ dev-python/pychm
+ )
+ qt6? (
+ dev-qt/qtbase:6[gui,network,widgets]
+ webengine? ( dev-qt/qtwebengine:6[widgets] )
+ )
+ session? (
+ inotify? (
+ x11-libs/libSM
+ x11-libs/libICE
+ x11-libs/libX11
+ )
+ )
+ spell? ( app-text/aspell )
+ systemd? ( sys-apps/systemd )
+ ${PYTHON_DEPS}
+"
+
+BDEPEND="
+ qt6? ( dev-qt/qttools:6[linguist] )
+"
+
+RDEPEND="
+ ${DEPEND}
+ app-arch/unzip
+"
+
+pkg_setup() {
+ if use inotify; then
+ local CONFIG_CHECK="~INOTIFY_USER"
+ check_extra_config
+ fi
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ python_fix_shebang filters
+}
+
+src_configure() {
+ use qt6 && export QMAKE="$(qt6_get_bindir)/qmake"
+
+ local emesonargs=(
+ $(meson_use camelcase)
+ $(meson_use chm python-chm)
+ $(meson_use inotify)
+ $(meson_use qt6 qtgui)
+ $(meson_use session x11mon)
+ $(meson_use spell aspell)
+ $(meson_use spell python-aspell)
+ $(meson_use systemd)
+ $(meson_use webengine)
+ -Dfam=false
+ -Drecollq=true
+ -Dwebkit=false
+ -Dsystemd-system-unit-dir="$(systemd_get_systemunitdir)"
+ -Dsystemd-user-unit-dir="$(systemd_get_userunitdir)"
+ )
+
+ use qt6 && emesonargs+=( $(usex webengine "-Dwebpreview=true" "-Dwebpreview=false") )
+
+ meson_src_configure
+}
+
+src_install() {
+ meson_install --strip
+ rm -rf "${D}/$(python_get_sitedir)"/*.egg-info || die
+ python_optimize
+
+ # html docs should be placed in /usr/share/doc/${PN}/html
+ rm -r "${ED}/usr/share/${PN}/doc" || die
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ optfeature "XML based documents support" "dev-libs/libxslt[python] dev-libs/libxml2[python]"
+ optfeature "PDF files support" app-text/poppler
+ optfeature "PDF files with OCR support" app-text/tesseract
+ optfeature "MS Word files support" app-text/antiword
+ optfeature "Wordperfect files support" "app-text/libwpd[tools]"
+ optfeature "Lyx files support" app-office/lyx
+ optfeature "GNU Info files support" sys-apps/texinfo
+ optfeature "RAR archives support" dev-python/rarfile
+ optfeature "7zip archives support" dev-python/pylzma
+ optfeature "iCalendar files support" dev-python/icalendar
+ optfeature "Postscript files support" app-text/pstotext
+ optfeature "RTF files support" app-text/unrtf
+ optfeature "TeX files support" virtual/tex-base
+ optfeature "DVI files support" virtual/tex-base
+ optfeature "DJVU files support" app-text/djvu
+ optfeature "tags in audio files support" media-libs/mutagen
+ optfeature "tags in image files support" media-libs/exiftool
+ optfeature "Midi karaoke files support" dev-python/chardet
+}