summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2024-06-16 10:44:10 +0200
committerConrad Kostecki <conikost@gentoo.org>2024-06-22 20:50:06 +0200
commitca3065b8df513f8a4f3c27f204ad40541b0490e1 (patch)
tree00f47d1bfa281010ffbb4fa0e6d72a292d8cb1c2 /app-misc
parentapp-misc/lockfile-progs: add 0.1.19 (diff)
downloadgentoo-ca3065b8df513f8a4f3c27f204ad40541b0490e1.tar.gz
gentoo-ca3065b8df513f8a4f3c27f204ad40541b0490e1.tar.bz2
gentoo-ca3065b8df513f8a4f3c27f204ad40541b0490e1.zip
app-misc/sonypid: add 1.9.1
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Closes: https://github.com/gentoo/gentoo/pull/37182 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/sonypid/Manifest1
-rw-r--r--app-misc/sonypid/sonypid-1.9.1.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/app-misc/sonypid/Manifest b/app-misc/sonypid/Manifest
index e7dbe9c9b202..0b11356fe16a 100644
--- a/app-misc/sonypid/Manifest
+++ b/app-misc/sonypid/Manifest
@@ -1 +1,2 @@
+DIST sonypid-1.9.1.tar.bz2 10089 BLAKE2B 51b1376f6fefc5e04d11431a302b462452c7511ff16fa4598b257b9569987aa817d2f895418fbb545e028360fdde0642f3a41f7fb885bf14868d42c69506c436 SHA512 7bf65f88b719ff511cce82d0def528e054a34274449f5cf9a07f721f5f3a9cb9b328656ff375585ad48405e6511f8b2de6bfe30a78bfba8c85d5e835d8cc0e96
DIST sonypid-1.9.tar.bz2 9710 BLAKE2B edc68ffe6649b6ad7f8afa41666be514b34593bf5f764f29d1ea0d94c335e2f497b7c31b9f0946210b008d6c37e0647b3327476cbc628db24ba7179dc2c25360 SHA512 fcd2b2d2a9db94cd59b8d0f23c41aca2e738e433ecd6818ce84cc1298f5609c84aa16b75e0ce1323e24bf6bb59feccd28c5016549d0690e6dd2f3aae1244e3d0
diff --git a/app-misc/sonypid/sonypid-1.9.1.ebuild b/app-misc/sonypid/sonypid-1.9.1.ebuild
new file mode 100644
index 000000000000..9dbe9c185488
--- /dev/null
+++ b/app-misc/sonypid/sonypid-1.9.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Tool to use the Sony Vaios jog-dial as a mouse-wheel"
+HOMEPAGE="https://www.popies.net/sonypi/"
+SRC_URI="https://www.popies.net/sonypi/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 x86"
+
+RDEPEND="x11-libs/libXtst"
+DEPEND="
+ ${RDEPEND}
+ x11-base/xorg-proto
+"
+
+src_compile() {
+ emake CFLAGS="${CFLAGS}" CC="$(tc-getCC)" LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ dobin sonypid
+ dodoc AUTHORS CHANGES
+}