summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Burroughs <chris.burroughs@gmail.com>2019-11-07 21:37:38 -0500
committerJoonas Niilola <juippis@gentoo.org>2020-06-12 09:59:45 +0300
commitbbf4348280a355c7def871019405fc563730ed7c (patch)
tree0b8132fcd7a25797262f3e4c4c4ea7cfcf64a27d /app-misc
parentdev-lang/rust: add some comments to cross section (diff)
downloadgentoo-bbf4348280a355c7def871019405fc563730ed7c.tar.gz
gentoo-bbf4348280a355c7def871019405fc563730ed7c.tar.bz2
gentoo-bbf4348280a355c7def871019405fc563730ed7c.zip
app-misc/anki: bump to 2.1.15 and modernize ebuild
- claiming maintainer timeout to update version and fix bugs, --juippis * Bump to EAPI 7 * Enable python 3.{7,8} support * Fix missing test dependencies * Add missing jsonschema dependency * Backport argument fix to allow mpv versions > 0.31 to be used by anki * Correct and expand LICENSE * Resolve NonexistentDeps DEPEND warning (leftover from PyQtWebEngine split, but no version of PyQt5 with a webengine use flag is still in the tree.) * Use default pkg_setup from eclass and rely on default value for S variable * Clarify optional runtime dependencies needed (mpv OR mplayer) * Move optional runtime dependencies to optfeature * Adjust SRC_URL after upstream re-arranging NOTE: The upstream LICENSE includes "Qt's bundled translations: LGPL3", but since we are building from source that is not directly included. More recent upstream versions have clarified this in the LICENSE file. Bug: https://bugs.gentoo.org/625894 Bug: https://bugs.gentoo.org/645314 Bug: https://bugs.gentoo.org/651472 Bug: https://bugs.gentoo.org/688798 Closes: https://bugs.gentoo.org/700010 Closes: https://bugs.gentoo.org/715624 Bug: https://bugs.gentoo.org/722502 Bug: https://bugs.gentoo.org/724482 Bug: https://bugs.gentoo.org/724990 Closes: https://bugs.gentoo.org/726522 Signed-off-by: Chris Burroughs <chris.burroughs@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/16054 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/anki/Manifest1
-rw-r--r--app-misc/anki/anki-2.1.15.ebuild93
-rw-r--r--app-misc/anki/files/anki-2.1.15-mpv-args.patch26
3 files changed, 120 insertions, 0 deletions
diff --git a/app-misc/anki/Manifest b/app-misc/anki/Manifest
index b40a9f9484c8..d013dc23f146 100644
--- a/app-misc/anki/Manifest
+++ b/app-misc/anki/Manifest
@@ -1,2 +1,3 @@
DIST anki-2.1.0_beta27.tgz 4127906 BLAKE2B b4f83cc30dc3e89f3ca17c03ba8dcfc9a487de43d8ac564d5dc83488e286c302816c8a8140aa764b596404194c5f3727218deec303ef201ccaef38b945d8b32d SHA512 50b4ece1361ecafdfe08dad04e9b622b1e8ba2224bfef7e4660c95f81cb8f525d892170548d741ff53bc19ff4c13863f488a71c31c8328511fea3203d2c345f1
DIST anki-2.1.13.tgz 4248906 BLAKE2B 82a2a9a556cbf3596af22a73a2865815561cdd408b249443fc7e144734fdc2b62317120db71475afd7b0d4027f19e53c47437132028ef78b158ec3624f54a33f SHA512 921ef48b16c0c8c83b85523aa0a5b828210b210cd51fa471f57e9aa6777a1aced30c7e24084ef0c2f14c9d846a19091923d13faaff7ed9075860fc23f8ba1cd3
+DIST anki-2.1.15.tgz 4269571 BLAKE2B 00b351f5ffacb363642e02bf806bcd7c0d9446c9815a75328e7fa37c848b271b135510de17cc012e8cc96d8a52a183a49de84b6f85f562a370255bd36c6f866e SHA512 f3acfa6ff62d43fa461efddd81a8570304ada53b97bd494fdbbe0a0439700d7a52aa62ead31cbaed731be0df96a6cc845a7cf92dcf65f3080dc63282fe5941c3
diff --git a/app-misc/anki/anki-2.1.15.ebuild b/app-misc/anki/anki-2.1.15.ebuild
new file mode 100644
index 000000000000..2f651f60f1dc
--- /dev/null
+++ b/app-misc/anki/anki-2.1.15.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8} )
+PYTHON_REQ_USE="sqlite"
+
+inherit desktop eutils python-single-r1 xdg
+
+DESCRIPTION="A spaced-repetition memory training program (flash cards)"
+HOMEPAGE="https://apps.ankiweb.net"
+SRC_URI="https://apps.ankiweb.net/downloads/archive/${P}-source.tgz -> ${P}.tgz"
+
+LICENSE="AGPL-3+ BSD MIT GPL-3+ CC-BY-SA-3.0 Apache-2.0 CC-BY-2.5"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ >=dev-python/PyQt5-5.12[gui,svg,widgets,${PYTHON_MULTI_USEDEP}]
+ >=dev-python/PyQtWebEngine-5.12[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/httplib2-0.7.4[${PYTHON_MULTI_USEDEP}]
+ dev-python/beautifulsoup:4[${PYTHON_MULTI_USEDEP}]
+ dev-python/decorator[${PYTHON_MULTI_USEDEP}]
+ dev-python/jsonschema[${PYTHON_MULTI_USEDEP}]
+ dev-python/markdown[${PYTHON_MULTI_USEDEP}]
+ dev-python/requests[${PYTHON_MULTI_USEDEP}]
+ dev-python/send2trash[${PYTHON_MULTI_USEDEP}]
+ ')
+"
+BDEPEND="test? (
+ ${RDEPEND}
+ $(python_gen_cond_dep '
+ dev-python/nose[${PYTHON_MULTI_USEDEP}]
+ dev-python/mock[${PYTHON_MULTI_USEDEP}]
+ ')
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.1.0_beta25-web-folder.patch
+ "${FILESDIR}"/${PN}-2.1.15-mpv-args.patch
+)
+
+src_prepare() {
+ default
+ sed -i -e "s/updates=True/updates=False/" \
+ aqt/profiles.py || die
+}
+
+src_compile() {
+ :;
+}
+
+src_test() {
+ sed -e "s:nose=nosetests$:nose=\"${EPYTHON} ${EROOT}/usr/bin/nosetests\":" \
+ -i tools/tests.sh || die
+ sed -e "s:nose=nosetests3$:nose=\"${EPYTHON} ${EROOT}/usr/bin/nosetests3\":" \
+ -i tools/tests.sh || die
+ sed -e "s:which nosetests3:which ${EROOT}/usr/bin/nosetests3:" \
+ -i tools/tests.sh || die
+ ./tools/tests.sh || die
+}
+
+src_install() {
+ doicon ${PN}.png
+ domenu ${PN}.desktop
+ doman ${PN}.1
+
+ dodoc README.md README.development
+ python_domodule aqt anki
+ python_newscript runanki anki
+
+ # Localization files go into the anki directory:
+ python_moduleinto anki
+ python_domodule locale
+
+ # not sure if this is correct, but
+ # site-packages/aqt/mediasrv.py wants the directory
+ insinto /usr/share/anki
+ doins -r web
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ optfeature "LaTeX in cards" "app-text/texlive app-text/dvipng"
+ optfeature "Record sound" "dev-python/pyaudio media-sound/lame"
+ optfeature "Playback sound" media-video/mpv media-video/mplayer
+}
diff --git a/app-misc/anki/files/anki-2.1.15-mpv-args.patch b/app-misc/anki/files/anki-2.1.15-mpv-args.patch
new file mode 100644
index 000000000000..1e8cde1083f2
--- /dev/null
+++ b/app-misc/anki/files/anki-2.1.15-mpv-args.patch
@@ -0,0 +1,26 @@
+--- a/anki/mpv.py
++++ b/anki/mpv.py
+@@ -104,9 +104,9 @@ class MPVBase:
+ """
+ self.argv = [self.executable]
+ self.argv += self.default_argv
+- self.argv += ["--input-ipc-server", self._sock_filename]
++ self.argv += ["--input-ipc-server="+self._sock_filename]
+ if self.window_id is not None:
+- self.argv += ["--wid", str(self.window_id)]
++ self.argv += ["--wid="+str(self.window_id)]
+
+ def _start_process(self):
+ """Start the mpv process.
+diff --git a/anki/sound.py b/anki/sound.py
+index aa3431b1..a5fce446 100644
+--- a/anki/sound.py
++++ b/anki/sound.py
+@@ -124,7 +124,6 @@ class MpvManager(MPV):
+ def setMpvConfigBase(base):
+ mpvConfPath = os.path.join(base, "mpv.conf")
+ MpvManager.default_argv += [
+- "--no-config",
+ "--include="+mpvConfPath,
+ ]
+