summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Sokolov <alexey+gentoo@asokolov.org>2022-08-23 00:43:14 +0100
committerPatrick McLean <chutzpah@gentoo.org>2022-08-26 16:57:01 -0700
commitaef9f1c95eb175d285128d28aada26dc29d3f762 (patch)
treecd0fcbdc65a0a367d434d12b54164540a09c973c /app-misc
parentapp-misc/openrgb: fix build with dev-cpp/nlohmann_json-3.11.2 (diff)
downloadgentoo-aef9f1c95eb175d285128d28aada26dc29d3f762.tar.gz
gentoo-aef9f1c95eb175d285128d28aada26dc29d3f762.tar.bz2
gentoo-aef9f1c95eb175d285128d28aada26dc29d3f762.zip
app-misc/openrgb: drop old
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Alexey Sokolov <alexey+gentoo@asokolov.org> Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/openrgb/Manifest1
-rw-r--r--app-misc/openrgb/files/OpenRGB-0.6-pkgconf.patch11
-rw-r--r--app-misc/openrgb/files/OpenRGB-0.6-plugins.patch24
-rw-r--r--app-misc/openrgb/openrgb-0.6-r1.ebuild75
4 files changed, 0 insertions, 111 deletions
diff --git a/app-misc/openrgb/Manifest b/app-misc/openrgb/Manifest
index 7b8c113774cc..2e2723147628 100644
--- a/app-misc/openrgb/Manifest
+++ b/app-misc/openrgb/Manifest
@@ -1,2 +1 @@
-DIST OpenRGB-release_0.6.tar.bz2 24301305 BLAKE2B 20d8f8f7a3189fd5f94b008b11c869d2a8584dc038322e4ac8649c7b57172637133dd18c05ed8eaa6907ba7c097280727a9e7ce2e676250146044bbc2d66921e SHA512 9eb090e1cab121308f3adea8c50feb819a19cb52feff29e45ec24dfbb37013421f53d2ac614496781af1ef4e612dd41c1abafec509430df7d0715aba59ee5a32
DIST OpenRGB-release_0.7.tar.bz2 28053114 BLAKE2B dfab42fca654478ab359e6e46133fc20a4bf32aca35d1b2f475d3e4e5e218f35c7e1f03be15381b0e8d874ea24254b88b8fe21548a4183b29b4c66647aeef516 SHA512 6ee605bfc91da14d34bc89fe75790f99548253e2d6aa088e20d1996577629bf15fe0fae09e65d983aa829f54cfcbd33e13f2c7d493a2776fd1723f8725b62186
diff --git a/app-misc/openrgb/files/OpenRGB-0.6-pkgconf.patch b/app-misc/openrgb/files/OpenRGB-0.6-pkgconf.patch
deleted file mode 100644
index 380b1091d225..000000000000
--- a/app-misc/openrgb/files/OpenRGB-0.6-pkgconf.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/OpenRGB.pro 2021-06-06 22:51:12.022561718 +0100
-+++ b/OpenRGB.pro 2021-06-06 22:51:24.466105358 +0100
-@@ -837,7 +837,7 @@ unix:!macx {
- # hidapi-hidraw >= 0.10.1 supports USAGE/USAGE_PAGE #
- # Define USE_HID_USAGE if hidapi-hidraw supports it #
- #---------------------------------------------------------------------------------------#
-- HIDAPI_HIDRAW_VERSION = $$system(pkgconf --modversion hidapi-hidraw)
-+ HIDAPI_HIDRAW_VERSION = $$system(pkg-config --modversion hidapi-hidraw)
- if(versionAtLeast(HIDAPI_HIDRAW_VERSION, "0.10.1")) {
- DEFINES += USE_HID_USAGE
- }
diff --git a/app-misc/openrgb/files/OpenRGB-0.6-plugins.patch b/app-misc/openrgb/files/OpenRGB-0.6-plugins.patch
deleted file mode 100644
index ccc83de27ebe..000000000000
--- a/app-misc/openrgb/files/OpenRGB-0.6-plugins.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-Allow installation of plugins not only in ~/.config
-
-Used by app-misc/openrgb-plugin-* packages
-
-diff --git a/PluginManager.cpp b/PluginManager.cpp
-index b424b8b..991fb75 100644
---- a/PluginManager.cpp
-+++ b/PluginManager.cpp
-@@ -15,7 +15,8 @@ void PluginManager::ScanAndLoadPlugins(bool dark_theme)
- \*--------------------------------------------------------------------------------------*/
- OpenRGBPluginInterface *OpenRGBPlugin = nullptr;
-
-- const QDir pluginsDir = QString().fromStdString(ResourceManager::get()->GetConfigurationDirectory()) + "plugins/";
-+ for (const QDir pluginsDir : {QString().fromStdString(ResourceManager::get()->GetConfigurationDirectory()) + "plugins/",
-+ QString().fromStdString(GENTOO_PLUGINS_DIR)}) {
-
- std::vector<std::string> FileList;
-
-@@ -54,4 +56,5 @@ void PluginManager::ScanAndLoadPlugins(bool dark_theme)
- std::cout << loader.errorString().toStdString() << std::endl;
- }
- }
-+ }
- }
diff --git a/app-misc/openrgb/openrgb-0.6-r1.ebuild b/app-misc/openrgb/openrgb-0.6-r1.ebuild
deleted file mode 100644
index b53579dca202..000000000000
--- a/app-misc/openrgb/openrgb-0.6-r1.ebuild
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 2020-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit flag-o-matic qmake-utils
-
-if [[ ${PV} == *9999* ]]; then
- inherit git-r3
- EGIT_REPO_URI=${EGIT_REPO_URI:-"https://gitlab.com/CalcProgrammer1/OpenRGB"}
-else
- SRC_URI="https://gitlab.com/CalcProgrammer1/OpenRGB/-/archive/release_${PV}/OpenRGB-release_${PV}.tar.bz2"
- S="${WORKDIR}/OpenRGB-release_${PV}"
- KEYWORDS="~amd64 ~x86"
- PATCHES=(
- "${FILESDIR}"/OpenRGB-0.5-build-system.patch
- )
-fi
-
-DESCRIPTION="Open source RGB lighting control that doesn't depend on manufacturer software"
-HOMEPAGE="https://openrgb.org https://gitlab.com/CalcProgrammer1/OpenRGB/"
-LICENSE="GPL-2"
-SLOT="0/1"
-
-RDEPEND="
- dev-libs/hidapi:=
- dev-qt/qtcore:5
- dev-qt/qtgui:5
- dev-qt/qtwidgets:5
- virtual/libusb:1
-"
-DEPEND="
- ${RDEPEND}
- dev-cpp/nlohmann_json
-"
-BDEPEND="
- virtual/pkgconfig
-"
-
-PATCHES+=(
- "${FILESDIR}"/OpenRGB-0.6-pkgconf.patch
- "${FILESDIR}"/OpenRGB-0.6-plugins.patch
-)
-
-src_prepare() {
- default
- rm -r dependencies/{hidapi,libusb,json}* || die
-}
-
-src_configure() {
- # Some plugins require symbols defined in the main binary.
- # The official build system bundles OpenRGB as a submodule instead, and
- # compiles the .cpp file again.
- append-ldflags -Wl,--export-dynamic
-
- eqmake5 \
- INCLUDEPATH+="${ESYSROOT}/usr/include/nlohmann" \
- DEFINES+="GENTOO_PLUGINS_DIR=\\\\\"\\\"${EPREFIX}/usr/$(get_libdir)/OpenRGB/plugins\\\\\"\\\""
-}
-
-src_install() {
- emake INSTALL_ROOT="${ED}" install
-
- dodoc README.md OpenRGB.patch
-
- # This is for plugins. Upstream doesn't install any headers at all.
- insinto /usr/include/OpenRGB
- doins *.h
- insinto /usr/include/OpenRGB/RGBController
- doins RGBController/*.h
- insinto /usr/include/OpenRGB/i2c_smbus
- doins i2c_smbus/*.h
- insinto /usr/include/OpenRGB/net_port
- doins net_port/*.h
-}