summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-06-18 23:03:27 +0200
committerDavid Seifert <soap@gentoo.org>2021-06-18 23:03:27 +0200
commit8d7c66e19dc3897f617c22e21db099c967dc670e (patch)
tree6ff930401edba65d3a06a957319e5a92d65c09be /app-misc
parentmedia-video/vdr: tidy up patch (diff)
downloadgentoo-8d7c66e19dc3897f617c22e21db099c967dc670e.tar.gz
gentoo-8d7c66e19dc3897f617c22e21db099c967dc670e.tar.bz2
gentoo-8d7c66e19dc3897f617c22e21db099c967dc670e.zip
app-misc/abook: fix ncurses, readline detection
* Use PKG_CHECK_MODULES (pkg-config) to detect ncurses as we shouldn't assume tinfo is _always_ split (although it usually is on Gentoo). It isn't on Prefix and it's best to be flexible. * Use more modern Autoconf Archive macro for readline which was also previously failing on Prefix (Darwin). Signed-off-by: Sam James <sam@gentoo.org> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/abook/abook-0.6.1-r2.ebuild18
-rw-r--r--app-misc/abook/files/abook-0.6.1-use-PKG_CHECK_MODULES-for-ncurses.patch44
-rw-r--r--app-misc/abook/files/abook-0.6.1-use-newer-macro-for-readline.patch31
3 files changed, 86 insertions, 7 deletions
diff --git a/app-misc/abook/abook-0.6.1-r2.ebuild b/app-misc/abook/abook-0.6.1-r2.ebuild
index deec4303f985..0d55af71738f 100644
--- a/app-misc/abook/abook-0.6.1-r2.ebuild
+++ b/app-misc/abook/abook-0.6.1-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -16,18 +16,24 @@ KEYWORDS="~alpha amd64 ppc ppc64 sparc x86"
IUSE="nls"
RDEPEND="
- sys-libs/ncurses
- sys-libs/readline
+ sys-libs/ncurses:=
+ sys-libs/readline:=
dev-libs/libvformat
nls? ( virtual/libintl )"
-DEPEND="nls? ( sys-devel/gettext )"
+DEPEND="
+ sys-devel/autoconf-archive
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )
+"
S="${WORKDIR}/${MY_P}"
DOCS=( BUGS ChangeLog FAQ README TODO sample.abookrc )
+
PATCHES=(
- "${FILESDIR}"/${PN}-0.6.1-tinfo.patch
+ "${FILESDIR}"/${PN}-0.6.1-use-PKG_CHECK_MODULES-for-ncurses.patch
+ "${FILESDIR}"/${PN}-0.6.1-use-newer-macro-for-readline.patch
"${FILESDIR}"/${PN}-0.6.1-vformat.patch
)
@@ -38,8 +44,6 @@ src_prepare() {
src_configure() {
econf \
- --with-curses \
- --with-readline \
--enable-vformat \
$(use_enable nls)
}
diff --git a/app-misc/abook/files/abook-0.6.1-use-PKG_CHECK_MODULES-for-ncurses.patch b/app-misc/abook/files/abook-0.6.1-use-PKG_CHECK_MODULES-for-ncurses.patch
new file mode 100644
index 000000000000..e6f98906af3e
--- /dev/null
+++ b/app-misc/abook/files/abook-0.6.1-use-PKG_CHECK_MODULES-for-ncurses.patch
@@ -0,0 +1,44 @@
+From: Sam James <sam@gentoo.org>
+Date: Wed, 21 Apr 2021 06:06:13 +0100
+Subject: Use PKG_CHECK_MODULES for ncurses
+
+We don't _always_ have split tinfo, e.g. Prefix.
+--- a/configure.ac
++++ b/configure.ac
+@@ -74,31 +74,9 @@ dnl -------------------
+ dnl (n)curses detection
+ dnl -------------------
+
+-abook_cv_curses=/usr
+-AC_ARG_WITH(curses, [ --with-curses=DIR Where ncurses is installed ],
+- [if test $withval != yes; then
+- abook_cv_curses=$withval
+- fi
+- if test x$abook_cv_curses != x/usr; then
+- LDFLAGS="-L${abook_cv_curses}/lib $LDFLAGS"
+- CPPFLAGS="$CPPFLAGS -I${abook_cv_curses}/include"
+- fi])
+-
+-AC_CHECK_LIB(ncursesw, initscr,
+- [LIBS="$LIBS -lncursesw"
+- if test x$abook_cv_curses = x/usr -a -d /usr/include/ncursesw; then
+- CPPFLAGS="$CPPFLAGS -I/usr/include/ncursesw"
+- fi
+- AC_CHECK_HEADERS(ncurses.h)],[
+- ac_widec_possible=no
+- AC_CHECK_LIB(ncurses, initscr,
+- [LIBS="$LIBS -lncurses"
+- if test x$abook_cv_curses = x/usr -a -d /usr/include/ncurses; then
+- CPPFLAGS="$CPPFLAGS -I/usr/include/ncurses"
+- fi
+- AC_CHECK_HEADERS(ncurses.h)],
+- [CF_CURSES_LIBS])
+- ])
++PKG_CHECK_MODULES(ncurses, ncurses)
++LDFLAGS="${ncurses_LIBS} $LDFLAGS"
++CPPFLAGS="${ncurses_CFLAGS} $CPPFLAGS"
+
+ dnl --------------------------
+ dnl end of (n)curses detection
+--
+
diff --git a/app-misc/abook/files/abook-0.6.1-use-newer-macro-for-readline.patch b/app-misc/abook/files/abook-0.6.1-use-newer-macro-for-readline.patch
new file mode 100644
index 000000000000..1a35e636964d
--- /dev/null
+++ b/app-misc/abook/files/abook-0.6.1-use-newer-macro-for-readline.patch
@@ -0,0 +1,31 @@
+From: Sam James <sam@gentoo.org>
+Date: Wed, 21 Apr 2021 06:20:13 +0100
+Subject: Use more modern autoconf archive macro for readline
+
+The previous macro used was pretty obsolete and certainly didn't work
+on Gentoo Prefix on Darwin anyway.
+--- a/configure.ac
++++ b/configure.ac
+@@ -86,19 +86,9 @@ dnl ------------------
+ dnl readline detection
+ dnl ------------------
+
+-abook_cv_readline=/usr
+-AC_ARG_WITH(readline, [ --with-readline=DIR Where readline is installed ],
+- [if test $withval != yes; then
+- abook_cv_readline=$withval
+- fi
+- if test x$abook_cv_readline != x/usr; then
+- LDFLAGS="-L${abook_cv_readline}/lib $LDFLAGS"
+- CPPFLAGS="$CPPFLAGS -I${abook_cv_readline}/include"
+- fi])
+-
+-AC_LIB_READLINE
+-
+-if test x$ac_cv_lib_readline = xno -o x$ac_cv_lib_readline_history = xno; then
++AX_LIB_READLINE
++
++if test x$ax_cv_lib_readline = xno -o x$ax_cv_lib_readline_history = xno; then
+ AC_MSG_ERROR([*** readline library not found or it doesn't support history ***])
+ fi
+