summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPunarbasu Purkayastha <ppurka@gmail.com>2022-07-30 10:41:41 +0800
committerJoonas Niilola <juippis@gentoo.org>2022-08-17 20:11:29 +0300
commit8d2bb6145e7430d98985ae51aed0bacda910d51f (patch)
tree59c9ec56d9ba2da529fc6162b17c7b66e77dc854 /app-misc
parentapp-backup/backup-manager: drop 0.7.14 (diff)
downloadgentoo-8d2bb6145e7430d98985ae51aed0bacda910d51f.tar.gz
gentoo-8d2bb6145e7430d98985ae51aed0bacda910d51f.tar.bz2
gentoo-8d2bb6145e7430d98985ae51aed0bacda910d51f.zip
app-misc/recoll: Version bump to 1.32.5
Closes: https://bugs.gentoo.org/860132 Signed-off-by: Punarbasu Purkayastha <ppurka@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/26661 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/recoll/Manifest1
-rw-r--r--app-misc/recoll/recoll-1.32.5.ebuild127
2 files changed, 128 insertions, 0 deletions
diff --git a/app-misc/recoll/Manifest b/app-misc/recoll/Manifest
index 8cb0361cd729..ab09b441605a 100644
--- a/app-misc/recoll/Manifest
+++ b/app-misc/recoll/Manifest
@@ -1,3 +1,4 @@
DIST recoll-1.31.0.tar.gz 3679099 BLAKE2B 6d02c0e0487ff02957ffc3c824152a14307e5a9ebfd472ffb84d047ce37f170ff7738b0d15ccfd6582840d22d19aa6e509ca50b98fd88d1a3730e58304cdb4b1 SHA512 1a740cdabab158737461ab8f097ece79844e1f0b64285871217049c0619df400d99db18eac8942e1986def555c5ab8364f3320eb403d150b061126cbc3be2116
DIST recoll-1.32.0.tar.gz 3622960 BLAKE2B 74adc5861d7eeaa3240471444622a4cf638a111bc79aa7ea372c49e63732b06c011f2ae627130da84aaa9a3df42d8c64d4a65d2d83db2ebb20c21bf7820b06f6 SHA512 4a2edf3b9ef7048352bb7c8547138b8e21597f362f8ca058218c99400c841a5a80f948ab5ff51209ae66010c8d35d5b136e8b7e09284d1c70665b4641cc4c9da
DIST recoll-1.32.2.tar.gz 3648813 BLAKE2B 091df122d9d484ad2247a96da2a376cf0884349ab57e4be4cf31bc2abd175741cc1eb82084706f23445f1b47f13a5819916e2d48f10e4fab6e498bb34e99eea4 SHA512 6e0c51867306cd13cb09fcdebc60d8fef97ab680d22425eb58e398ab4d119bf58e19e21e986309ade25a4d6fe2ff0d33eaa44826fcddc2f5d401df159c3f865f
+DIST recoll-1.32.5.tar.gz 3647176 BLAKE2B e2f6ed2866283cf2f3f0c70612c2d3b0ac26c5a6ef559d8ff0f5ff027c04d0878623597ba23d8cad73f9f0ee0ba869b66166e193b836e7b23695b14c494a45fa SHA512 ea7242d7a3cbba66bb9f90523388b097263b370a1f11b09e5ad63ac58cdcea74db1ae17e312b81efcda6cfd856c02b7f961a57dbacd7c5b6b1a76f9afa89622e
diff --git a/app-misc/recoll/recoll-1.32.5.ebuild b/app-misc/recoll/recoll-1.32.5.ebuild
new file mode 100644
index 000000000000..59a495aceb67
--- /dev/null
+++ b/app-misc/recoll/recoll-1.32.5.ebuild
@@ -0,0 +1,127 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit linux-info optfeature python-single-r1 qmake-utils systemd
+
+DESCRIPTION="Personal full text search package"
+HOMEPAGE="https://www.lesbonscomptes.com/recoll/"
+SRC_URI="https://www.lesbonscomptes.com/recoll/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="camelcase chm +inotify qt5 session +spell systemd webengine"
+REQUIRED_USE="
+ session? ( inotify )
+ webengine? ( qt5 )
+ ${PYTHON_REQUIRED_USE}
+"
+
+DEPEND="
+ dev-libs/libxml2
+ dev-libs/libxslt
+ dev-libs/xapian:=
+ sys-libs/zlib
+ virtual/libiconv
+ chm? (
+ dev-libs/chmlib
+ dev-python/pychm
+ )
+ qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtwidgets:5
+ webengine? ( dev-qt/qtwebengine:5[widgets] )
+ )
+ session? (
+ inotify? (
+ x11-libs/libSM
+ x11-libs/libICE
+ x11-libs/libX11
+ )
+ )
+ spell? ( app-text/aspell )
+ systemd? ( sys-apps/systemd )
+ ${PYTHON_DEPS}
+"
+
+BDEPEND="
+ qt5? ( dev-qt/linguist-tools:5 )
+"
+
+RDEPEND="
+ ${DEPEND}
+ app-arch/unzip
+"
+
+pkg_setup() {
+ if use inotify; then
+ local CONFIG_CHECK="~INOTIFY_USER"
+ check_extra_config
+ fi
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ python_fix_shebang filters
+}
+
+src_configure() {
+ use qt5 && export QMAKE="$(qt5_get_bindir)/qmake"
+
+ local myeconfargs=(
+ $(use_enable camelcase)
+ $(use_enable chm python-chm)
+ $(use_enable session x11mon)
+ $(use_enable qt5 qtgui)
+ $(use_enable webengine)
+ $(use_with inotify)
+ $(use_with spell aspell)
+ $(use_with systemd)
+ --with-system-unit-dir="$(systemd_get_systemunitdir)"
+ --with-user-unit-dir="$(systemd_get_userunitdir)"
+ --disable-webkit
+ --without-fam
+ --enable-recollq
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ emake STRIP="$(type -P true || die)" DESTDIR="${D}" install
+ python_optimize
+
+ # html docs should be placed in /usr/share/doc/${PN}/html
+ dodoc -r "${ED}"/usr/share/recoll/doc/.
+ rm -r "${ED}/usr/share/recoll/doc" || die
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ optfeature "XML based documents support" "dev-libs/libxslt[python] dev-libs/libxml2[python]"
+ optfeature "PDF files support" app-text/poppler
+ optfeature "PDF files with OCR support" app-text/tesseract
+ optfeature "MS Word files support" app-text/antiword
+ optfeature "Wordperfect files support" "app-text/libwpd[tools]"
+ optfeature "Lyx files support" app-office/lyx
+ optfeature "GNU Info files support" sys-apps/texinfo
+ optfeature "RAR archives support" dev-python/rarfile
+ optfeature "7zip archives support" dev-python/pylzma
+ optfeature "iCalendar files support" dev-python/icalendar
+ optfeature "Postscript files support" app-text/pstotext
+ optfeature "RTF files support" app-text/unrtf
+ optfeature "TeX files support" dev-text/detex
+ optfeature "DVI files support" virtual/tex-base
+ optfeature "DJVU files support" app-text/djvu
+ optfeature "tags in audio files support" media-libs/mutagen
+ optfeature "tags in image files support" media-libs/exiftool
+ optfeature "Midi karaoke files support" dev-python/chardet
+}