summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBailey Kasin <baileykasin@gmail.com>2023-10-20 00:11:04 -0700
committerJoonas Niilola <juippis@gentoo.org>2023-10-20 10:29:45 +0300
commit6fb8c321abb5af9f53eb29c66c4abe7c457fe4b2 (patch)
treee3ef2a4600a2f0d73d223c1bce92b1611c505a5c /app-misc
parentnet-libs/gsoap: Fix incompatible integer to pointer conversion (diff)
downloadgentoo-6fb8c321abb5af9f53eb29c66c4abe7c457fe4b2.tar.gz
gentoo-6fb8c321abb5af9f53eb29c66c4abe7c457fe4b2.tar.bz2
gentoo-6fb8c321abb5af9f53eb29c66c4abe7c457fe4b2.zip
app-misc/hyfetch: new package, add 1.4.10, 9999
Closes: https://github.com/gentoo/gentoo/pull/32681 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/hyfetch/Manifest1
-rw-r--r--app-misc/hyfetch/files/hyfetch-1.4.10-config_fix.patch15
-rw-r--r--app-misc/hyfetch/hyfetch-1.4.10.ebuild40
-rw-r--r--app-misc/hyfetch/hyfetch-9999.ebuild36
-rw-r--r--app-misc/hyfetch/metadata.xml19
5 files changed, 111 insertions, 0 deletions
diff --git a/app-misc/hyfetch/Manifest b/app-misc/hyfetch/Manifest
new file mode 100644
index 000000000000..3a5f627eff09
--- /dev/null
+++ b/app-misc/hyfetch/Manifest
@@ -0,0 +1 @@
+DIST hyfetch-1.4.10.tar.gz 266471 BLAKE2B 294002c2cd986055f6392aa61bb8de1d3d558712cd327243e7c2e756aa6e00ff23372fd0ffcc60db8f978110a3d8d1d78c6f683e304fc65b19d2f076e10347f2 SHA512 3f44bd9c0b030b435949db0c0cbd4913e7ec15e857df0dcf2fc3b7d10dca0a4c8ecb9862157f60eebd15b7a1c233c51a74f341b440892e0925871e42215c80e0
diff --git a/app-misc/hyfetch/files/hyfetch-1.4.10-config_fix.patch b/app-misc/hyfetch/files/hyfetch-1.4.10-config_fix.patch
new file mode 100644
index 000000000000..955eaf60ca30
--- /dev/null
+++ b/app-misc/hyfetch/files/hyfetch-1.4.10-config_fix.patch
@@ -0,0 +1,15 @@
+check_config uses the global constant CONFIG_PATH instead
+of the path that gets passed to it.
+
+--- a/hyfetch/main.py
++++ b/hyfetch/main.py
+@@ -27,7 +27,7 @@ def check_config(path) -> Config:
+ """
+ if path.is_file():
+ try:
+- return Config.from_dict(json.loads(CONFIG_PATH.read_text('utf-8')))
++ return Config.from_dict(json.loads(path.read_text('utf-8')))
+ except KeyError:
+ return create_config()
+
+
diff --git a/app-misc/hyfetch/hyfetch-1.4.10.ebuild b/app-misc/hyfetch/hyfetch-1.4.10.ebuild
new file mode 100644
index 000000000000..076daa812814
--- /dev/null
+++ b/app-misc/hyfetch/hyfetch-1.4.10.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..12} )
+inherit optfeature distutils-r1
+
+DESCRIPTION="Neofetch with LGBTQ+ pride flags!"
+HOMEPAGE="https://github.com/hykilpikonna/hyfetch"
+if [[ ${PV} == *9999 ]]; then
+ EGIT_REPO_URI="https://github.com/hykilpikonna/hyfetch.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/hykilpikonna/${PN}/archive/${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.4.10-config_fix.patch
+)
+
+pkg_postinst() {
+ optfeature "displaying images" "media-libs/imlib2 www-client/w3m[imlib]"
+ optfeature "gpu detection" sys-apps/pciutils
+ optfeature "thumbnail creation" media-gfx/imagemagick
+ optfeature "wallpaper" media-gfx/feh x11-misc/nitrogen
+ optfeature "window size" x11-misc/xdotool "x11-apps/xwininfo x11-apps/xprop" "x11-apps/xwininfo x11-apps/xdpyinfo"
+ elog "The standard neofetch is installed as 'neowofetch', to avoid name conflicts."
+ elog "So if you do not wish to use the pride flag functionality, you can call the"
+ elog "tool that way instead."
+}
diff --git a/app-misc/hyfetch/hyfetch-9999.ebuild b/app-misc/hyfetch/hyfetch-9999.ebuild
new file mode 100644
index 000000000000..c73d6a446e80
--- /dev/null
+++ b/app-misc/hyfetch/hyfetch-9999.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..12} )
+inherit optfeature distutils-r1
+
+DESCRIPTION="Neofetch with LGBTQ+ pride flags!"
+HOMEPAGE="https://github.com/hykilpikonna/hyfetch"
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/hykilpikonna/hyfetch.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/hykilpikonna/${PN}/archive/${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+"
+
+pkg_postinst() {
+ optfeature "displaying images" "media-libs/imlib2 www-client/w3m[imlib]"
+ optfeature "gpu detection" sys-apps/pciutils
+ optfeature "thumbnail creation" media-gfx/imagemagick
+ optfeature "wallpaper" media-gfx/feh x11-misc/nitrogen
+ optfeature "window size" x11-misc/xdotool "x11-apps/xwininfo x11-apps/xprop" "x11-apps/xwininfo x11-apps/xdpyinfo"
+ elog "The standard neofetch is installed as 'neowofetch', to avoid name conflicts."
+ elog "So if you do not wish to use the pride flag functionality, you can call the"
+ elog "tool that way instead."
+}
diff --git a/app-misc/hyfetch/metadata.xml b/app-misc/hyfetch/metadata.xml
new file mode 100644
index 000000000000..3a8c9e49c124
--- /dev/null
+++ b/app-misc/hyfetch/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>baileykasin@gmail.com</email>
+ <name>Bailey Kasin</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription lang="en"> hyfetch builds upon neofetch to add pride flag coloration to the OS
+ logo, and also maintains the standard version of neofetch with bug fixes and new features,
+ as the original project is un-maintained. </longdescription>
+ <upstream>
+ <remote-id type="github">hykilpikonna/hyfetch</remote-id>
+ <bugs-to>https://github.com/hykilpikonna/hyfetch/issues</bugs-to>
+ </upstream>
+</pkgmetadata>