summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZoltan Puskas <zoltan@sinustrom.info>2021-02-25 01:17:35 -0800
committerJoonas Niilola <juippis@gentoo.org>2021-03-05 18:17:29 +0200
commit6bfdc5eb222b77e499da6d5cc25bf53c232b38c6 (patch)
tree881f09aad0613dc1aef1d8b80696f5a43d6980ba /app-misc
parentnet-print/cnrdrvcups-lb: remove whitespace (diff)
downloadgentoo-6bfdc5eb222b77e499da6d5cc25bf53c232b38c6.tar.gz
gentoo-6bfdc5eb222b77e499da6d5cc25bf53c232b38c6.tar.bz2
gentoo-6bfdc5eb222b77e499da6d5cc25bf53c232b38c6.zip
app-misc/trash-cli: Bump to 0.20.12.26
Closes: https://bugs.gentoo.org/772122 Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Zoltan Puskas <zoltan@sinustrom.info> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/trash-cli/Manifest1
-rw-r--r--app-misc/trash-cli/trash-cli-0.20.12.26.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/app-misc/trash-cli/Manifest b/app-misc/trash-cli/Manifest
index 88b99eed046c..b435c157e0ed 100644
--- a/app-misc/trash-cli/Manifest
+++ b/app-misc/trash-cli/Manifest
@@ -1,2 +1,3 @@
DIST trash-cli-0.17.1.14_p20170816.tar.gz 69713 BLAKE2B f995c22ba0704eba96abac2c130f9118cc98ad5c5f21903601ea60ee1f52c594b7f8b16ebcaabb4b34086f5f9f66ad02cd628c379ed5139bcb1f691016b435ab SHA512 9d35620b55c63b53b7255179a6304f4d7190c2a90f68c102f64b9616ee897460939633e9c77826968a1682fc5fa090b0f3ea1daad82a44cc96704dc54da45dcd
DIST trash-cli-0.20.11.23.tar.gz 69229 BLAKE2B f3650a037f00e6ce8cd7bd1ff5f3e11c794ceb09563193e2930eb9b81cd40120dd48f117e8c96d900a8221db9a68360ff633e591367bd544ad07045b1a505304 SHA512 d370687da706677de61c0d234d4cb4db4ff4d9da8cde60c361d11eaccf319e2e418969a7d49ec6edd456524b1275b63d1fcd49bc9a9012afabda1c7a8ad7de78
+DIST trash-cli-0.20.12.26.tar.gz 74542 BLAKE2B 558e3cc043cdaef44bf68317e666c6f757daf9feeb6b731a57aba91ec983e1adb1e404f7e8428a7bd1225d83df6e94e8b9b793942bbb233f09a44127af0a42fa SHA512 d0b0a97014c888ddda95759dc82837385a2809cae04bdf6a84dcf0233dc2cf9370253110bc5fdbc5c4452ebb65c5e7836fe1cfaa9aaabe38d34269724456cd1c
diff --git a/app-misc/trash-cli/trash-cli-0.20.12.26.ebuild b/app-misc/trash-cli/trash-cli-0.20.12.26.ebuild
new file mode 100644
index 000000000000..4c1b99fd98bf
--- /dev/null
+++ b/app-misc/trash-cli/trash-cli-0.20.12.26.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+DISTUTILS_USE_SETUPTOOLS=no
+
+inherit distutils-r1
+
+DESCRIPTION="Python scripts to manipulate trash cans via the command line"
+HOMEPAGE="https://github.com/andreafrancia/trash-cli"
+SRC_URI="https://github.com/andreafrancia/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests nose