summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-misc/worker
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-misc/worker')
-rw-r--r--app-misc/worker/Manifest1
-rw-r--r--app-misc/worker/metadata.xml17
-rw-r--r--app-misc/worker/worker-2.19.6.ebuild55
3 files changed, 73 insertions, 0 deletions
diff --git a/app-misc/worker/Manifest b/app-misc/worker/Manifest
new file mode 100644
index 000000000000..dce63adb0a54
--- /dev/null
+++ b/app-misc/worker/Manifest
@@ -0,0 +1 @@
+DIST worker-2.19.6.tar.bz2 1191546 SHA256 25998018bd3b50819cf2bbb35c3c2f0eb6449efd6b9da84f2f39c3e0570d188e SHA512 401c986ff532c225cbd183afd8424e900ed8ff874368d68cb985136d130b5a4d4746a59e391ba01ae610eacd4fec0d76061ba967112b8262e4a9297599596b60 WHIRLPOOL 1b209710fd0c47d565eb85d7f631cd31690314139793428ab9d8105a31d0ac940011622bf6f56951be96e193c5291d8b9a9ab325058117d23a84cd4b75f32320
diff --git a/app-misc/worker/metadata.xml b/app-misc/worker/metadata.xml
new file mode 100644
index 000000000000..dd6a7aa850ba
--- /dev/null
+++ b/app-misc/worker/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+</maintainer>
+<longdescription>
+ Worker is a filemanager for X-Window on UNIX.
+ It's a clone of the filemanager "Directory Opus 4", a very famous program
+ for Amiga-systems. The dirs and files are shown in two independent panels
+ (similar to MidnightCommander).
+</longdescription>
+<use>
+ <flag name='avfs'>Enable support for <pkg>sys-fs/avfs</pkg></flag>
+ <flag name='magic'>Add magic file support from <pkg>sys-apps/file</pkg> to automatically detect file types</flag>
+</use>
+</pkgmetadata>
diff --git a/app-misc/worker/worker-2.19.6.ebuild b/app-misc/worker/worker-2.19.6.ebuild
new file mode 100644
index 000000000000..61b49f61a231
--- /dev/null
+++ b/app-misc/worker/worker-2.19.6.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Worker Filemanager: Amiga Directory Opus 4 clone"
+HOMEPAGE="http://www.boomerangsworld.de/cms/worker/"
+SRC_URI="http://www.boomerangsworld.de/cms/worker/downloads/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~hppa ppc ~ppc64 x86"
+IUSE="avfs debug dbus examples libnotify +magic xinerama xft"
+
+RDEPEND="x11-libs/libSM
+ x11-libs/libX11
+ avfs? ( >=sys-fs/avfs-0.9.5 )
+ dbus? ( dev-libs/dbus-glib )
+ magic? ( sys-apps/file )
+ xft? ( x11-libs/libXft )
+ xinerama? ( x11-libs/libXinerama )"
+DEPEND="${RDEPEND}"
+
+DOCS=( AUTHORS ChangeLog INSTALL NEWS README README_LARGEFILES THANKS )
+
+src_prepare() {
+ # respect AR, bug #466014
+ sed -i -e "/AR/s/ar/$(tc-getAR)/" src/aguix/Makefile.in || die 'sed on Makefile.in failed'
+
+ epatch_user
+}
+
+src_configure() {
+ # there is no option for disabling libXinerama support
+ use xinerama || export ac_cv_lib_Xinerama_XineramaQueryScreens=no
+ econf \
+ --without-hal \
+ $(use_with avfs) \
+ $(use_with dbus) \
+ $(use_enable debug) \
+ $(use_enable libnotify inotify) \
+ $(use_with magic libmagic) \
+ $(use_enable xft)
+}
+
+src_install() {
+ default
+ if use examples; then
+ docinto examples
+ dodoc examples/config-*
+ fi
+}