summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Leupold <tl@stonemx.de>2022-10-02 15:49:12 +0200
committerJoonas Niilola <juippis@gentoo.org>2022-10-12 19:23:30 +0300
commit1ea69eb2fb376d52a6804a8e355b319dbcc4aa67 (patch)
tree20411bde4ad8efe860c6bd7b47e1b8f5b59f0e83 /app-misc/vcontrold
parentmedia-sound/klick: remove old (diff)
downloadgentoo-1ea69eb2fb376d52a6804a8e355b319dbcc4aa67.tar.gz
gentoo-1ea69eb2fb376d52a6804a8e355b319dbcc4aa67.tar.bz2
gentoo-1ea69eb2fb376d52a6804a8e355b319dbcc4aa67.zip
app-misc/vcontrold: version bump to 0.98.11
Signed-off-by: Tobias Leupold <tl@stonemx.de> Closes: https://github.com/gentoo/gentoo/pull/27575 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-misc/vcontrold')
-rw-r--r--app-misc/vcontrold/Manifest1
-rw-r--r--app-misc/vcontrold/vcontrold-0.98.11.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/app-misc/vcontrold/Manifest b/app-misc/vcontrold/Manifest
index 40e25b659b47..a713563fe75a 100644
--- a/app-misc/vcontrold/Manifest
+++ b/app-misc/vcontrold/Manifest
@@ -1 +1,2 @@
DIST vcontrold-0.98.10.tar.gz 87721 BLAKE2B 06111f534d137d08f0a66b00f1238dd04856c3a7dbe630baeed89667de2840cfa6d9227a899b3ce4819accccd8d2228ef7e31e9562e1bb21027a3ddd2fe2b148 SHA512 4e65c23edd2542323a2815154544c2a4376c35a49a52168d6a3a08dba68f462dbd9c0c43020f86a4cb6c4eb7736b5d9460c2e4e2a67c015e2e51841338547c55
+DIST vcontrold-0.98.11.tar.gz 108805 BLAKE2B ff9cde5fb807a67a891bdf0feeb692c88f52d2960eef77d12153602bd18588489f08a03ef2c4d6d847d30e2b19870453a48800cdc28f40e8797dda50d3601b3f SHA512 28693472897bae695cd2bab23bc0abd8fa0b85dcf1816983f6876b99a78114f81e5e64f199ca646bd37b6f1603c3824485c78d73e289cf5dbf702c22ed5100dc
diff --git a/app-misc/vcontrold/vcontrold-0.98.11.ebuild b/app-misc/vcontrold/vcontrold-0.98.11.ebuild
new file mode 100644
index 000000000000..e6de901e68b8
--- /dev/null
+++ b/app-misc/vcontrold/vcontrold-0.98.11.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit cmake python-any-r1
+
+DESCRIPTION="Daemon for communication with Viessmann Vito heatings"
+HOMEPAGE="https://github.com/openv/vcontrold/"
+SRC_URI="https://github.com/openv/vcontrold/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="+man +vclient vsim"
+
+DEPEND="dev-libs/libxml2:2"
+RDEPEND="${DEPEND}"
+BDEPEND="man? ( $(python_gen_any_dep 'dev-python/docutils[${PYTHON_USEDEP}]') )"
+
+src_prepare() {
+ sed "s/@VERSION@/${PV}/" "src/version.h.in" \
+ > "src/version.h" || die "Setting version failed"
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DMANPAGES="$(usex man)"
+ -DVCLIENT="$(usex vclient)"
+ -DVSIM="$(usex vsim)"
+ )
+
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+ doinitd "${FILESDIR}/vcontrold"
+ insinto /etc/vcontrold/
+ doins -r xml
+}