summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2023-04-10 14:03:56 -0700
committerPatrick McLean <chutzpah@gentoo.org>2023-04-10 14:04:42 -0700
commite82cf2e815e26c565ab1f1b0a583ff17ebf6a534 (patch)
tree8cdadaf99e737bd6f4f35c3f8441e507471defe7 /app-misc/tmuxp/tmuxp-1.27.1.ebuild
parentdev-ruby/faraday: Stabilize 2.7.2 amd64, #904121 (diff)
downloadgentoo-e82cf2e815e26c565ab1f1b0a583ff17ebf6a534.tar.gz
gentoo-e82cf2e815e26c565ab1f1b0a583ff17ebf6a534.tar.bz2
gentoo-e82cf2e815e26c565ab1f1b0a583ff17ebf6a534.zip
app-misc/tmuxp: add 1.27.1
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'app-misc/tmuxp/tmuxp-1.27.1.ebuild')
-rw-r--r--app-misc/tmuxp/tmuxp-1.27.1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/app-misc/tmuxp/tmuxp-1.27.1.ebuild b/app-misc/tmuxp/tmuxp-1.27.1.ebuild
new file mode 100644
index 000000000000..9a1ee04e2a23
--- /dev/null
+++ b/app-misc/tmuxp/tmuxp-1.27.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2019-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_PEP517=poetry
+inherit distutils-r1
+
+DESCRIPTION="tmux session manager. built on libtmux"
+HOMEPAGE="https://tmuxp.git-pull.com"
+SRC_URI="https://github.com/tmux-python/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+RDEPEND="
+ >=app-misc/tmux-3.0a
+ =dev-python/libtmux-0.21.0*[${PYTHON_USEDEP}]
+ >=dev-python/colorama-0.3.9[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-6.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ >=dev-python/pytest-rerunfailures-4.2[${PYTHON_USEDEP}]
+ >=dev-python/tomli-1.1.0[${PYTHON_USEDEP}]
+ !dev-python/flaky
+ )
+"
+
+EPYTEST_DESELECT=(
+ # test doesn't get along with sandbox
+ "tests/cli/test_load.py::test_load_zsh_autotitle_warning"
+)
+
+distutils_enable_tests pytest
+
+python_test() {
+ SHELL="/bin/bash" epytest tests
+}