summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2016-02-22 11:34:23 +0800
committerYixun Lan <dlan@gentoo.org>2016-02-22 11:34:23 +0800
commit333c7fa94468f155d7ea5ad457756c406d38c3e7 (patch)
tree9db5a5cf9f79723519775058e33029812f23155d /app-misc/tmate
parentdev-util/cscope: add ~arm64 keyword (diff)
downloadgentoo-333c7fa94468f155d7ea5ad457756c406d38c3e7.tar.gz
gentoo-333c7fa94468f155d7ea5ad457756c406d38c3e7.tar.bz2
gentoo-333c7fa94468f155d7ea5ad457756c406d38c3e7.zip
app-misc/tmate: new 2.2.0 added
Gentoo-bug: 498692 initial version contributed by Jayson Reis (jaysonsantos) at sunrise overlay, and slightly improved by me Package-Manager: portage-2.2.27
Diffstat (limited to 'app-misc/tmate')
-rw-r--r--app-misc/tmate/Manifest2
-rw-r--r--app-misc/tmate/metadata.xml8
-rw-r--r--app-misc/tmate/tmate-2.2.0.ebuild52
3 files changed, 62 insertions, 0 deletions
diff --git a/app-misc/tmate/Manifest b/app-misc/tmate/Manifest
new file mode 100644
index 000000000000..58de49634b78
--- /dev/null
+++ b/app-misc/tmate/Manifest
@@ -0,0 +1,2 @@
+DIST tmate-2.2.0-upstream-patches-0.tar.xz 6784 SHA256 aa5b0ca858bb652418aa5200f0f5dcda0827295c16fb73fd34594d718a65878a SHA512 3e16e0b7988d3d1942fcac0a535d2cc8d7156d26332dc84fd21c4761afae40159282b0fbeb71cd5f6525b5a1c7a46e7813c8e6a11851592077570c1a001a73a7 WHIRLPOOL fb05b5d90f2542bb2e8fdc8c5df988338d5626bd48899697b8c16b9078ca71d2b2682c648f5f7c37ed8cd4a9966b1c6d5524823b34a4ac4cb9833a62325bb39c
+DIST tmate-2.2.0.tar.gz 610793 SHA256 932148b24d9c67e524ce744c9480b5603c9f976afb6ad7ca6d63246cd9e7fd3a SHA512 e9429833cdb8c28873d01bfc6b9a0d1241e30346ef1b3efae6763389c8444943b831283c1ea65e49c68d11936d6586186b38e0f7c14d373d9f63e841026c3338 WHIRLPOOL e1a2203e9a63466244d9d61e6e06d4dea77a9eb3e7069c1c87c115e5ce370e3b3b7ad2d7fc8b4c740030ee980b4d52833066f853a05d1c611a5d5c4810c89a36
diff --git a/app-misc/tmate/metadata.xml b/app-misc/tmate/metadata.xml
new file mode 100644
index 000000000000..3398ef8b263c
--- /dev/null
+++ b/app-misc/tmate/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>dlan@gentoo.org</email>
+ <name>Yixun Lan</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/app-misc/tmate/tmate-2.2.0.ebuild b/app-misc/tmate/tmate-2.2.0.ebuild
new file mode 100644
index 000000000000..f58ded2db269
--- /dev/null
+++ b/app-misc/tmate/tmate-2.2.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=1
+inherit eutils autotools-utils
+
+DESCRIPTION="Instant terminal sharing"
+HOMEPAGE="http://tmate.io/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug static-libs"
+
+UPSTREAM_VER=0
+[[ -n ${UPSTREAM_VER} ]] && \
+ UPSTREAM_PATCHSET_URI="https://dev.gentoo.org/~dlan/distfiles/${P}-upstream-patches-${UPSTREAM_VER}.tar.xz"
+SRC_URI="https://github.com/tmate-io/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz
+ ${UPSTREAM_PATCHSET_URI}"
+
+RDEPEND="
+ sys-libs/zlib[static-libs?]
+ dev-libs/openssl[static-libs?]
+ dev-libs/libevent[static-libs?]
+ dev-libs/msgpack[static-libs?]
+ >=net-libs/libssh-0.6.0[static-libs?]
+"
+DEPEND="${RPDEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ # Upstream's patchset
+ if [[ -n ${UPSTREAM_VER} ]]; then
+ einfo "Try to apply tmate Upstream patch set"
+ EPATCH_SUFFIX="patch" \
+ EPATCH_FORCE="yes" \
+ EPATCH_OPTS="-p1" \
+ epatch "${WORKDIR}"/patches-upstream
+ fi
+
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable debug)
+ )
+ autotools-utils_src_configure
+}