summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Denoncin <ddenoncin@gmail.com>2020-07-22 11:36:25 +0200
committerJoonas Niilola <juippis@gentoo.org>2020-08-16 11:00:58 +0300
commit3e7575aba789ceeecfe8b18916698b9d306f02f1 (patch)
tree9c2fd5b7650908a3b9aa3ce32c671a12fedf4719 /app-misc/timew
parentapp-misc/timew: new package maintainer (diff)
downloadgentoo-3e7575aba789ceeecfe8b18916698b9d306f02f1.tar.gz
gentoo-3e7575aba789ceeecfe8b18916698b9d306f02f1.tar.bz2
gentoo-3e7575aba789ceeecfe8b18916698b9d306f02f1.zip
app-misc/timew: vbump 1.3.0, EAPI 7
Package-Manager: Portage-2.3.103, Repoman-2.3.22 Signed-off-by: David Denoncin <ddenoncin@gmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-misc/timew')
-rw-r--r--app-misc/timew/Manifest1
-rw-r--r--app-misc/timew/timew-1.3.0.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/app-misc/timew/Manifest b/app-misc/timew/Manifest
index 0470c1cbfb85..c1c08e29e959 100644
--- a/app-misc/timew/Manifest
+++ b/app-misc/timew/Manifest
@@ -1,3 +1,4 @@
DIST timew-1.0.0.tar.gz 140539 BLAKE2B 486c1e99a587597a040e3fb45c15602e56798b5a13ce3f47fb8d73b3995ee270ef2601e49dc4efe3023d1179a111b55c50c92a3feece87d9bad6a26123dc9008 SHA512 0539ff93b2375c154d126c39aa84f21b57b62f51c220c80b2e323a4d6aefd2eda6f87c04112e096222102b019ee3683a78b9ee9d6fbf6736d4a34c529f6152f5
DIST timew-1.1.1.tar.gz 166484 BLAKE2B 64b8560220550299c76207873184252b1100d146ac745e46f38790a90294c59e5da95852836433f1d5213a2f1272063a534c20b2963a88fbaa1bcb888e40b70b SHA512 d262227d6dc99994599252c9fc55d32e4caac9d5ff1f223b8637005ed9f4f7fa238bd5cb7392c8e42a468f6246a7afad9b6fdb02af636e53d3bd813cfc3ee110
DIST timew-1.2.0.tar.gz 181477 BLAKE2B 03c815dddbcc1801bd5d6849b4a6b97291ccfcae98421a3c89582b97b0214e57886a2ed485b506aafd11e16e5e8444bcfe6f457289598eb1ac671ac85004b5df SHA512 e576aff06dde1e3d5d46f4a9a425991c91c8484aa8f2eeeb8dda7a4bd40716863432740e7810c2acb43adf223a090af4e95d77994ceba03c043c57bcab745c21
+DIST timew-1.3.0.tar.gz 1125892 BLAKE2B 7ef9f6f405d710addd90758ea1188678aa3269354f81be583f63eb920c0163d0a428e9b62d896ba189f842494835df785e1f26d877bda03205a94067af8456d0 SHA512 38bf44c83d2315155ee43085957824db69d9501abf2cf0bdf51636169043d82b701ebfac3176bc1dfc0186abb7db7a3a40111968c85597e7edb73c66083f0ab0
diff --git a/app-misc/timew/timew-1.3.0.ebuild b/app-misc/timew/timew-1.3.0.ebuild
new file mode 100644
index 000000000000..86785cd3972f
--- /dev/null
+++ b/app-misc/timew/timew-1.3.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Tracks your time from the command line, and generates reports"
+HOMEPAGE="https://timewarrior.net"
+SRC_URI="https://github.com/GothenburgBitFactory/timewarrior/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_configure() {
+ mycmakeargs=(
+ -DCMAKE_BUILD_TYPE=release
+ -DTIMEW_DOCDIR=share/doc/"${PF}"
+ )
+
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+
+ dodoc -r ext
+ docompress -x /usr/share/doc/${PF}/ext/{on-modify.timewarrior,README}
+}
+
+pkg_postinst() {
+ elog "To integrate timewarrior with taskwarrior, issue the following commands:"
+ elog "cp /usr/share/doc/${PF}/ext/on-modify.timewarrior ~/.task/hooks/"
+ elog "chmod +x ~/.task/hooks/on-modify.timewarrior"
+ elog "see https://timewarrior.net/docs/taskwarrior.html"
+}