summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2023-02-26 21:27:27 +0100
committerLouis Sautier <sbraz@gentoo.org>2023-02-26 21:31:27 +0100
commit1996c841ed565836c1633515175c7ecb40ec370c (patch)
treec689b453c53b4259f530d9e46ea1531a2494966a /app-misc/rmlint
parentapp-editors/emacs: Fix multiple command injection vulnerabilities (diff)
downloadgentoo-1996c841ed565836c1633515175c7ecb40ec370c.tar.gz
gentoo-1996c841ed565836c1633515175c7ecb40ec370c.tar.bz2
gentoo-1996c841ed565836c1633515175c7ecb40ec370c.zip
app-misc/rmlint: add Python 3.11, fix GUI installation
Also: * remove redundant eclass inherit. * switch to EAPI 8. Closes: https://bugs.gentoo.org/896596 Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'app-misc/rmlint')
-rw-r--r--app-misc/rmlint/files/rmlint-2.10.1-fix-gui-install.patch11
-rw-r--r--app-misc/rmlint/rmlint-2.10.1-r1.ebuild (renamed from app-misc/rmlint/rmlint-2.10.1.ebuild)8
2 files changed, 16 insertions, 3 deletions
diff --git a/app-misc/rmlint/files/rmlint-2.10.1-fix-gui-install.patch b/app-misc/rmlint/files/rmlint-2.10.1-fix-gui-install.patch
new file mode 100644
index 000000000000..2ae13cd4abb0
--- /dev/null
+++ b/app-misc/rmlint/files/rmlint-2.10.1-fix-gui-install.patch
@@ -0,0 +1,11 @@
+--- a/gui/setup.py
++++ b/gui/setup.py
+@@ -19,7 +19,7 @@ def read_version():
+ with open('../.version', 'r') as handle:
+ version_string = handle.read()
+
+- return version_string.strip()
++ return version_string.split()[0]
+
+ class install_glib_resources(install):
+ user_options = install.user_options + [
diff --git a/app-misc/rmlint/rmlint-2.10.1.ebuild b/app-misc/rmlint/rmlint-2.10.1-r1.ebuild
index 838041b4fc6e..0bb48648fcc8 100644
--- a/app-misc/rmlint/rmlint-2.10.1.ebuild
+++ b/app-misc/rmlint/rmlint-2.10.1-r1.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{9..10} )
+PYTHON_COMPAT=( python3_{9..11} )
-inherit gnome2-utils python-single-r1 scons-utils toolchain-funcs xdg-utils
+inherit gnome2-utils python-single-r1 scons-utils toolchain-funcs
DESCRIPTION="Extremely fast tool to remove duplicates and other lint from your filesystem"
HOMEPAGE="https://rmlint.readthedocs.io/"
@@ -70,6 +70,8 @@ PATCHES=(
"${FILESDIR}/${PN}-2.10.1-x86-fix-size.patch"
# https://github.com/sahib/rmlint/pull/526
"${FILESDIR}/${PN}-2.10.1-fix-cc.patch"
+ # https://github.com/sahib/rmlint/issues/608#issuecomment-1406811107
+ "${FILESDIR}/${PN}-2.10.1-fix-gui-install.patch"
)
src_prepare() {