summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAric Belsito <lluixhi@gmail.com>2016-07-14 15:37:21 -0700
committerPatrice Clement <monsieurp@gentoo.org>2016-08-30 17:29:30 +0200
commitf91bd4a5dac8cb786cb607dd75b8cce8514c2c24 (patch)
treed291dd9911e0eecd8fec0a313b548fca097e3d79 /app-misc/openastro-data
parentapp-vim/nginx-syntax: add ~x86-fbsd keyword. (diff)
downloadgentoo-f91bd4a5dac8cb786cb607dd75b8cce8514c2c24.tar.gz
gentoo-f91bd4a5dac8cb786cb607dd75b8cce8514c2c24.tar.bz2
gentoo-f91bd4a5dac8cb786cb607dd75b8cce8514c2c24.zip
app-misc/openastro{,-data}, dev-python/pyswisseph: new package.
openastro is an open source astrology program written in Python. Gentoo-Bug: https://bugs.gentoo.org/586110 Closes: https://github.com/gentoo/gentoo/pull/1888 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'app-misc/openastro-data')
-rw-r--r--app-misc/openastro-data/Manifest1
-rw-r--r--app-misc/openastro-data/metadata.xml19
-rw-r--r--app-misc/openastro-data/openastro-data-1.6.ebuild24
3 files changed, 44 insertions, 0 deletions
diff --git a/app-misc/openastro-data/Manifest b/app-misc/openastro-data/Manifest
new file mode 100644
index 000000000000..aa7eb48e2f73
--- /dev/null
+++ b/app-misc/openastro-data/Manifest
@@ -0,0 +1 @@
+DIST openastro.org-data_1.6.orig.tar.gz 13603001 SHA256 1ea8a80ebb6077f2b5f4abafe532037a2bf6ff060afba5419cf1f5aaa0890370 SHA512 99f3b6db61e27ccf04a7e0ff3ba7da45b889e1177bfbc1192af1929fca7255dc2b18a4ac9eb536af9ceb11e7722e0a3420102c7e45a6c839abe87734e8be6591 WHIRLPOOL 33486b0c9c7b3b243acda872d5a8812a329ec2963305098a5bace73dadfc99b442a6d338ca98e305932a63298b4ea6b1550308fe22eaee243dedc825694ffbbc
diff --git a/app-misc/openastro-data/metadata.xml b/app-misc/openastro-data/metadata.xml
new file mode 100644
index 000000000000..b433d43ad5ce
--- /dev/null
+++ b/app-misc/openastro-data/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>lluixhi@gmail.com</email>
+ <name>Aric Belsito</name>
+ </maintainer>
+ <upstream>
+ <maintainer status="active">
+ <email>devel@openastro.org</email>
+ <name>Pelle van der Scheer</name>
+ </maintainer>
+ <bugs-to>https://bugs.launchpad.net/openastro.org</bugs-to>
+ </upstream>
+</pkgmetadata>
diff --git a/app-misc/openastro-data/openastro-data-1.6.ebuild b/app-misc/openastro-data/openastro-data-1.6.ebuild
new file mode 100644
index 000000000000..006d8ab4f71e
--- /dev/null
+++ b/app-misc/openastro-data/openastro-data-1.6.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+MY_PN=${PN/-data}
+MY_PN=${MY_PN}.org-data
+
+DESCRIPTION="OpenAstro data files, ephemeris, famous people database, geo database"
+HOMEPAGE="http://openastro.org"
+SRC_URI="http://ppa.launchpad.net/pellesimon/ubuntu/pool/main/o/${MY_PN}/${MY_PN}_${PV}.orig.tar.gz"
+KEYWORDS="~amd64 ~x86"
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_PN}-${PV}