summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2018-07-30 14:30:02 +0200
committerManuel Rüger <mrueg@gentoo.org>2018-07-30 14:30:02 +0200
commit9ff886abc973f4d3f7e4e690eac647343484aef7 (patch)
treef89c3e45450eaa31a6f46475e713e8686aa9f1d6 /app-misc/go-jira
parentdev-ros/amcl: Remove old (diff)
downloadgentoo-9ff886abc973f4d3f7e4e690eac647343484aef7.tar.gz
gentoo-9ff886abc973f4d3f7e4e690eac647343484aef7.tar.bz2
gentoo-9ff886abc973f4d3f7e4e690eac647343484aef7.zip
app-misc/go-jira: Version bump to 1.0.18
Package-Manager: Portage-2.3.43, Repoman-2.3.10
Diffstat (limited to 'app-misc/go-jira')
-rw-r--r--app-misc/go-jira/Manifest1
-rw-r--r--app-misc/go-jira/go-jira-1.0.18.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/app-misc/go-jira/Manifest b/app-misc/go-jira/Manifest
index f9ce2192a6ba..e58cb797e816 100644
--- a/app-misc/go-jira/Manifest
+++ b/app-misc/go-jira/Manifest
@@ -1 +1,2 @@
DIST go-jira-1.0.17.tar.gz 1382832 BLAKE2B 17cada8407b5136ec3b84d9f43c67cb25a893bdfeae7309bc15eb479954ba3ce7df4bc1248782a0bd1874b08b48a68a8e69a1651960c10d6260b22c63a0a8147 SHA512 8abbe6233413d12495399446adbb02d6a37aedf2a2b1a860c403b6e210f5e1f44fa01dfe937d86241486cb4a56c52530eff1c582d59f5ddde4b466a6908fd020
+DIST go-jira-1.0.18.tar.gz 1296612 BLAKE2B f88bbb57e3b775f8b2426574dd104d3b4683dfe90a991bf2f49eb1ae69b8281e0a381a30d42dcac1630e19482e2f04fb323098f379aca40f420644ba4e8e52ff SHA512 8421f176207f7b836d261734065c92aa43909564c0265792be0c2cf14a3751a800c4840bc93f860eee8433594542f4dc5ca57ae4bb3808b8282a9ed991418f5a
diff --git a/app-misc/go-jira/go-jira-1.0.18.ebuild b/app-misc/go-jira/go-jira-1.0.18.ebuild
new file mode 100644
index 000000000000..513090c2a8f9
--- /dev/null
+++ b/app-misc/go-jira/go-jira-1.0.18.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+EGO_PN="gopkg.in/Netflix-Skunkworks/go-jira.v1"
+
+inherit golang-build golang-vcs-snapshot
+
+KEYWORDS="~amd64"
+
+DESCRIPTION="A simple JIRA commandline client in Go"
+HOMEPAGE="https://github.com/Netflix-Skunkworks/go-jira"
+SRC_URI="https://github.com/Netflix-Skunkworks/go-jira/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+src_compile() {
+ pushd src/${EGO_PN} || die
+ GOPATH="${WORKDIR}/${P}" go build -v -o jira cmd/jira/main.go || die
+ popd || die
+}
+
+src_install() {
+ dobin src/${EGO_PN}/jira
+ dodoc src/${EGO_PN}/{CHANGELOG,README}.md
+}