summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2023-07-21 18:48:20 -0400
committerMatt Turner <mattst88@gentoo.org>2023-07-21 18:55:01 -0400
commit745f35fe65bc4263d4ad3e6cfebba44562f8f762 (patch)
treea7086bd5290079f2e6dcf0a74cffd4d09f49f8ee /app-misc/gnote
parentmedia-libs/glu: Version bump to 9.0.3 (diff)
downloadgentoo-745f35fe65bc4263d4ad3e6cfebba44562f8f762.tar.gz
gentoo-745f35fe65bc4263d4ad3e6cfebba44562f8f762.tar.bz2
gentoo-745f35fe65bc4263d4ad3e6cfebba44562f8f762.zip
app-misc/gnote: Version bump to 44.1
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'app-misc/gnote')
-rw-r--r--app-misc/gnote/Manifest1
-rw-r--r--app-misc/gnote/gnote-44.1.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/app-misc/gnote/Manifest b/app-misc/gnote/Manifest
index cae3aea18945..644a03bd79a0 100644
--- a/app-misc/gnote/Manifest
+++ b/app-misc/gnote/Manifest
@@ -1 +1,2 @@
DIST gnote-44.0.tar.xz 3330052 BLAKE2B 5b8a45de08419cdc8b22596fc4019ddd18edf7103dda5d51fe87153e624a3623a3b5af1e65ee15bc0afbefc13400ceddebc740fc34ff3675f4e0fa3a68ae87d5 SHA512 95299d811372f9c011e2966cd0fcb770830d691a85e390fbeb0500ff2db394301d0aeb478c622af1a8caf54d07cb15243c65e73809e02ae36407ef5006e636bb
+DIST gnote-44.1.tar.xz 3330072 BLAKE2B ff86fa34bdfff61eceb25abef1c73377f888082e70e539172849bf9425eada1c11000c1a75f69eb74fdbc2fc6d45ad3c58c843bf769279a026dd5298a07abc68 SHA512 89364d161d6ecc11822b89dec0353d0e20bc08d883573f324e4980ff2420361ddeb326213eb668fba4ce8de7d5d9668a1a058666ad2b81658ef94f8a65b87363
diff --git a/app-misc/gnote/gnote-44.1.ebuild b/app-misc/gnote/gnote-44.1.ebuild
new file mode 100644
index 000000000000..d23217101987
--- /dev/null
+++ b/app-misc/gnote/gnote-44.1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome2 meson readme.gentoo-r1
+
+DESCRIPTION="Desktop note-taking application"
+HOMEPAGE="https://wiki.gnome.org/Apps/Gnote"
+
+LICENSE="GPL-3+ FDL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ >=dev-libs/glib-2.62:2[dbus]
+ >=dev-cpp/glibmm-2.62.0:2
+ >=dev-cpp/gtkmm-3.22.20:3.0
+ >=app-crypt/libsecret-0.8
+ >=dev-libs/libxml2-2:2
+ dev-libs/libxslt
+ >=sys-apps/util-linux-2.16
+ >=app-text/gspell-1.6.0:=
+ test? ( dev-libs/unittest++ )
+"
+RDEPEND="${DEPEND}
+ gnome-base/gsettings-desktop-schemas
+"
+BDEPEND="
+ dev-util/itstool
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+
+ # Build system requires UnitTest++ >=1.5.1, but the .pc file doesn't
+ # specify a version
+ sed -i -e "/UnitTest++/ s/version: [^,]*,//" meson.build || die
+ if ! use test; then
+ sed -i -e "/unit_test_pp/ s/ = .*/ = disabler()/" meson.build || die
+ fi
+
+ if has_version net-fs/wdfs; then
+ DOC_CONTENTS="You have net-fs/wdfs installed. app-misc/gnote will use it to
+ synchronize notes."
+ else
+ DOC_CONTENTS="Gnote can use net-fs/wdfs to synchronize notes.
+ If you want to use that functionality just emerge net-fs/wdfs.
+ Gnote will automatically detect that you did and let you use it."
+ fi
+}
+
+src_install() {
+ meson_src_install
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ readme.gentoo_print_elog
+}