summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-misc/gcstar/gcstar-1.7.0.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-misc/gcstar/gcstar-1.7.0.ebuild')
-rw-r--r--app-misc/gcstar/gcstar-1.7.0.ebuild114
1 files changed, 114 insertions, 0 deletions
diff --git a/app-misc/gcstar/gcstar-1.7.0.ebuild b/app-misc/gcstar/gcstar-1.7.0.ebuild
new file mode 100644
index 000000000000..b89ea30b2b6f
--- /dev/null
+++ b/app-misc/gcstar/gcstar-1.7.0.ebuild
@@ -0,0 +1,114 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit eutils fdo-mime gnome2-utils
+
+DESCRIPTION="Manage your collections of movies, games, books, music and more"
+HOMEPAGE="http://www.gcstar.org/"
+SRC_URI="http://download.gna.org/gcstar/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="cddb gnome mp3 spell stats tellico vorbis"
+
+RDEPEND="dev-lang/perl
+ dev-perl/Archive-Zip
+ dev-perl/DateTime-Format-Strptime
+ dev-perl/gtk2-perl
+ dev-perl/HTML-Parser
+ dev-perl/libwww-perl
+ dev-perl/URI
+ dev-perl/XML-Parser
+ dev-perl/XML-Simple
+ virtual/perl-Archive-Tar
+ virtual/perl-Encode
+ virtual/perl-Getopt-Long
+ virtual/perl-File-Path
+ virtual/perl-File-Spec
+ virtual/perl-File-Temp
+ virtual/perl-IO-Compress
+ virtual/perl-libnet
+ virtual/perl-Storable
+ virtual/perl-Time-Piece
+
+ cddb? ( dev-perl/Net-FreeDB )
+ gnome? ( dev-perl/gnome2-vfs-perl )
+ mp3? ( dev-perl/MP3-Info dev-perl/MP3-Tag )
+ spell? ( dev-perl/gtk2-spell )
+ stats? ( dev-perl/Date-Calc
+ dev-perl/GD[png,truetype] )
+ tellico? ( virtual/perl-Digest-MD5
+ virtual/perl-MIME-Base64 )
+ vorbis? ( dev-perl/Ogg-Vorbis-Header-PurePerl )"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-1.4.0-man.patch"
+ epatch "${FILESDIR}/${P}-gcstar.desktop.patch"
+}
+
+src_install() {
+ if [[ -n ${LINGUAS+set} ]]; then
+ # LINGUAS is set, let's try to respect it.
+ pushd lib/gcstar/GCLang > /dev/null
+
+ mkdir tmp || die "mkdir failed"
+ mv ?? ZH_CN tmp || die "mv 1 failed"
+ # English version should be always available so we will keep it
+ mv tmp/EN . || die "mv 2 failed"
+
+ for x in ${LINGUAS}; do
+ if [[ ${x} = "zh_CN" ]]; then
+ mv "tmp/ZH_CN" . || die "mv 3 failed"
+ else
+ # GCstar uses upper-case, 2-letter language codes
+ d=$(echo ${x} | tr '[:lower:]' '[:upper:]' | sed -e 's:_.*::')
+ if [[ -d "tmp/${d}" ]]; then
+ mv "tmp/${d}" . || die "mv 5 failed"
+ fi
+ fi
+ done
+
+ rm -rf tmp
+ popd > /dev/null
+ fi
+
+ # Yes, ED *is* needed here. gcstar's install lacks any concept of DESTDIR.
+ ./install --prefix="${ED}usr" \
+ --noclean --nomenu || die "install script failed"
+
+ domenu share/applications/gcstar.desktop
+ for size in 16 22 24 32 36 48 64 72 96 128 256
+ do
+ insinto /usr/share/icons/hicolor/${size}x${size}/apps
+ newins share/gcstar/icons/gcstar_${size}x${size}.png gcstar.png
+ done
+ insinto /usr/share/icons/hicolor/scalable/apps
+ newins share/gcstar/icons/gcstar_scalable.svg gcstar.svg
+ insinto /usr/share/mime/packages
+ doins share/applications/gcstar.xml
+
+ dodoc CHANGELOG README README.fr
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+ gnome2_icon_cache_update
+}