summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-misc/g15stats
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-misc/g15stats')
-rw-r--r--app-misc/g15stats/Manifest1
-rw-r--r--app-misc/g15stats/files/g15stats-1.9.7.confd20
-rw-r--r--app-misc/g15stats/files/g15stats-1.9.7.initd24
-rw-r--r--app-misc/g15stats/g15stats-1.9.7.ebuild49
-rw-r--r--app-misc/g15stats/metadata.xml14
5 files changed, 108 insertions, 0 deletions
diff --git a/app-misc/g15stats/Manifest b/app-misc/g15stats/Manifest
new file mode 100644
index 000000000000..de6272512f6d
--- /dev/null
+++ b/app-misc/g15stats/Manifest
@@ -0,0 +1 @@
+DIST g15stats-1.9.7.tar.bz2 24103 SHA256 55669ffc080091beb59934e3cdd54e305da340f090a0e4ca6289d3ddc041a3d5 SHA512 de447dfddd563513205b29b3611b0558371b2a7fbe7bf3aa11cd997c0ee2767b3aba05df9745d15e5c0b81382b96163fb7d33ba6a77e04ac817c7a8e26e228ff WHIRLPOOL abe464c0ea44b14a5101a023d3de52907f21c91828b6791b678e6efc4875b129d7a75cb554a21e09a046a52da72b083a9df1c0f1a5a4f284572d954bcb4e3dda
diff --git a/app-misc/g15stats/files/g15stats-1.9.7.confd b/app-misc/g15stats/files/g15stats-1.9.7.confd
new file mode 100644
index 000000000000..4bf61c238488
--- /dev/null
+++ b/app-misc/g15stats/files/g15stats-1.9.7.confd
@@ -0,0 +1,20 @@
+# /etc/conf.d/g15stats: Configuration for the G15 stats
+
+#Gather statistics from named interface (ie eth0)
+#Network Screen displays Total bytes In/Out, history graph, Peak speed.
+IFACE="eth0"
+
+# Please see g15stats --help for meanings
+#TEMP_INPUT=1
+#GLOBAL_TEMP_INPUT=1
+#FAN_INPUT=1
+
+# please see g15stats --help for all options
+# As of 1.9.7, the options where:
+# --unicore
+# --net-scale-absolute
+# --info-rotate
+# --variable-cpu
+# --refresh
+# --disable-freq
+EXTRA_OPTS="${IFACE:+--interface} ${IFACE} ${TEMP_INPUT:+--temperature} ${TEMP_INPUT} ${GLOBAL_TEMP_INPUT:+--global-temp} ${GLOBAL_TEMP_INPUT} ${FAN_INPUT:+--fan} ${FAN_INPUT}"
diff --git a/app-misc/g15stats/files/g15stats-1.9.7.initd b/app-misc/g15stats/files/g15stats-1.9.7.initd
new file mode 100644
index 000000000000..57fedd4ae6f4
--- /dev/null
+++ b/app-misc/g15stats/files/g15stats-1.9.7.initd
@@ -0,0 +1,24 @@
+#!/sbin/runscript
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+PIDFILE=/var/run/${SVCNAME}.pid
+
+depend() {
+ need g15daemon
+ after xdm
+}
+
+start() {
+ ebegin "Starting ${SVCNAME}"
+ start-stop-daemon --start --background --make-pidfile --pidfile ${PIDFILE} --exec \
+ /usr/bin/g15stats -- "${EXTRA_OPTS}"
+ eend $?
+}
+
+stop() {
+ ebegin "Stoping ${SVCNAME}"
+ start-stop-daemon --stop --pidfile ${PIDFILE} --name g15stats
+ eend $?
+}
diff --git a/app-misc/g15stats/g15stats-1.9.7.ebuild b/app-misc/g15stats/g15stats-1.9.7.ebuild
new file mode 100644
index 000000000000..0c34a10e6574
--- /dev/null
+++ b/app-misc/g15stats/g15stats-1.9.7.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+DESCRIPTION="CPU, memory, swap, network stats for G15 Keyboard"
+HOMEPAGE="http://g15daemon.sourceforge.net/"
+SRC_URI="mirror://sourceforge/g15daemon/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=app-misc/g15daemon-1.9.0
+ dev-libs/libg15
+ dev-libs/libg15render
+ sys-libs/zlib
+ gnome-base/libgtop"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ sh autogen.sh
+}
+
+src_configure() {
+ export CPPFLAGS=$CFLAGS
+ econf
+}
+
+src_compile() {
+ emake
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ rm "$D"/usr/share/doc/${P}/{COPYING,NEWS}
+
+ newconfd "${FILESDIR}/${PN}-1.9.7.confd" ${PN}
+ newinitd "${FILESDIR}/${PN}-1.9.7.initd" ${PN}
+}
+
+pkg_postinst() {
+ elog "Remember to set the interface you want monitored in"
+ elog "/etc/conf.d/g15stats"
+}
diff --git a/app-misc/g15stats/metadata.xml b/app-misc/g15stats/metadata.xml
new file mode 100644
index 000000000000..4aeeac5bc12b
--- /dev/null
+++ b/app-misc/g15stats/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>robbat2@gentoo.org</email>
+ </maintainer>
+ <maintainer>
+ <email>polynomial-c@gentoo.org</email>
+ <name>Lars Wendler</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">g15daemon</remote-id>
+ </upstream>
+</pkgmetadata>