summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2016-12-15 01:21:29 -0500
committerTim Harder <radhermit@gentoo.org>2016-12-15 01:23:27 -0500
commit04e5b2313d40dbcebc056b944b7e6d611402d877 (patch)
tree1848dc0045cc834e0410368200aac3013963a9d1 /app-misc/evemu/evemu-2.6.0.ebuild
parentdev-ruby/ruby-gnome2: drop obsolete webkit versions, bug 573094 (diff)
downloadgentoo-04e5b2313d40dbcebc056b944b7e6d611402d877.tar.gz
gentoo-04e5b2313d40dbcebc056b944b7e6d611402d877.tar.bz2
gentoo-04e5b2313d40dbcebc056b944b7e6d611402d877.zip
app-misc/evemu: version bump to 2.6.0
Diffstat (limited to 'app-misc/evemu/evemu-2.6.0.ebuild')
-rw-r--r--app-misc/evemu/evemu-2.6.0.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/app-misc/evemu/evemu-2.6.0.ebuild b/app-misc/evemu/evemu-2.6.0.ebuild
new file mode 100644
index 000000000000..18259c7e5c96
--- /dev/null
+++ b/app-misc/evemu/evemu-2.6.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils python-single-r1
+
+DESCRIPTION="tools and bindings for kernel evdev device emulation, data capture, and replay"
+HOMEPAGE="https://www.freedesktop.org/wiki/Evemu/"
+SRC_URI="https://www.freedesktop.org/software/${PN}/${P}.tar.xz"
+
+LICENSE="LGPL-3 GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="python static-libs"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="python? ( ${PYTHON_DEPS} )
+ >=dev-libs/libevdev-1.2.99.902"
+DEPEND="app-arch/xz-utils
+ ${RDEPEND}"
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_enable python python-bindings)
+}
+
+src_test() {
+ if use python ; then
+ if [[ ! ${EUID} -eq 0 ]] || has sandbox $FEATURES || has usersandbox $FEATURES ; then
+ ewarn "Tests require userpriv, sandbox, and usersandbox to be disabled in FEATURES."
+ else
+ emake check
+ fi
+ fi
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}