summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-misc/color
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-misc/color')
-rw-r--r--app-misc/color/Manifest1
-rw-r--r--app-misc/color/color-1.2-r1.ebuild39
-rw-r--r--app-misc/color/files/1.2-ldflags.patch23
-rw-r--r--app-misc/color/metadata.xml11
4 files changed, 74 insertions, 0 deletions
diff --git a/app-misc/color/Manifest b/app-misc/color/Manifest
new file mode 100644
index 000000000000..5d42785a35d7
--- /dev/null
+++ b/app-misc/color/Manifest
@@ -0,0 +1 @@
+DIST color-1.2.tar.gz 10040 SHA256 7862fffb3d948b47435803461732f7dea4af64c2714219df7f929e20cb818bd9 SHA512 58f7d379bca3352b2e39eab83d2fa5891df86c45722541eb810becce813c8e866f28b856ed244a75b173f0dab5dbdc84ceb91d96175dcd2484e29abb98ba87ac WHIRLPOOL 9fbde967107e278ef2a65418cce3011bf4c7ab78b6a2d620e83d2524362b1456edd45479c9dc4308a5a69c0721f90bb061842589086297afce0652250890b5ae
diff --git a/app-misc/color/color-1.2-r1.ebuild b/app-misc/color/color-1.2-r1.ebuild
new file mode 100644
index 000000000000..98db130dd51b
--- /dev/null
+++ b/app-misc/color/color-1.2-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Easily add ANSI colouring to shell scripts"
+HOMEPAGE="http://www.runslinux.net/?page_id=10"
+SRC_URI="http://runslinux.net/projects/color/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ~ia64 ~mips ppc ppc64 sparc x86"
+IUSE=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-ldflags.patch
+ tc-export CC
+}
+
+src_install() {
+ dobin color || die "dobin failed"
+ dodoc CHANGELOG README || die
+
+ # symlink for british users.
+ dosym color /usr/bin/colour || die
+}
+
+pkg_postinst() {
+ elog "For information on using colour in your shell scripts,"
+ elog "run \`color\` without any arguments."
+ elog
+ elog "To see all the colours available, use this command"
+ elog " $ color --list"
+ elog
+ elog "More examples are available in ${EPREFIX}/usr/share/doc/${PF}."
+}
diff --git a/app-misc/color/files/1.2-ldflags.patch b/app-misc/color/files/1.2-ldflags.patch
new file mode 100644
index 000000000000..9c95eda73b0e
--- /dev/null
+++ b/app-misc/color/files/1.2-ldflags.patch
@@ -0,0 +1,23 @@
+diff --git a/Makefile b/Makefile
+index 79c5b33..452e091 100644
+--- a/Makefile
++++ b/Makefile
+@@ -1,4 +1,4 @@
+-CC = cc
++CC ?= cc
+ #CFLAGS = -W -Wall -O2 -g
+ INCLUDE = $(wildcard *.h)
+ OBJS = color.o
+@@ -6,8 +6,11 @@ EXE = color
+
+ all: $(EXE)
+
++OBJS: color.c
++ $(CC) $(CFLAGS) -c $^ $@
++
+ $(EXE): $(OBJS)
+- $(CC) $(CFLAGS) -o $@ $^
++ $(CC) $(LDFLAGS) -o $@ $^
+
+ install: all
+ cp $(EXE) /usr/local/bin
diff --git a/app-misc/color/metadata.xml b/app-misc/color/metadata.xml
new file mode 100644
index 000000000000..c1bead0461d4
--- /dev/null
+++ b/app-misc/color/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>shell-tools</herd>
+ <longdescription lang="en">
+ Color is a nifty little utility that you can call from shell scripts,
+ that will let you easily use ANSI escape codes (for colors, bold,
+ underline, etc) to your shell scripts without having to memorize escape
+ sequences and type it every time you want a little red...
+ </longdescription>
+</pkgmetadata>