summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-02-20 21:25:07 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-02-23 20:52:34 +0100
commit65af20cf41735a2bb5d80ce4fa1c22434fcc3458 (patch)
tree9a53d0654a7c8d5624793467b4e731d9106cc4a8 /app-misc/ckb
parentsci-electronics/fritzing: Drop 0.9.4-r1 (diff)
downloadgentoo-65af20cf41735a2bb5d80ce4fa1c22434fcc3458.tar.gz
gentoo-65af20cf41735a2bb5d80ce4fa1c22434fcc3458.tar.bz2
gentoo-65af20cf41735a2bb5d80ce4fa1c22434fcc3458.zip
app-misc/ckb: Add dev-libs/quazip slot op
Build system already supports new QuaZip::Quazip target. Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-misc/ckb')
-rw-r--r--app-misc/ckb/ckb-0.4.3-r2.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/app-misc/ckb/ckb-0.4.3-r2.ebuild b/app-misc/ckb/ckb-0.4.3-r2.ebuild
new file mode 100644
index 000000000000..296ba6dabec8
--- /dev/null
+++ b/app-misc/ckb/ckb-0.4.3-r2.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg cmake
+
+DESCRIPTION="Corsair K65/K70/K95 Driver"
+HOMEPAGE="https://github.com/ckb-next/ckb-next"
+SRC_URI="https://github.com/ckb-next/ckb-next/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-libs/libdbusmenu-qt
+ dev-libs/quazip:0=
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ media-sound/pulseaudio
+ virtual/libudev:=
+ x11-libs/libX11
+ x11-libs/libxcb:=
+ x11-libs/xcb-util-wm"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-qt/linguist-tools:5"
+
+S="${WORKDIR}/${PN}-next-${PV}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DDISABLE_UPDATER=yes
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+ dodoc CHANGELOG.md
+
+ newinitd "${FILESDIR}"/ckb.initd ckb-daemon
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ elog "The ckb daemon will have to be started before use:"
+ elog
+ elog "OpenRC:"
+ elog "# rc-service ckb start"
+ elog
+ elog "Systemd:"
+ elog "# systemctl start ckb-next-daemon"
+ fi
+}