summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYumi Tanaka <myknt1184@gmail.com>2019-07-26 07:03:56 +0000
committerAlice Ferrazzi <alicef@gentoo.org>2019-08-10 05:55:53 +0900
commit94642b1c49e02be215202406a8cbda8b1fed8633 (patch)
treebbaf6735d56419fb2105b0b534c0d44f6eb017ad /app-misc/cfiles/cfiles-1.5.ebuild
parentpackage.mask: extend binutils mask to newer versions, bug 682698 (diff)
downloadgentoo-94642b1c49e02be215202406a8cbda8b1fed8633.tar.gz
gentoo-94642b1c49e02be215202406a8cbda8b1fed8633.tar.bz2
gentoo-94642b1c49e02be215202406a8cbda8b1fed8633.zip
app-misc/cfiles: New ebuild
It is a vim like terminal file manager, written in C using the ncurses library. Package-Manager: Portage-2.3.62, Repoman-2.3.14 Signed-off-by: Yumi Tanaka <yumi.tanaka@miraclelinux.com> Signed-off-by: Alice Ferrazzi <alicef@gentoo.org>
Diffstat (limited to 'app-misc/cfiles/cfiles-1.5.ebuild')
-rw-r--r--app-misc/cfiles/cfiles-1.5.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-misc/cfiles/cfiles-1.5.ebuild b/app-misc/cfiles/cfiles-1.5.ebuild
new file mode 100644
index 000000000000..9c770c677606
--- /dev/null
+++ b/app-misc/cfiles/cfiles-1.5.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A ncurses file manager written in C with vim like keybindings"
+HOMEPAGE="https://github.com/mananapr/cfiles"
+SRC_URI="https://github.com/mananapr/cfiles/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ sys-libs/ncurses:=
+ app-text/poppler[utils]
+"
+RDEPEND="${DEPEND}"
+
+src_install(){
+ dobin cfiles
+ dobin scripts/displayimg_uberzug
+ dobin scripts/clearimg_uberzug
+ dobin scripts/displayimg
+ doman cfiles.1
+}